DNS Woes

Discussion in 'Installation/Configuration' started by mrbcast, Nov 15, 2020.

  1. mrbcast

    mrbcast New Member

    So I have a fully working multi server setup on ubuntu 18 in three proxmox containers. The first is the master server with web, mail, dns, firewall, etc. The second and third are dns only servers. Ever since I set this thing up the dns will get some updates, but not others. It seems random enough. I have confirmed that they are logging in to the master ok and have permissions to get info, but they will update when I setup a new domain, but then when I update a domain I have to usually go in and manually do a file in order to get them updated. It has been very frustrating and I know I am not putting all the info in here you need, so please tell me what I need to give to help me figure this out. Is there another way to keep them updated? Maybe make a script to update on cron and then reset bind? I just need to get this working. Thanks to Til or whomever responds. I still love ispconfig. It has been a gamechanger for me. Thanks and have a blessed day.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    The second and third servers are setup as kitties servers? Or you are configuring slave zones on then?
     
  3. mrbcast

    mrbcast New Member

    the second and third servers are dns servers only.
     
  4. mrbcast

    mrbcast New Member

    What are kitties servers?
     
  5. mrbcast

    mrbcast New Member

    Ok. So I found a little hint from another issue with Till. The solution to my problem was to recheck the mirror server option on each dns server. I had redone both 8 months ago trying to fix another issue and forgot to go in and recheck that option. They are both now working perfectly. Thanks for your help.
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Hah, sorry, phone keyboards can sure be fun...

    I believe that should be "mirrored" not "kitties"
     
    Th0m likes this.

Share This Page