DNS wizard problem

Discussion in 'Installation/Configuration' started by Dezso Markon, Dec 1, 2020.

  1. Dezso Markon

    Dezso Markon New Member

    Hi,
    After a successfully installation I have modified my DNS template as follows:

    [ZONE]
    origin={DOMAIN}.
    ns={NS1}.
    mbox={EMAIL}.
    refresh=7200
    retry=540
    expire=604800
    minimum=3600
    ttl=3600

    [DNS_RECORDS]
    A|{DOMAIN}.|{IP}|0|3600
    A|ns|{IP}|0|3600
    A|www|{IP}|0|3600
    A|ftp|{IP}|0|3600
    A|mail|{IP}|0|3600
    NS|{DOMAIN}.|{NS1}.|0|3600
    NS|{DOMAIN}.|{NS2}.|0|3600
    MX|{DOMAIN}.|mail.{DOMAIN}.|10|3600

    This template works without problem on another server with ISPConfig 3.1.15p3, however on current installation with the latest version (3.2.1) I can't save my DNS records created with the wizard. After filling all the records and clicking on the Create new DNS zone button I get back to the DNS zones page, but there are no new records listed. The mysql table is also empty. If I create the DNS entry manually it works. So I suppose there is something wrong with this template on ISPConfig 3.2.1. What could be wrong? Please help!

    ISPConfig 3.2.1
    Centos 8.2.2004
    Apache 2.4.37
    PHP 7.2.24
    mysql Ver 15.1 Distrib 10.3.17-MariaDB
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You have to add
    Code:
    dnssec_wanted=n
    under the [ZONE] variables for every template. We will fix this so it is not necessary in 3.2.2.

    You can also set it to y if you want to enable DNSSEC by default.
     
    ahrasis and gregory121 like this.
  3. Dezso Markon

    Dezso Markon New Member

    Hi,
    Thank you! Works as expected.
     
    Th0m likes this.
  4. gregory121

    gregory121 New Member

    You saved me a lot of hair loss :)
     
    Th0m likes this.
  5. jnewman67

    jnewman67 Member

    (ISPConfig 3.2.5, CentOS)
    Ok, so I have a suggestion for the DNS-Wizard Templates. Seems like they could be a little more powerful...
    I get that the {IP} indicates this will be replaced with the value entered in the IP Address field when processing the form.
    How about this - if the {IP} in the template were replaced with an actual IP address, how about prefilling the IP Address field when the template is chosen (or initially when the Default template is loaded)? and in the case where data already exists in a field, and then the template is changed, replace that data if indicated by the template.
    Same for the other bracket variables. That would save a LOT of time when doing repetitive site/dns zone creations.
    Brackets = post-processing, no brackets = pre-processing.
    I honestly thought this was how they were supposed to work, only figured out it was post processing afterwards when I couldn't get them to show up when changing templates :)
    If this should've been put somewhere else, point me in that direction, I'll add it there.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can simply add a new template where you fill in the IP directly in the template instead of using the IP placeholder and disable the IP input field in the template settings. That is how it is used when you do mass inserts or when you have just one or a few web servers.
     
    ahrasis likes this.
  7. jnewman67

    jnewman67 Member

    Ahhhh!!
    That's makes sense :) I wondered why the checkboxes were there, I didn't get that usage from the manual.
    Thank you!
     

Share This Page