DNS Weird Problem

Discussion in 'Installation/Configuration' started by sheshes, Mar 9, 2010.

  1. sheshes

    sheshes Member

    Hello guys, I have been checking my dns records for each newly added domain with intodns.com which never gave me any sort of problems besides my nameserver beeing at the same subnet and a ptr record which I am aware of and as far as I know, don't really limit the functionality of the websites.

    But as of recently I have been getting complaints about problems accessing the sites while the sites are up. When this happened I checked that i could remotely login to the ISPConfig 3 panel and worked fine.

    So I did some tests with intodns.com for all of the domains, and guess what all my added domains have the following error:

    WWW A Record ERROR: I could not get any A records for www.xxxxxxx.net!

    (I only do a cache request, if you recently added a WWW A record, it might not show up here.)

    The strange thing is that the FQDN domain I have the server on and it's the domain I am using to access my hosting panel is setup fine and NO errors about the www A record appear after testing it with intodns.com

    I have tried removing the whole zone for each domain and readding everything up using the wizard but I am still getting the same results.

    Any clues about what's happening here?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. sheshes

    sheshes Member

    Thanks till, I have tested the domains with dig but without the @ infront of the ns1.mydomain.com and I got different answers for most of my domains.

    For one I get NOERROR, for the other SERVFAIL and for the server's one NXDOMAIN.

    The only one which appears to be working as it should is the server's one and note that all of the domains have the same records.

    I am really in a desperate situation, I can't figure it out
  4. falko

    falko Super Moderator ISPConfig Developer

    What are the authoritative nameservers for your domain? You can find that out by running
    dig ns yourdomain.com
    Did you create the A records on these nameservers, or somewhere else?
  5. sheshes

    sheshes Member

    Thanks for your quick response. I have tried what you've told me and sometimes I get a response showing the 2 nameserver but sometimes nothing shows up.

    I have created 2 hosts ns1 and ns2 on my domain in Godaddy pointing at my server's ip. Then I just use ISPconfig 3 panel to configure my dns per domain.

    Am i missing anything?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If it works only sometimes, then there is most likely a problem with the snc of primary and secondary dns. Please test the primary and secondary dns separately with:

    dig ns @ns1.yourdomain.com yourdomain.com


    dig ns @ns2.yourdomain.com yourdomain.com
  7. sheshes

    sheshes Member

    Ok I tried testing both nameservers for all my setup domains/websites

    for dig ns @ns1.yourdomain.com yourdomain.com
    I get an answer

    xxxxxxx.com. 86400 IN NS ns1.xxxxxxxx.com.
    xxxxxxx.com. 86400 IN NS ns2.xxxxxxxx.com.

    but when I try the same for dig ns @ns2.yourdomain.com yourdomain.com

    I get

    dig: couldn't get address for 'ns2.xxxxxxxxxxxx.com': not found

    It looks like the second nameserver is not working. All my settings are correct and haven't touched anything regarding the nameserver dns which is done in godaddy. I checked if I haven't paid them or something but my domain expires in 3 years.

    Any other suggestions would be greatly appreaciated

    thanks guys

    p.s both of my nameservers are on the same ip for the time being until I get my 2nd ip from my provider, I don't know if that's affecting anything since it was working for more than 6months now
    Last edited: Mar 11, 2010
  8. falko

    falko Super Moderator ISPConfig Developer

  9. sheshes

    sheshes Member

    Where should have I created this?

    All my domains under ISPConfig have NS records of the 2 nameservers as well as A records for www, mydomain.com etc as the wizard sets it up properly.

    Are you saying I should create A records of the nameservers under Godaddy's dns?
  10. falko

    falko Super Moderator ISPConfig Developer

    You must create an A record for ns2 in the xxxxxxxx.com zone.
    The glue records must be created under GoDaddy.
  11. sheshes

    sheshes Member


    I have read the guide How To Run Your Own Name Servers With ISPConfig And GoDaddy although this is on the old GoDaddy platform and things have seriously changed now.

    I am not using GoDaddy's Total DNS for my top level domain, I just use the nameservers to redirect it to my ISPconfig server and manage all DNS from there.

    I have rang GoDaddy up and asked them to help me set up the Glue records but they didn't even know what glue records are so I gave up.

    Now, in ISPconfig 3 panel I should add A records for both the nameservers for each domain/site or just an A record to each domain/site for ns2.mydomain.com only?

    For all domains I have 2 NS records setup for each of the nameservers but obviously this is not enough.

    The thing I still don't get is, how is it possible that everything was working smoothly for 6 months and lately this problem has came up?
  12. falko

    falko Super Moderator ISPConfig Developer

    You need to set up A records for ns1.domain.com and ns2.domain.com in the domain.com zone, and you need to set up NS records for ns1.domain.com and ns2.domain.com in all the zones for which ns1.domain.com and ns2.domain.com are authoritative.
  13. sheshes

    sheshes Member

    Ok, I have set godaddys nameservers for my domain.com and using their DNS I have set records as follows:

    A records
    @ myip
    ns1 myip
    ns2 myip
    ns3 myip

    smtp mail.domain.com


    Priority Host Goes To
    10 @ mail.domain.com

    Are these enough?

    Now under ISPconfig

    I am using the wizard to create dns records and it automatically creates 2 NS records for my nameservers along with the usual A records for www, site.com, mail and the MX for mail.site.com

    Am I missing anything? (note that for the time being it works
  14. falko

    falko Super Moderator ISPConfig Developer

    You also need an A record for mail.domain.com.
  15. sheshes

    sheshes Member

    Thanks a lot falko. My issue is resolved.

    Just a quick question though it's a bit irrelevant to the thread. I am on Ubuntu 9.04, is it ok to upgrade to 9.10 using dist-upgrade or my installation and setup will be broken? I remember something said about courier but nobody answered my question before...

    Thanks again for all your help, falko, Tim

Share This Page