DNS TXT record: The hostname has the wrong format

Discussion in 'General' started by rogeriosjr, Jul 12, 2012.

  1. rogeriosjr

    rogeriosjr New Member

    Hello,

    I need to create a TXT record into a DNS Zone in ISPConfig 3.0.3.3 where hostname field is "@" text.

    When I click the save button ISPConfig shows me this error:
    "The hostname has the wrong format".

    Is it not possible to configure this ?

    What I need to configure:

    TXT record
    Hostname: @
    Text: MS=ms90127323
    TTJ: 3600
    Active: "yes"

    Regards,

    Rogerio.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    @ is not a valid hostname. If the txt record shall be for the zone, then enter the zone name with a dot at the end in the host field:

    yourdomain.tld.

    or leave the host field empty.
     
  3. rogeriosjr

    rogeriosjr New Member

    Hi till,

    I don't understand why @ is not valid.
    Look, I need this entry because we are configuring our DNS to respond to a Microsoft request.
    The customer is starting to use Office365 and need to validade their domain to start using it in Office365 environment.

    I had tried your instructions (entering zone name wth dot and leaving host filed empty) before starting this post without sucess.

    I really need to create this record with host field with @.
    This is a limitation of ISPConfig or BIND ?

    Regards.

    Rogerio.
     
  4. rogeriosjr

    rogeriosjr New Member

    Thats work.

    I set hostname empty and after 72 hours this worked.

    Thanks.
     

Share This Page