dns troubles

Discussion in 'Server Operation' started by cvenom96, Jan 3, 2007.

  1. cvenom96

    cvenom96 New Member

    I'm running Ubuntu 6.10 using ISPConfig. I followed the tutorial here http://www.howtoforge.com/perfect_setup_ubuntu_6.10. I set this up on two machines and I had no problems getting into ispconfig. I then worked through this tutorial on running my own dns servers http://www.howtoforge.com/ispconfig_dns_godaddy with the only exception being I am not using godaddy as my registrar. After an initial goof of running the primary and secondary servers on the same machine, I was able to run dig @ns1.hostmyvids.com any hostmyvids.com and here are my results:

    ; <<>> DiG 9.3.2 <<>> @ns1.hostmyvids.com any hostmyvids.com
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47023
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hostmyvids.com. IN ANY

    ;; ANSWER SECTION:
    hostmyvids.com. 86400 IN SOA ns1.hostmyvids.com. admin.hostmyvids.com. 2007010205 28800 7200 604800 86400
    hostmyvids.com. 86400 IN NS ns1.hostmyvids.com.
    hostmyvids.com. 86400 IN NS ns2.hostmyvids.com.
    hostmyvids.com. 86400 IN MX 10 mail.hostmyvids.com.
    hostmyvids.com. 86400 IN A 72.151.8.188

    ;; ADDITIONAL SECTION:
    mail.hostmyvids.com. 86400 IN A 72.151.8.188

    ;; Query time: 12 msec
    ;; SERVER: 72.151.8.189#53(72.151.8.189)
    ;; WHEN: Wed Jan 3 07:59:04 2007
    ;; MSG SIZE rcvd: 163

    However, I am not consistently able to dig these records. I was just able to run dig @ns1.hostmyvids.com any www.hostmyvids.com and got some info back but, when I tried using mail.hostmyvids.com, I got ; <<>> DiG 9.3.2 <<>> @ns1.hostmyvids.com any mail.hostmyvids.com

    ; (1 server found)
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    Any ideas as to why it is sporadically working?
     
  2. cvenom96

    cvenom96 New Member

    I just wanted to mention that it has only been about 24 hours since I got the name servers changed with the registrar. Maybe about 12 hours since I got things straightened out on my dns servers.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    It's still not working:

    Code:
    mh1:~# dig hostmyvids.com
    
    ; <<>> DiG 9.2.1 <<>> hostmyvids.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 16596
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;hostmyvids.com.                        IN      A
    
    ;; Query time: 179 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Jan  4 15:27:59 2007
    ;; MSG SIZE  rcvd: 32
    
    mh1:~# dig ns hostmyvids.com
    
    ; <<>> DiG 9.2.1 <<>> ns hostmyvids.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 27313
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;hostmyvids.com.                        IN      NS
    
    ;; Query time: 290 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Jan  4 15:28:05 2007
    ;; MSG SIZE  rcvd: 32
    
    mh1:~# dig any hostmyvids.com
    
    ; <<>> DiG 9.2.1 <<>> any hostmyvids.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 7392
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;hostmyvids.com.                        IN      ANY
    
    ;; Query time: 124 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Jan  4 15:28:14 2007
    ;; MSG SIZE  rcvd: 32
    I think the problem is that you need a glue record: http://en.wikipedia.org/wiki/Dns#Circular_dependencies_and_glue_records
     
  4. cvenom96

    cvenom96 New Member

    Thanks I'll try that.
     

Share This Page