DNS transfering domain + FTP question

Discussion in 'Installation/Configuration' started by Peterwebdev, Jun 6, 2018.

  1. Peterwebdev

    Peterwebdev New Member

    i had a read at the manual but i don't understand how to update the DNS I current have my domain and shared hosting with a2 company.

    Lets say my domain on a2 name server points to ns1.a2hosting.com and my domain is mydomainname.com

    ill setup my ispconfig 3 dns to

    then on a2 hosting i will be changing name servers from ns1.a2hosting.com to ns1.mydomainname.com.com, is that correct?

    i read that ftp is unsafe but people still use it is sftp the next best option?
    Last edited: Jun 6, 2018
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Regarding DNS:

    If you don't have many domains and if your domain provider has support for providing DNS for the domain free of charge, then you should consider to keep DNS at your provider and just point the DNS a- and mx records to your server.

    If your provider does not provide DNS service or you want to host many domains or you have fun in learning how dns works, then you can run your own DNS server, but normally you should have at least two servers for this.

    If you want to run your own dns, then use the DNS wizard in ISPConfig to create the dns zone. As you will probably use the same domain for the ns subdomains, add two a-records to that newly created zone, one for ns1 and one for ns2. Then you can go to a2 panel and configure that your own server is the DNS server for that zone.

    FTP over TLS as used today is not unsafe, it's fully encrypted with SSL/TLS, so it's a common myth that FTP is generally insecure. Only the old way to use FTP without TLS was unsafe. So there is no need to switch to sftp, you can still use FTP but ensure that you use FTP over TLS in your FTP client. TLS is enabled by default when you followed one of the perfect server guides. Using sftp is fine too of course, but you'll have to create a shell user for that in ISPConfig instead of an FTP account as SFTP is not FTP, it is SSH.
  3. Peterwebdev

    Peterwebdev New Member

    is this correct? trying to learn more about dns server, i created a client(me) then use the dnz zone wizzard and filled in the ip and ns, ns1.mydomain.com ns2.mydomain.com (no idea how is ns1,ns2 etc is created? is this what the wizzard is doing?)
    in the img below is a2 host i filled in ns1.mydomain.com ns2.mydomain.com
    on the right is records in the clients setting.

    I always used shared hosting and domain with the same company so working with dns is new to me.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to add two DNS A-Records, 'ns1' and 'ns2' both pointing to the IP of your server. Then the CNAME record that you entered is wrong, the dot at the end of the domain in the data field is missing. The setup at A2 is probably fine, but I wonder why they don't have an IP field as well as you must create a glue record at their servers, otherwise other servers won't be able to find your dns server.
  5. Peterwebdev

    Peterwebdev New Member

    Thanks i managed to find A2 in other setting called Private name server where i create ns1 ns2 etc.

    question about DNS A-Records, 'ns1' and 'ns2'

    i understand that we can use A record to to the server IP, i usually see its as domain address to point to an ip e.g when creating subdomain sub.domain.com etc. but what is it when the host is without domain.com e.g 'ns1' and 'ns2' ?

    EDIT: seems like i get an error that hte "ns.domain" could not be registered when i change the nameserver
    Last edited: Jun 7, 2018
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    DNS records have a short format and a long format in BIND DNS server. The short format is 'ns1' and the long format is 'ns1.yourdomain.tld.'. The long form must end with a dot, if the dot is missing, then the name is treated as short form zone name gets appended and you end up with a domain name ns1.yourdomain.tld.yourdomain.tld which is not desired. So eitehr use the hsort form as I suggested or use the long form if you prefer that, but then don't forget to add the dot (see my comment on the wrong cname record above).

Share This Page