DNS template problem

Discussion in 'Installation/Configuration' started by pawan, Nov 7, 2011.

  1. pawan

    pawan Member HowtoForge Supporter

    I had created a DNS custom template, where opted for not show some fields on selection of the custom templates.

    But now whether the field shown is selected or not, the fields are shown.

    I think there is some problem related to 3.0.4
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This function works for me in ISPConfig 3.0.4, just tested it with a fresh install. I went to DNS > DNS templates, clicked on "Add DNS Zone", all fields are shown. Then clicked on DNS Templates, edited the default template and unchecked the IP address checkbox, clicked on save. Clicked on "Add dns zone" again and all fields except of the disabled IP address field were shown. So it works as expected on my server.
     
  3. pawan

    pawan Member HowtoForge Supporter

    with default template it works for me as well.

    but if I select the custom template for which I disabled certain fields are still shown, which were getting hidden earlier immediately.
     
  4. pawan

    pawan Member HowtoForge Supporter

    One more thing I have noticed, is that whatever defaults you have chosen for the default template, it shows it exactly those field irrespective of the fields chosen for custom template.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I've fixed that in svn stable branch.
     

Share This Page