DNS SERVFAIL for virtual sites

Discussion in 'Installation/Configuration' started by tbcham, Jun 19, 2013.

  1. tbcham

    tbcham New Member

    Installed ISPconfig 3, added a site and added a dns zone using the site name for the ns1 and ns 2, went to the registrar and added the new nameserver and the site is there working.

    Then when I add a new site, I go the registar and add the original nameservers and nothing.

    Dig the site name gives a status: SERVFAIL, dig localhost status: SERVFAIL and there is no ip for A record.

    If I create a new dns zone for the second site using ns1 and ns2 site name and the same ip as the first name servers, then add the new name server at the registrar the site works.

    I checked bind9,restarted it.

    In my previous hosting all sites used just the one name server and the site configuration was automatic for all the virtual hosts (no manual adding of A records). I am thinking that some configuration files are not being written here, but not sure where to look or what might stop them being written.

    I don't want to or to ask other users to create a dns zone for each site on the server, but not sue what I have done or am doing wrong.
     
  2. till

    till Super Moderator

    If you use your own dns server then you have to create a-records on the dns zones for your sites. Adding a website means that you add a vhost in apache or nginx, neither apache nor nginx handle dns records, so you have to add the a-records in the dns zone of the dns manager so that they get added to bind.
     
  3. tbcham

    tbcham New Member

    Thanks.
    I tried adding an A record for the new site to the DNS zone for the nameserver, however same problem and SERVFAIL error and no ip appearing for the A record.
    In my last control panel ISPCP Omega, there was no manually adding a records to use the nameserver. You created the site then told the domain owner to add the nameserver at their registrar, hence not knowing or following the problem here.I presumed addin ghte A record would have been auto here too on site creation.
     
  4. tbcham

    tbcham New Member

Share This Page