DNS-server offline error

Discussion in 'Installation/Configuration' started by vincej97, Oct 24, 2011.

  1. vincej97

    vincej97 New Member

    Hello,

    I'm trying to resolve the DNS-server off-line error that I'm having in ISPconfig 3.0.3.3. I've read postings dealing with the issue from others but those haven't helped me any. All the other servers are on-line and I guess are working fine. Is there anything you need me to post here so you could assist me?

    NOTE: this is the first server I've built.

    vince
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    ifconfig
    ?
     
  3. vincej97

    vincej97 New Member

    netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program
    name
    tcp 0 0 localhost.localdomain:10024 *:* LISTEN 1223/amavis
    d (maste
    tcp 0 0 *:mysql *:* LISTEN 1169/mysqld

    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 918/cupsd

    tcp 0 0 localhost.localdomain:smtp *:* LISTEN 1489/sendma
    il: acce
    tcp 0 0 server1.5ss.com:56923 216.156.149.56.ptr.us.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:43670 69.22.148.210:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:60024 lax04s08-in-f14.1e100.:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:59851 lax02s01-in-f22.1e100:https ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:44932 64.145.89.16:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:52928 a72-246-245-55.deploy.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:52925 a72-246-245-55.deploy.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:47539 lax04s09-in-f28.1e100.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:33211 nuq04s06-in-f19.1e100:https TIME_WAIT -

    tcp 0 0 server1.5ss.com:51362 lax04s08-in-f27.1e100.:http ESTABLISHED 2089/firefo
    x
    tcp 0 1 server1.5ss.com:36139 50.97.209.196-static.r:http FIN_WAIT1 -

    tcp 0 0 server1.5ss.com:43668 69.22.148.210:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:50733 lax04s09-in-f27.1e100.:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:43672 69.22.148.210:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:42748 lax04s08-in-f24.1e100:https ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:52927 a72-246-245-55.deploy.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:47003 lax02s01-in-f29.1e100:https TIME_WAIT -

    tcp 0 0 server1.5ss.com:43671 69.22.148.210:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:50717 216.156.149.26.ptr.us.:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:47540 lax04s09-in-f28.1e100.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:47495 lax04s09-in-f28.1e100.:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:51949 lax04s09-in-f25.1e100.:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:56922 216.156.149.56.ptr.us.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:filenet-pa 64.210.61.138:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:57596 a184-31-239-139.deploy:http TIME_WAIT -

    tcp 0 488 server1.5ss.com:42226 ec2-50-19-244-56.compu:http ESTABLISHED -

    tcp 0 0 server1.5ss.com:52926 a72-246-245-55.deploy.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:60161 www.howtoforge.com:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:56925 216.156.149.56.ptr.us.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:57041 216.156.149.40.ptr.us.:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:55689 vip1.G-anycast1.cachef:http ESTABLISHED -

    tcp 0 0 server1.5ss.com:50273 www-10-01-prn1.faceboo:http ESTABLISHED 2089/firefo
    x
    tcp 0 0 server1.5ss.com:58202 lax04s08-in-f28.1e100.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:54453 74.121.136.115:http ESTABLISHED -

    tcp 0 28 server1.5ss.com:56163 pz-in-f84.1e100.net:https FIN_WAIT1 -

    tcp 0 0 server1.5ss.com:42762 lax04s08-in-f24.1e100:https ESTABLISHED 2089/firefox
    tcp 0 0 server1.5ss.com:43301 lax04s08-in-f10.1e100.:http ESTABLISHED 2089/firefox

    tcp 0 0 server1.5ss.com:47495 pz-in-f132.1e100.net:https TIME_WAIT -

    tcp 0 0 server1.5ss.com:44450 lax02s01-in-f10.1e100:https TIME_WAIT -

    tcp 0 0 server1.5ss.com:54459 lax04s09-in-f25.1e100:https TIME_WAIT -

    tcp 0 0 server1.5ss.com:59847 lax02s01-in-f22.1e100:https ESTABLISHED 2089/firefox

    tcp 0 0 server1.5ss.com:48650 lax02s01-in-f25.1e100.:http ESTABLISHED 2089/firefox

    tcp 0 0 server1.5ss.com:39935 mpr4.ngd.vip.sp2.yahoo:http ESTABLISHED -

    tcp 0 0 server1.5ss.com:54948 ec2-107-22-242-233.com:http ESTABLISHED -

    tcp 0 0 server1.5ss.com:59222 204.1.136.155:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:57772 lax04s09-in-f4.1e100.:https TIME_WAIT -

    tcp 0 0 server1.5ss.com:57588 nuq04s06-in-f17.1e100.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:56921 216.156.149.56.ptr.us.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:55920 204.1.136.121:http ESTABLISHED 2089/firefox

    tcp 0 0 server1.5ss.com:43669 69.22.148.210:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:47490 lax04s09-in-f28.1e100.:http ESTABLISHED 2089/firefox

    tcp 0 0 *:pop3 *:* LISTEN 1278/couriertcpd

    tcp 0 0 *:imap *:* LISTEN 1249/couriertcpd

    tcp 0 0 *:webcache *:* LISTEN 1351/httpd

    tcp 0 0 *:http *:* LISTEN 1351/httpd

    tcp 0 0 *:tproxy *:* LISTEN 1351/httpd
    tcp 0 0 server1.5ss.com:59847 lax02s01-in-f22.1e100:https ESTABLISHED 2089/firefox

    tcp 0 0 server1.5ss.com:48650 lax02s01-in-f25.1e100.:http ESTABLISHED 2089/firefox

    tcp 0 0 server1.5ss.com:39935 mpr4.ngd.vip.sp2.yahoo:http ESTABLISHED -

    tcp 0 0 server1.5ss.com:54948 ec2-107-22-242-233.com:http ESTABLISHED -

    tcp 0 0 server1.5ss.com:59222 204.1.136.155:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:57772 lax04s09-in-f4.1e100.:https TIME_WAIT -

    tcp 0 0 server1.5ss.com:57588 nuq04s06-in-f17.1e100.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:56921 216.156.149.56.ptr.us.:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:55920 204.1.136.121:http ESTABLISHED 2089/firefox

    tcp 0 0 server1.5ss.com:43669 69.22.148.210:http TIME_WAIT -

    tcp 0 0 server1.5ss.com:47490 lax04s09-in-f28.1e100.:http ESTABLISHED 2089/firefox

    tcp 0 0 *:pop3 *:* LISTEN 1278/couriertcpd

    tcp 0 0 *:imap *:* LISTEN 1249/couriertcpd

    tcp 0 0 *:webcache *:* LISTEN 1351/httpd

    tcp 0 0 *:http *:* LISTEN 1351/httpd

    tcp 0 0 *:tproxy *:* LISTEN 1351/httpd

    tcp 0 0 *:ftp *:* LISTEN 1381/proftpd: (acc
    e
    tcp 0 0 localhost6.localdomain6:ipp *:* LISTEN 918/cupsd

    tcp 0 0 *:imaps *:* LISTEN 1266/couriertcpd

    tcp 0 0 *:pop3s *:* LISTEN 1287/couriertcpd


    [[email protected] ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0C:76:61:E7:E6
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:11 Base address:0xa000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:19954 errors:0 dropped:0 overruns:0 frame:0
    TX packets:19954 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1527554 (1.4 MiB) TX bytes:1527554 (1.4 MiB)

    wlan0 Link encap:Ethernet HWaddr 00:0E:3B:1E:C6:1D
    inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::20e:3bff:fe1e:c61d/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:97718 errors:0 dropped:0 overruns:0 frame:0
    TX packets:9538 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:10401562 (9.9 MiB) TX bytes:1876116 (1.7 MiB)
     
  4. falko

    falko Super Moderator ISPConfig Developer

    named isn't running. Please start it.
     
  5. vincej97

    vincej97 New Member

    This is what I get...


    service named start
    Starting named (via systemctl): Job failed. See system logs and 'systemctl status' for details.
    [FAILED]
     
  6. vincej97

    vincej97 New Member

    I fix it knowing this...

    [[email protected] ~]# service named test
    /etc/named.conf.local:4: expected IP address near '[email protected]'


    and it started! Thanks for your help!!
     
  7. vincej97

    vincej97 New Member

    I don't believe this! My DNS stopped working again. It was working fine, but I don't know what happened. What should I do now? It's giving me this::

    [[email protected] ~]# service named test
    zone localhost.localdomain/IN: loaded serial 0
    zone localhost/IN: loaded serial 0
    zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
    zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
    zone 0.in-addr.arpa/IN: loaded serial 0
    /var/named/pri.server1.5ss.com:10: ignoring out-of-zone data (5ss.com)
    /var/named/pri.server1.5ss.com:11: ignoring out-of-zone data (5ss.com)
    /var/named/pri.server1.5ss.com:12: ignoring out-of-zone data (5ss.com)
    /var/named/pri.server1.5ss.com:13: ignoring out-of-zone data (5ss.com)
    zone server1.5ss.com/IN: has no NS records
    zone server1.5ss.com/IN: not loaded due to errors.
    _default/server1.5ss.com/IN: bad zone

    [[email protected] ~]# service named status
    rndc: connect failed: 127.0.0.1#953: connection refused
    named.service - LSB: start|stop|status|restart|try-restart|reload|force-reload DNS server
    Loaded: loaded (/etc/rc.d/init.d/named)
    Active: failed since Wed, 02 Nov 2011 20:21:44 -0700; 20min ago
    Process: 802 ExecStart=/etc/rc.d/init.d/named start (code=exited, status=2/INVALIDARGUMENT)
    CGroup: name=systemd:/system/named.service

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:10024 *:* LISTEN 1231/amavisd (maste
    tcp 0 0 *:mysql *:* LISTEN 1164/mysqld
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 913/cupsd
    tcp 0 0 localhost.localdomain:smtp *:* LISTEN 1502/sendmail: acce
    tcp 0 0 server1.5ss.com:35098 lax02s01-in-f22.1e100:https ESTABLISHED 2099/firefox
    tcp 0 0 server1.5ss.com:55439 lax04s08-in-f21.1e100:https ESTABLISHED 2099/firefox
    tcp 0 0 *:pop3 *:* LISTEN 1290/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 1261/couriertcpd
    tcp 0 0 *:webcache *:* LISTEN 2409/httpd
    tcp 0 0 *:http *:* LISTEN 2409/httpd
    tcp 0 0 *:tproxy *:* LISTEN 2409/httpd
    tcp 0 0 *:ftp *:* LISTEN 1393/proftpd: (acce
    tcp 0 0 localhost6.localdomain6:ipp *:* LISTEN 913/cupsd
    tcp 0 0 *:imaps *:* LISTEN 1278/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 1299/couriertcpd


    [[email protected] ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0C:76:61:E7:E6
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:11 Base address:0x2000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1028 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1028 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:352794 (344.5 KiB) TX bytes:352794 (344.5 KiB)

    wlan0 Link encap:Ethernet HWaddr 00:0E:3B:1E:C6:1D
    inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::20e:3bff:fe1e:c61d/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:5211 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3358 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3194950 (3.0 MiB) TX bytes:790320 (771.7 KiB)
     
  8. vincej97

    vincej97 New Member

    Remote Access

    I'm trying to remotely access my server at home from work. Is there a setup that allows me to do that? I've been trying to connect but it doesn't allow me too. What am I doing wrong or not doing? Thanks!
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Do you mean over SSH? What's the error you get?
     
  10. vincej97

    vincej97 New Member

    Trying to connect remotely to ISPconfig server

    I don't get an error. It just says "can not connect to host". I'm not sure if it's through SSH or not. I haven't done anything after installing ISPConfig, I just went straight to trying to connect remotely from work.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    But how do you try to connect? With an SSH client, a browser, and email client, FTP, ...?
     

Share This Page