DNS-server offline after installing ISPConfig3

Discussion in 'Installation/Configuration' started by waffo, Jun 16, 2011.

  1. waffo

    waffo New Member

    Hi,

    I just finished installing ISPConfig 3 using the The Perfect Server - Fedora 15 [ISPConfig3] tutorial.

    But in the monitor at ISPConfig3, its showing 1 error - DNS server OFFLINE.

    How do I fix it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The dns will start working when you add the first dns zone.
     
  3. waffo

    waffo New Member

    So I have the following information:

    an IP address - that I used while setting up the webserver
    a subnet mask - that I used while setting up the webserver
    Default Gateway - that I used while setting up the webserver
    Pref DNS - that I used while setting up the webserver
    Alt DNS - that I used while setting up the webserver

    - I followed only the steps from The perfect server - fedora 15 [ISPConfig 3] tutorial.

    I am only a beginner at Unix and had never set up a server/website before.

    Setting up a DNS Zone asked for the following:

    Server - i guess i put the name of my server over here?
    Client - I have set up a client
    Domain - I dont know what to use here
    IP Address - I dont know what to use here
    NS 1 - I dont know what to use here
    NS 2 - I dont know what to use here
     
  4. waffo

    waffo New Member

    I was going through the forum when the DNS wasn't working as it was showing offline, and everywhere people were talking about myDNS.

    The Perfect Server - Fedora 15 [ISPConfig3] didn't have a myDNS section. Therefore, I followed the myDNS section of Fedora 10 [ISPConfig3], which is the following:
    18 Install MyDNS

    We can install MyDNS as follows:

    wget http://mydns.bboy.net/download/mydns-mysql-1.1.0-1.i386.rpm
    rpm -ivh mydns-mysql-1.1.0-1.i386.rpm

    When the system boots, MyDNS must be started after MySQL. The MySQL startup link has the priority 64 on Fedora 10, so the MyDNS startup link must have a priority between 65 and 99. Therefore we open the MyDNS init script...

    vi /etc/init.d/mydns

    ... and change

    [...]
    # chkconfig: 345 52 50
    [...]

    to

    [...]
    # chkconfig: 345 65 50
    [...]

    Then we create the startup links:

    chkconfig --levels 235 mydns on

    We don't start MyDNS now because it must be configured first - this will be done automatically by the ISPConfig 3 installer later on.



    And it worked, now its showing online. But I haven't/couldn't set up a DNS zone yet. Did I do anything wrong?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please dont install mydns because your setup uses bind. mydns is not used in new ispconfig setups anymore.

    The solution for your problem was to add a new dns zone in the dns module of the ispconfig 3 interface. To create a new dns zone, just enter the details for the zone like domain name, ip address and the primary and secondary dns server of that domain.
     
  6. waffo

    waffo New Member


    Can I use the same IP address that I used while setting up the webserver? Because the sites are going to be in an Intranet.
    And I only have the ip addresses of the primary & secondary DNS servers, what should I put as their name?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    So basically you dont need any dns? Then there is no need to create a record, just let it as it is.
     

Share This Page