DNS server not working externally!

Discussion in 'Server Operation' started by JimmiJames, Jun 12, 2009.

  1. JimmiJames

    JimmiJames New Member

    I've setup a DNS server(Debian ispconfig3 perfect server). It works fine internally with domains that we own, but it doesn't resolve any other domain on the internet.

    Any ideas?
     
  2. Artanis

    Artanis New Member

    Also having this issue on one of my ispconfig3 servers.

    the nameservers in /etc/resolve.conf are all pingable as are all external IP's i've tried, but all I can't resolve any DNS records.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

  4. Artanis

    Artanis New Member

    Tried that, anything else? :)
     
  5. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/resolv.conf?
     
  6. Artanis

    Artanis New Member

    Code:
    nameserver 64.85.160.4
    nameserver 209.165.240.227
    nameserver 208.67.222.222
    First two being VPS providers nameservers, last being OpenDNS nameserver.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Can you add
    Code:
    nameserver 145.253.2.75
    in the first place?
    Does
    Code:
    dig google.com
    work then?
     
  8. JimmiJames

    JimmiJames New Member

    I can dig, I can ping, tried different nameservers still doesn't work. I have 3 debian machines, none have DNS working.
     
  9. ajhart

    ajhart New Member

    DNS not working.

    Hi guys.
    First off, I'm quite new to this all and strugling my head off. I don't know much of this all but I can make some sence of Linux and ISPConfig. (What a Noob!?) ha ha

    Right, I'm running ISPConfig 3 on Fedora 10 setuped through Perfect Server tut.
    I have 3 eth cards in my server, one for internal (10.1.1.210) firewalled by mikrotik router and the other two with a public ip each (196.212.216.75, ADSL fiber Billion router) and (196.212.78.51 ASDL sat Cisco router) ISP provider @ Datapro. The two DNS I got fromm them is 168.210.2.2 and 196.14.239.2, where I get my internet from.

    What I intend to do is to use one public ip for a ns1 and the second for a ns2 and register a domain gbsecwireless.co.za.

    So first, this is how my server cfg looks like:

    Code:
    [global]
    webserver=apache
    mailserver=postfix
    dnsserver=mydns
    
    [server]
    auto_network_configuration=
    ip_address=10.1.1.210
    netmask=255.255.255.0
    gateway=10.1.1.1
    hostname=server.gbsecwireless.co.za
    nameservers=168.210.2.2, 196.14.239.2
    
    [mail]
    module=postfix_mysql
    maildir_path=/var/vmail/[domain]/[localpart]
    homedir_path=/var/vmail
    mailuser_uid=5000
    mailuser_gid=5000
    mailuser_name=vmail
    mailuser_group=vmail
    relayhost=
    relayhost_user=
    relayhost_password=
    mailbox_size_limit=0
    message_size_limit=0
    
    [getmail]
    getmail_config_dir=/etc/getmail
    
    [web]
    website_basedir=/var/www
    website_path=/var/www/clients/client[client_id]/web[website_id]
    website_symlinks=/var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/
    vhost_conf_dir=/etc/httpd/conf/sites-available
    vhost_conf_enabled_dir=/etc/httpd/conf/sites-enabled
    
    [fastcgi]
    fastcgi_starter_path=/var/www/php-fcgi-scripts/[system_user]/
    fastcgi_starter_script=.php-fcgi-starter
    fastcgi_alias=/php/
    fastcgi_phpini_path=/etc/
    fastcgi_children=8
    fastcgi_max_requests=5000
    fastcgi_bin=/usr/bin/php-cgi
    
    [jailkit]
    jailkit_chroot_home=/home/[username]
    jailkit_chroot_app_sections=basicshell editors extendedshell netutils ssh sftp scp groups jk_lsh
    jailkit_chroot_app_programs=/usr/bin/groups /usr/bin/id /usr/bin/dircolors /bin/basename /usr/bin/dirname /usr/bin/nano
    Second, I created a new client and a mail domain

    [​IMG]

    Then I added a site

    [​IMG]

    And then I added a DNS Zone with records

    [​IMG]

    [​IMG]

    I added a DNS record on my mikrotik so I can access the site www.gbsecwireless.co.za from my internal network


    And it is working perfectley fine. I installed Joomla and its working like a dream.

    Code:
    [[email protected] ~]# cat /etc/resolv.conf
    # Generated by NetworkManager
    search gbsecwireless.co.za gbsecwireless.co.za gbsecwireless.co.za
    nameserver 168.210.2.2
    [[email protected] ~]# dig google.com
    
    ; <<>> DiG 9.5.1-P2-RedHat-9.5.1-2.P2.fc10 <<>> google.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63250
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;google.com.                    IN      A
    
    ;; ANSWER SECTION:
    google.com.             106     IN      A       74.125.127.100
    google.com.             106     IN      A       74.125.67.100
    google.com.             106     IN      A       74.125.45.100
    
    ;; Query time: 40 msec
    ;; SERVER: 168.210.2.2#53(168.210.2.2)
    ;; WHEN: Wed Jun 17 09:53:46 2009
    ;; MSG SIZE  rcvd: 76
    
    [[email protected] ~]#
    
    Now the thing is, when I try to regester the domain gbsecwireless.co.za at co.za uniform, they tell me that they can't resolve my forward or PTR dns. I can ping both public ip's and co.za as well. Could it maybe be because of my ISP or is there something wrong with my config.

    Any help would be very apreciated!!
    Thanks in advance!!
     
  10. falko

    falko Super Moderator ISPConfig Developer

    @ajhart: Please open a new thread.
     

Share This Page