dns server is offline help please?

Discussion in 'Server Operation' started by lang, Aug 20, 2009.

  1. lang

    lang New Member

    hi all gurus, please help a newbie, I have setup ubuntu 9.04 server (with a GUI for ease of use and because im a newbie) and ispconfig 3 as per falko tutorial, all went well so well done Falko for making it foolproof....well not quite, ispconfig/monitor reports my-dns server is offline, i ran /etc/init.d/mydns start through a terminal and got this error

    /etc/init.d/mydns: line 18: syntax error near unexpected token `start'

    what on earth does it mean please and how can i fix it.

    TIA
    Lang
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/init.d/mydns?
     
  3. lang

    lang New Member

    #! /bin/sh
    #
    # mydns start the MyDNS Server
    #
    #
    set -e
    path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    daemon=/usr/local/sbin/mydns
    name=mydns
    desc="dns server"

    scriptname=/etc/init.d/$name

    #gracefully exit if the package has been removed
    test -x $daemon || exit 0

    case "$1"in
    start)
    echo -n "starting $desc: $name"
    start-stop-daemon --start --quite \
    --exec $daemon -- -b
    echo "."
    ;;

    hi there, thanks for the reply, above is a cut and paste. im pretty sure ??? i typed it in as you described in your tutorial, but maybe not, I am a total newbie and dont really understand yet what all the commands mean :eek: the server will be just an old computer i have at home and will serve just one site at this stage, but if i can get it to work i will run other sites i maintain on it as well, just a matter of slowly getting my head around it.... probably just a typo, so thanks if you can spot my mistake.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you copy the script from the tutorial, or did you type it manually? In the latter case you probably made a typo somewhere...
     
  5. lang

    lang New Member

    I installed ubuntu server as per your tutorial then installed a desktop, found your tutorial again and cut and pasted from browser to terminal, only changes i made were where you used the IP 198.168.0.100 i used my actual IP, netmask, gateway etc.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Try copy&paste again, I think something must have gone wrong with your first try.
     

Share This Page