DNS "server failed" on ISPconfig 3 and Fedora 13

Discussion in 'Installation/Configuration' started by thanatos2k, Aug 14, 2010.

  1. thanatos2k

    thanatos2k New Member

    I have a few ISPConfig 3 servers running on Fedora 13 (bind, not myDNS), all installed with the documentation on HowtoForge.

    I can successfully query for zones not hosted on my server, but any query to a zone hosted on my servers gets this error:

    *** [xxx.xxx.xxx.xxx] can't find www.domain.com: Server failed

    And the following 2 messages on the ISPconfig server's log:

    Aug 13 23:40:05 ns1 named[2079]: lame server resolving 'www.domain.com' (in 'domain.com'?): xxx.xxx.xxx.xxx#53
    Aug 13 23:40:05 ns1 named[2079]: lame server resolving 'www.domain.com' (in 'domain.com'?): yyy.yyy.yyy.yyy#53

    where xxx and yyy are the IP addresses of my 2 DNS servers as registered in the DNS records of the registrar.

    I had a DNS server running CentOS 5 with bind, and everything worked fine there. I'm just running into these problems since changing over to the IPSConfig DNS and changing the DNS records with my registrar.
     
  2. mike_p

    mike_p Member

    Are you using NAT? If so I presume your local DNS queries are failing to find the nameservers because they're using the external IP addresses (which obviously won't work within your local network). Try running the same nameserver queries from outside your network.
     
  3. thanatos2k

    thanatos2k New Member

    I'm not using NAT, the servers are in a datacenter, 1 public IP per server. I was querying them from my home machine on a cable modem, but I get the same result from other servers on the same subnet as the ISPConfig server, and from other servers on the internet.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you use ISPConfig's DNS Wizard, or did you set up the zone manually (in ISPConfig)?
     
  5. thanatos2k

    thanatos2k New Member

    I have tried it both ways, as well as SSHing the working zone file manually from my old DNS server.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you post your zone file for domain.com?
     
  7. thanatos2k

    thanatos2k New Member

    I just used the default DNS template in ISPConfig:

    $TTL 86400
    @ IN SOA ns1.domain.com. admin.domain.com. (
    2010081604 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;
    domain.com. A 1.2.3.4
    domain.com. MX 10 mail.domain.com.
    domain.com. NS ns1.domain.com.
    domain.com. NS ns2.domain.com.
    mail A 1.2.3.4
    www A 1.2.3.4
     
  8. falko

    falko Super Moderator ISPConfig Developer

Share This Page