DNS reverse mapping not working

Discussion in 'Installation/Configuration' started by dgmufasa, Jun 6, 2012.

  1. dgmufasa

    dgmufasa New Member

    Hello all,

    When I do :

    "host 192.168.1.78"

    I get the following answer:
    Host 78.1.168.192.in-addr.arpa not found: 3(NXDOMAIN)

    How can I fix this?

    TIA
     
  2. dgmufasa

    dgmufasa New Member

    DNS setting not saved at OS level

    Hi again,

    I attempted to create a zone for reverse lookup purposes. See attachment.

    It does not put anything in the /etc/named.conf file - at all.

    What is the problem?

    TIA

    Also, just to be clear, the info entered is:
    Zone: 78.1.168.in-addr.arpa.
    NS: ns1.pridelands.com.
    Email: d0mufasa.sbcglobal.net.
     

    Attached Files:

    Last edited: Jun 6, 2012
  3. dgmufasa

    dgmufasa New Member

    Hi again,

    Now getting this when restarting the nameserver:

    [root@zazu etc]# /etc/init.d/named restart
    Stopping named: [ OK ]
    Starting named:
    Error in named configuration:
    zone pridelands.com/IN: loaded serial 2012060603
    zone stashandcarry.com/IN: loaded serial 2011100801
    zone ucacheit.com/IN: loaded serial 2012033001
    zone klickmeup.com/IN: loaded serial 2012021201
    zone 1.168.192.in-addr.arpa/IN: has no NS records
    zone 1.168.192.in-addr.arpa/IN: not loaded due to errors.
    _default/1.168.192.in-addr.arpa/IN: bad zone
    [FAILED]

    Any hints on why this is going on is appreciated.

    TIA
     
  4. dgmufasa

    dgmufasa New Member

    This is what I have now:

    Below is what I am getting now. Does anyone have any ideas?

    TIA



    /etc/named.conf


    zone "ucacheit.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.ucacheit.com";
    };
    zone "pridelands.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.pridelands.com";
    };
    zone "klickmeup.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.klickmeup.com";
    };
    zone "stashandcarry.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.stashandcarry.com";
    };
    zone "1.168.192.in-addr.arpa" {
    type master;
    allow-transfer {none;};
    file "/var/named/kpri.1.168.192.in-addr.arpa";
    };

    for file: "/var/named/pri.1.168.192.in-addr.arpa"

    $TTL 86400
    @ IN SOA ns1.pridelands.com. administrator.pridelands.com. (
    2012060606 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;

    192.168.1.78.in-addr.arpa. PTR ns1.pridelands.com.

    When trying to start it, I get

    [root@zazu etc]# /etc/init.d/named restart
    Stopping named: [ OK ]
    Starting named:
    Error in named configuration:
    zone pridelands.com/IN: loaded serial 2012060603
    zone stashandcarry.com/IN: loaded serial 2011100801
    zone ucacheit.com/IN: loaded serial 2012033001
    zone klickmeup.com/IN: loaded serial 2012021201
    zone 1.168.192.in-addr.arpa/IN: has no NS records
    zone 1.168.192.in-addr.arpa/IN: not loaded due to errors.
    _default/1.168.192.in-addr.arpa/IN: bad zone
    [FAILED]
     
  5. dgmufasa

    dgmufasa New Member

    Getting closer - the latest results

    Things worked better when I used the option to "Add New DNS Zones With Wizard". It seems to work for "nala.pridelands.com" but not nala. Is there a way to fix this so it when doing "host nala", you will get an IP address?

    TIA


    [root@zazu etc]# ping nala
    PING nala.pridelands.com (192.168.1.78) 56(84) bytes of data.
    64 bytes from 192.168.1.78: icmp_seq=1 ttl=64 time=0.080 ms
    64 bytes from 192.168.1.78: icmp_seq=2 ttl=64 time=0.080 ms
    64 bytes from 192.168.1.78: icmp_seq=3 ttl=64 time=0.089 ms


    [root@zazu etc]# ping 192.168.1.78
    PING 192.168.1.78 (192.168.1.78) 56(84) bytes of data.
    64 bytes from 192.168.1.78: icmp_seq=1 ttl=64 time=0.074 ms
    64 bytes from 192.168.1.78: icmp_seq=2 ttl=64 time=0.096 ms
    64 bytes from 192.168.1.78: icmp_seq=3 ttl=64 time=0.094 ms


    [root@zazu etc]# cat /etc/named.conf
    zone "ucacheit.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.ucacheit.com";
    };
    zone "pridelands.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.pridelands.com";
    };
    zone "klickmeup.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.klickmeup.com";
    };
    zone "stashandcarry.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.stashandcarry.com";
    };
    zone "1.168.192.IN-ADDR.ARPA" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.1.168.192.IN-ADDR.ARPA";
    };





    [root@zazu etc]# vi "/var/named/pri.1.168.192.IN-ADDR.ARPA"
    $TTL 86400
    @ IN SOA ns1.pridelands.com. d0mufasa.sbcglobal.net. (
    2012060606 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;

    1.168.192.IN-ADDR.ARPA. 86400 A 192.168.1.78
    1.168.192.IN-ADDR.ARPA. MX 10 mail.1.168.192.IN-ADDR.ARPA.
    1.168.192.IN-ADDR.ARPA. NS ns1.pridelands.com.
    1.168.192.IN-ADDR.ARPA. NS ns2.pridelands.com.
    78 PTR ns1.pridelands.com
    mail 86400 A 192.168.1.78
    www 86400 A 192.168.1.78



    [root@zazu etc]# /etc/init.d/named restart
    Stopping named: [ OK ]
    Starting named: [ OK ]
    [root@zazu etc]#


    [root@zazu etc]# host 192.168.1.78
    78.1.168.192.in-addr.arpa domain name pointer ns1.pridelands.com.1.168.192.in-addr.arpa.


    [root@zazu etc]# dig -x 192.168.1.78

    ; <<>> DiG 9.7.0-P2-RedHat-9.7.0-5.P2.el6_0.1 <<>> -x 192.168.1.78
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2368
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;78.1.168.192.in-addr.arpa. IN PTR

    ;; ANSWER SECTION:
    78.1.168.192.in-addr.arpa. 86400 IN PTR ns1.pridelands.com.1.168.192.in-addr.arpa.

    ;; AUTHORITY SECTION:
    1.168.192.in-addr.arpa. 86400 IN NS ns1.pridelands.com.
    1.168.192.in-addr.arpa. 86400 IN NS ns2.pridelands.com.

    ;; ADDITIONAL SECTION:
    ns1.pridelands.com. 86400 IN A 192.168.1.70
    ns2.pridelands.com. 86400 IN A 192.168.1.70

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.70#53(192.168.1.70)
    ;; WHEN: Wed Jun 6 17:26:39 2012
    ;; MSG SIZE rcvd: 158


    [root@zazu etc]# nslookup nala
    Server: 192.168.1.70
    Address: 192.168.1.70#53

    ** server can't find nala: NXDOMAIN

    [root@zazu etc]# host nala.pridelands.com
    nala.pridelands.com has address 192.168.1.78


    [root@zazu etc]# ping nala.pridelands.com
    PING nala.pridelands.com (192.168.1.78) 56(84) bytes of data.
    64 bytes from ns1.pridelands.com.1.168.192.in-addr.arpa (192.168.1.78): icmp_seq=1 ttl=64 time=0.075 ms
    64 bytes from ns1.pridelands.com.1.168.192.in-addr.arpa (192.168.1.78): icmp_seq=2 ttl=64 time=0.096 ms
     
  6. falko

    falko Super Moderator ISPConfig Developer

    This is wrong - it should be

    Code:
    78 PTR ns1.pridelands.com.
     
  7. dgmufasa

    dgmufasa New Member

    Hello and thanks for the response,

    When following your instructions above I get the following:

    nala:~ # host 192.168.1.78
    78.1.168.192.in-addr.arpa domain name pointer ns1.pridelands.com.


    I dont get

    nala

    nor do i get

    nala.pridelands.com

    I have 5 machines here locally.

    All 5 are defined in the DNS server.

    One of the machines has the hostname of nala not nala.pridelands.com but just nala

    I am installing a product on nala that requires the reverse lookup definition of 192.168.1.78 to be nala Again, not
    nala.pridelands.com but just nala.

    Would a better way to deal with this be to just remove the definition of nala from the DNS server so that the definition of nala in the /etc/hosts file will become valid?
     
    Last edited: Jun 8, 2012

Share This Page