DNS problems

Discussion in 'Installation/Configuration' started by staticanime, Aug 29, 2008.

  1. staticanime

    staticanime New Member

    I'm having some problems getting my DNS working, and I don't know how to fix it.

    I'm trying to host my website (staticanime.net) on my dedicated webserver (ns363416.ovh.net), setup with a basic CentOS 5.0 (32-bit) OVH install, then tweaked as per this guide (http://www.howtoforge.com/perfect-server-centos-5.2) with the addition on Webmin/Usermin/Virtualmin.

    All the websites are handled through Virtualmin, and my site worked for a day or two, and now I can't access it at all.

    The domain staticanime.net is currently registered with DreamHost, and the dns records there have been set to:
    Nameserver 1: ns363416.ovh.net
    Nameserver 2: sdns1.ovh.net -> OVH's secondary dns

    I did a DNS traversal test, and as you can see in the results (pic attached), ns363416.ovh.net is timing out. First off, what ports/settings should I have for the firewall in Webmin, til I verify that it's not the firewall?

    I can post the named configs and zone info if needed

    Attached Files:

  2. staticanime

    staticanime New Member


    Fixed it myself, it was the firewall after all. For some reason, it was blocking incoming UDP traffic, so nothing could reach the local DNS server.

    Now, leaving all the UDP ports open seems a bit dodgy, security-wise, so is there anything I can do there? Should I just leave port 53 open on UDP in both directions?
  3. topdog

    topdog Active Member HowtoForge Supporter

    DNS only uses port 53 so u don't have to open up the whole of udp
  4. staticanime

    staticanime New Member

    Thanks mate :)

Share This Page