DNS problems www won't work

Discussion in 'Installation/Configuration' started by jaisol99, Aug 16, 2013.

  1. jaisol99

    jaisol99 New Member


    Linux ver ubuntu 10.04.4, its a light weight version and I can't remeber its name Lubuntu I think.

    When I put mydomain.com it works ok and comes up with the default "Welcome to your website ..... ispconfig"

    But when I put www.mydomain.com it comes up with the standard apache default "It works...."

    I looked at a similar problem
    it was surgested that:

    This can have several reasons:

    1) You did not setup the websites or dns records properly. I'm not sure
    2) You use mydomain.com as server hostname. As described in the perfect setup guide, the hostname of your server should be a subdomain like server1.mydomain.tld and not mydomain.tld. My server name is just dell_laptop_01
    3) You did not create a website mydomain.tld (without www!) In Sites .. Web Domain .. Domain = mydomain.com (with no www bit in front of it)
    4) You did not select aouto subdomain www in the settings of the mydomain.tld website. I selected DNS wizard and that seems to have created a A www ip address ok

    I did a dig @localhost mydomain.com


    ; (2 servers found) ???? Only one server There are no other compters with the same server name
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 32841
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;www.jaitec.com. IN A

    ;; Query time: 1 msec
    ;; SERVER:
    ;; WHEN: Fri Aug 16 00:14:33 2013
    ;; MSG SIZE rcvd: 32

    I'm now stuck and don't realy know what to do
    Last edited: Aug 16, 2013
  2. MrWolf

    MrWolf New Member

    you did have your www dns entry,
    you also have you domain created in the website but
    did you choose your "auto-subdomain: www." ?

    auto-subdomain is different then dns. the dns will point www.yourdomain.com to the right ip address but apache need to know that he have to answer to that request
  3. jaisol99

    jaisol99 New Member

    Thank you that worked

    Took a few minutes to find - Sites .. website ...

Share This Page