Dns problems via ISPCONFIG setup

Discussion in 'Installation/Configuration' started by daseagle, Mar 11, 2012.

  1. daseagle

    daseagle New Member


    First of all, I am posting this here and not in the ISPconfig section, because I am not sure if its a server issue or related to ISPconfig. Please excuse any deviation from forum rules.
    I seem to have a weird situation, described below:

    Basic conditions: server is a Centos 6.2 x64, installed following the general guidelines of Falko's guide.

    Ispconfig: installed, with a client added.

    Firewall: used the one in ispconfig, open ports:
    TCP: 20,21,25,53,80,110,143,443,993,995,2012,3306,8080,8081,10000 (probably going to eliminate 10000)
    UDP: 53, 3306
    I will close off ftp and 3306 after finishing the configuration.

    PROBLEM: I added the client in the ispconfig admin interface. Then I logged in with the client credentials. In the client interface, I created a new website, new mail domain and new dns entries for that specific domain.
    But for some reason, the dns settings will not work. I mean the interface accepts them without any visible error message and the records do show up, but when I question the server via nslookup, it fails. Before someone asks, yes, the domain has been redirected to the new IP address from my domain provider.

    I thought that maybe named needs a restart, so I gave the whole server a reboot, for good measure. Still, no joy.

    Any ideas? I went through the ispconfig manual, unfortunately I did not find any meaningful ideas there.

    Help would be much appreciated. Whats bugging me is that I followed the same steps I would normally use on a 5.7 Centos and it worked perfectly there on every server. Now, in 6.2, I'm missing something :(


    Edit: I also tried setting up the dns via the direct admin interface (w/o any client account) - that does not work either. The changes at the domain provider were made almost 12 hours ago and its a national domain, so it should have synced a long time ago.


    Edit2: named failed too, but it was because of the rndc key issue that popped up in Centos 6 (found the bug and discussion page). Fixed it (at least named now starts and stops without giving error messages.). Main issue still very much active.

    Edit3: pinging example.com fails, but pinging server1.example.com works :) So it resolves something, but I'll be damned if I know where and how.

    At this moment I am desperate enough to scrap the whole setup and go back to Centos 5.7.

    Records look like this:

    A example.com. XXX.XXX.XXX.XXX 0
    A mail XXX.XXX.XXX.XXX 0
    A www XXX.XXX.XXX.XXX 0
    MX example.com. mail.example.com. 10
    NS example.com ns.example.com. 0
    NS example.com. ns2.example.com. 0
    NS example.com. ns1.example.com. 0

    I bet Falko could sort this out in no-time :)
    Last edited: Mar 11, 2012
  2. falko

    falko Super Moderator ISPConfig Developer

  3. daseagle

    daseagle New Member

    All I understand from that wiki article is that for some reason, my server is going around in circles?

    Can you suggest a solution?

    What I can't understand is, that I have 5 more boxes, all running Centos, all set up the same way and only this one is giving me the creeps.

    All are top level domains, all have the nameservers configured at the national tld provider. All are in the format example.com, where ns1 and ns2 are the nameservers for example.com. All are various flavours of Cebntos.
    Last edited: Mar 12, 2012

Share This Page