DNS problems, im almost giving up!

Discussion in 'Installation/Configuration' started by beryl, May 11, 2007.

  1. beryl

    beryl New Member

    DNS problems, im almost giving up! [SOLVED!]

    EDIT: Solved! Just did a restart of the system and everything worked.

    Hi there,

    Sorry for troubling you people with this but im so confused i don´t know where to start.

    Ive followed the Debian 4.0 Etch Perfect setup and everything went well.
    No errors spotted whatsoever.

    Then i went into the settings and put in my DNS servers.
    ns1.mydomain.com
    ns2.mydomain.com

    Then i went to ISP config and created a new website and added DNS.

    Went to DNS manager and put this in there:
    Under settings:
    Nameserver 1: ns1.mydomain.com
    Nameserver 1: ns1.mydomain.com

    Then went to the last tab for DNS.
    IP-Adresse Värdnamn
    server IP www
    server IP ns1
    server IP ns2
    server IP reverse

    Then i registered the nameservers ns1.mydomain.com and ns2.mydomain.com at my registrars. They all setup just fine.

    But when i go to the terminal i get this:

    dig www.mydomain.com

    ; <<>> DiG 9.3.4 <<>> www.mydomain.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 1885
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.mydomain.com. IN A

    ;; Query time: 4 msec
    ;; SERVER: SOMEIP#53(SOMEIP)
    ;; WHEN: Fri May 11 17:06:34 2007
    ;; MSG SIZE rcvd: 31

    Can anyone answer me why this will not work at all?
    I simply cannot understand what is wrong, ive searched thru forums and howtos and all the stuff i can find but cant figure out what is missing, or wrong! And yes, BIND is up and running.

    Best Regards, Mikael.

    EDIT: Solved! Just did a restart of the system and everything worked.
     
    Last edited: May 11, 2007

Share This Page