DNS Problem

Discussion in 'Installation/Configuration' started by beenfishing, Apr 11, 2012.

  1. beenfishing

    beenfishing New Member

    I have setup a multiserver following the Debian Squeeze guide, everything appears to be setup correctly except for the DNS.

    I have made my domain at GoDaddy use my dns servers without any problems nut I am unable to ping my domain.

    What I have noticed through if I look at the bind configs via terminal, both are set as master and use the same IP.

    I have told DNS2 to be a mirror of DNS1 via the ISPconfig wen interface.

    Please could some one point me in the right direction.

    Here is a brief overview of my system.

    Webserver and CP = 196.213.171.1 (example)
    Mail server = 196.213.171.2 (example)
    DB Server = 196.213.171.3 (example)
    DNS1 = 196.213.171.4 (example)
    DNS2 = 196.213.171.5 (example)

    DNS1 Named.conf.local file

    zone "ofthesea.net" {
    type master;
    allow-transfer {41.76.212.98;};
    file "/etc/bind/pri.ofthesea.net";

    DNS2 Named.conf.local file

    zone "ofthesea.net" {
    type master;
    allow-transfer {41.76.212.98;};
    file "/etc/bind/pri.ofthesea.net";
    };

    By looking at this it looks as if they are both acting as the master, how do I fix my setup?

    Thanks
     
  2. till

    till Super Moderator

    Your setup is fine, dns records are mirrored by ispconfig so both bind servers have to act as master and your config files show that it woks as expected. The problem that you can not ping your domain has a different reason, please post the content of the file /etc/bind/pri.ofthesea.net from one of your servers.
     
  3. beenfishing

    beenfishing New Member

    Thanks so much for you speedy reply.

    I have removed the DNS record and added it again.

    Please see below

    DNS1

    zone "ofthesea.net" {
    type master;
    allow-transfer {none;};
    file "/etc/bind/pri.ofthesea.net";

    DNS2


    zone "ofthesea.net" {
    type master;
    allow-transfer {none;};
    file "/etc/bind/pri.ofthesea.net";
    };

    pri.ofthesea.net

    @ IN SOA tuna.ofthesea.net. postmaster.ofthesea.net. (
    2012041103 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;

    mail 3600 A 41.76.212.92
    ofthesea.net. 3600 A 41.76.212.92
    ofthesea.net. 3600 MX 10 mail.ofthesea.net.
    ofthesea.net. 3600 NS tuna.ofthesea.net.
    ofthesea.net. 3600 NS yellowtail.ofthesea.net.
    www 3600 A 41.76.212.92
     
  4. till

    till Super Moderator

    The dns servers of the domain ofthesea.net are subdomains of the same domain, in such a case you have to add dns glue records in the dns server of the domain registry or in your case in the godaddy dns interface:

    http://en.wikipedia.org/wiki/Glue_record#Circular_dependencies_and_glue_records

    So the dns setup on your server is fine, its just a externalproblem that you have to fix at godaddy by adding glue records for tuna.ofthesea.net and yellowtail.ofthesea.net
     
  5. beenfishing

    beenfishing New Member

    DNS Problems

    I've done the correct setup at godaddy i think.

    I've attached a screenshot of my GoDaddy config.

    Really at a dead end here, can't seem to get this right.
     

    Attached Files:

  6. beenfishing

    beenfishing New Member

    Still battling with this if anyone has any suggestions.

    Just some more info.

    Output of "dig ofthesea.net" on tuna (dns1)


    ; <<>> DiG 9.7.0-P1 <<>> ofthesea.net
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 42704
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;ofthesea.net. IN A

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sat Apr 14 15:00:42 2012
    ;; MSG SIZE rcvd: 30


    Output of intodns.com

    http://www.intodns.com/ofthesea.net

    Please if anyone has any suggestions, I would be truly grateful.
     
  7. falko

    falko Super Moderator

    Did you create A records for tuna.ofthesea.net and yellowtail.ofthesea.net? Did oyu create NS records with tuna.ofthesea.net and yellowtail.ofthesea.net in your zone?

    Also, the glue records still seem to be missing. Unfortunately, I cannot help you with the GoDaddy interface because I don't use it myself. Maybe you should contact their support.
     

Share This Page