DNS problem

Discussion in 'Installation/Configuration' started by veuster, Jul 12, 2010.

  1. veuster

    veuster New Member


    I use a VPS that is installed with ISPConfig 3 and I plan to use it as a nameserver and also a webserver. Is this possible?

    I think it's possible if I conclude it from articles in the internet.

    I have a static public IP, and the server is configured as name server and web server according to this forum and some other website.

    Right now, I have a domain name that will be used as DNS and also for my website.
    Is this can be done? Do I have to own 2 domain names, one for DNS and one for website?

    There are no errors in my VPS and ISPconfig 3 also shows that everything's running well.
    I have registered my name server IP to my domain provider and sets it as primary DNS for my domain name, and use the default domain provider DNS as secondary and tertiary DNS.

    I waited for 2-3 days, because I read that DNS propagation needs time.
    But the domain name with or without www still points to default domain provider DNS.
    If I access my website through IP, the website is running and there's no error.

    I also can access my website through the name server host, example: ns1.domain.tld will open the website. From here, I think the name server registration works too. But it cannot point to the site if using www or without www.

    What seems to be the problem here?

    In ISPConfig 3 -> Server Config -> DNS, is there something I need to change? Because this is never shows up in tutorial/manual of ISPConfig 3, I left it with the default from installation
    Last edited: Jul 12, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats possible. ISPConfig is a controlpanel for web, mail and DNS servers.

    No, one is enough.

    Then your domain provider has not changed the ns records to point to your dns server. You should contact them an ask why they have not switched the domain to your dns server.

    To ensure that your local dns server is configured correctly, use this command:

    dig @localhost yourdomain.com

    Thast ok, there has nothing to be changed there normally.
  3. veuster

    veuster New Member

    More DNS question

    Thanks for the reply.

    There's something wrong with my last question
    I mean, in ISPConfig 3 -> System -> Server Config -> Server, is there some things to be changed? There is field for Gateway and Name Servers, this points to local address I think, like 192.168.x.x

    Also in ISPConfig 3 -> DNS -> DNS Zones, there is combo for Client. Is this need to be set to one of the client or leave it empty?

    This is the result for dig @localhost yourdomain.com :

    ;; Question Section:
    ;yourdomain.com. IN A
    ;; Answer Section:
    ;yourdomain.com. 86400 IN A x.x.x.x
    ;;Authority Section:
    ;yourdomain.com. 86400 IN NS ns1.yourdomain.com.
    ;yourdomain.com. 86400 IN NS ns2.provider.com.
    ;;Additional Section
    ;ns1.yourdomain.com. 86400 IN A x.x.x.x

    Is it OK? Do I have to delete hostname yourdomain.com. for NS record? Because in some example, I notice that they don't include it.

    I have contact my domain provider, but it seems I have to wait a while for their reply. I just want to make sure there's nothing wrong with my config.

    Just for information, there some important things that do not included in the perfect server setup. I'm using CentOS 5.5, I don't know if this happen in other distribution.
    1. The cron is not installed, so everything is not working in my first install, I install vixie-cron then everything runs.
    2. In System -> Server Config -> DNS, BIND zonefiles directory and BIND named.conf path needs to be changed to chrooted directory because default is pointing to /var/named. So I changed it to directory /var/named/chroot/var/named and path /var/named/chroot/etc/named.conf and also named.conf.local. After the change, the DNS is working.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thats ok. These settings are normally not used.

    This has only influence on who is able to edit the zone in ispconfig interface and not of the zone itself in the dns server.

    Yes thats ok. So the problem is not our server as I guessed already in my first answer. Talk to the domain registry and ask them why the have not cahnged the authority for the domain to your server yet.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Just for information, there some important things that do not included in the perfect server setup. I'm using CentOS 5.5, I don't know if this happen in other distribution.
    The setup is complete and nothing is missing as cron is always installed during the base setup if you do the fulle setup as described in the guide. Most likely you used a base setup of a provider that has not installed cron.

    The setup in the guide uses a non chrooted dns setup, so the bind-chroot package is not installed and the paths that ispconfig uses are correct for the centos setup. If your bind is chrooted, then you must have installed it either manually or you used the installation of a provider that installed this package.
  6. veuster

    veuster New Member

    some thought

    One more thing, I installed fail2ban and run it from the installation, but the GUI of fail2ban log said that fail2ban is not installed. why is this?
    Or this is because I haven't set any jail or fail2ban setting?

    About the cron, I think maybe you're right because VPS is already installed, I don't know what the default settings.
    But about ISPConfig 3 perfect server guide, I am sure I read that it installed a chrooted BIND9.

    This is the guide I used :

    Don't mean to argue your answer, just want to make it clear.
    Thanks a lot for your answers.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, you are right. the original manual that i've written as txt file uses a non chrooted bind.
  8. veuster

    veuster New Member

    global registry

    Still no solution to the DNS problem.

    One of the howto in this forum tells how to use own name server with fasthost.com.

    At the end of setting there's a line that says :
    "At the end of it, you MUST contact the domain provider and ask them to add your two name servers to the global registry."

    What is this means? Can this be the problem?

    I have tried to contact my domain provider, and they say that :
    "Global registries are turned off, the only way to turn it on if you are on a VPS"
    But as far as I know my domain provider doesn't provide VPS service, only hosting and colocation.

    So ,what is this mean? Can someone help me?

    The condition now is :
    I have a VPS and a domain name that I get from two different provider.
    In the domain name provider, I can register my name server (I think this what some people say "glue record") and assign it as nameserver for my domain. But the setting still doesn't work after almost a week now.

    Do I have to add the nameserver to global registry? If I do, how do I do that? I have to contact the domain name provider or VPS provider?

    I also found out that BIND uses port 53, and some articles say I should have been able to telnet to my server at port 53.
    I tried that and it failed. Does this mean that my BIND doesn't work or not?
    Last edited: Jul 15, 2010
  9. falko

    falko Super Moderator ISPConfig Developer

    Please post the outputs of
    netstat -tap
    netstat -uap
  10. veuster

    veuster New Member


    I just tried some solution from other thread that was answered by matty.

    It seems the permission to listening port need to be changed.

    He said to change named.conf file :
    listen-on port 53 {; }; // change parameter to any;

    allow-query { localhost; }; // change parameter to any;

    And now it worked.

    What I want to know now is :
    Is it OK? I mean I am not creating a security hole or anything dangerous, am I? :confused:

    Because I followed the perfect server guide and it says nothing about this change.

Share This Page