DNS Problem

Discussion in 'General' started by Rotty, Feb 19, 2007.

  1. Rotty

    Rotty New Member

    Hi,
    I have a problem with DNS.
    Test 1:
    When i execute: nslookup mydomain.com the server respond, but when i execute: google.com server respond ;; connection timed out; no servers could be reached.
    Test 2:
    Whe i send a mail with user in the same domain (mydomain.com), ISPConfig send email ok.But when i send with user resgiter in ISPConfig for (example) [email protected] the server not send email.The log of mail.log say this: type MX: Host not found,try again.

    Somebody knows that it happens?.
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Looks like you have not set your DNS forwarders. Which means you have a local DNS server that does not look at upstream DNS servers when required. Depends a bit on how you have setup your server, but adding
    Code:
    options {
            forwarders {
                    IP address1 of DNS server of your ISP;
                    IP address2 of DNS server of your ISP;
            };
    
    might help. Beware, there are multiple locations you can put these lines (I've put them in /etc/bind/named.conf.options) and there are alternative soltutions also. You need to test. Try to get the
    Code:
    nslookup google.com
    to work before trying to solve your mail problems.
     
  3. Rotty

    Rotty New Member

    Thanks to respond to me,
    I have done what you said to me, I´ve including the forwarders into named.conf.local, then i reboot the server.
    When server boot again i did this: nslookup google.com and i obtain the same message connection timed out; no servers could be reached.

    This is my configuration:
    /etc/resolv.conf:
    nameserver 192.168.0.5 << The IP of ISPConfig
    /etc/network/interface
    gateway 192.168.0.1 << IP of Gateway
     
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    There's no need to reboot a *nix server when you change options or even when you install a new or updated program. A restart of that specific program will do. To restart the name server
    Code:
    /etc/init.d/bind restart
    .
    Look in the log files to see if you have some errors. Log files can be found in /var/log. It depends a bit which distribution you use where to look. For Ubuntu it's /var/log/daemon, but /var/log/messages could also contain error messages. I assume you have entered the real IP numbers of your ISP's DNS servers.
     
  5. Rotty

    Rotty New Member

    Ok, i install webmin in ISPConfig.
    I configure in Servers > DNS BIND Server the fordwars to DNS-Servers.
    Now i can send a icmp-packet (ping) and resolv it.But the problem is the following one:
    The Mail.log say this:
    connect to gmail-smtp-in.l.google.com[66.249.93.27]: Connection timed out (port 25)
    What happend?.
     
  6. falko

    falko Super Moderator ISPConfig Developer

Share This Page