DNS problem with Wordpress MU

Discussion in 'Installation/Configuration' started by tonytroy, Nov 15, 2016.

  1. tonytroy

    tonytroy Member

    Hi there,

    On a Debian 8 install with ISP Config 3 i have a Wordpress multisites installed with a domain name called A. It worked until I add a new domain called B using wizard dns (on the same IP address). Now, all subdomain added to A are redirecting to B with 301.
    I checked my DNS conf and i saw wildcards added in A IP_ADDRESS, so i changed that to CNAME A_DOMAIN_NAME but it looks like problem is still there (I wait 2 hours, TTL is set to 3600).

    Do you have an idea to fix that problem ? Or a clue to help me look in the right direction ?

    If you need another other information, just ask :)

    Many thanks,
    Tony.
     
  2. Jesse Norell

    Jesse Norell Active Member

    If DNS resolves to the right ip address for your various domain/subdomain names your problem probably isn't there; 301 redirects come from the webserver, unrelated to DNS. Check the ip address set for site A and B, make sure they're either the same ip or both '*'.
     
  3. tonytroy

    tonytroy Member

    Thank you Jesse.

    I had 2 problems, the second one was because of the first one (and some changes in the DNS settings). So the DNS issue is now solved, but the redirect problem is still there. As i was on an emergency case, i bought another IP Address and delocated the second website on it, it worked.
    Now i have to find why when i add a website on the same IP address where i have a WPMU installed, all subdomains mapped on DN (using Domain Mapping extension) are redirecting to the new website.
     

Share This Page