DNS problem when modified zone

Discussion in 'Installation/Configuration' started by csubakka, Sep 10, 2012.

  1. csubakka

    csubakka New Member

    Hi!
    Sorry for my english.
    When modified zone settings (ex. set another IP address for a domain) in the bind configuration file is setup property (in pri.mydomain.hu)
    But when pinging the zone from outside, dosn't change anything.
    dig look like this:
    ; <<>> DiG 9.7.3 <<>> mail.mydomain.hu
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34518
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;mail.mydomain.hu. IN A

    ;; ANSWER SECTION:
    mail.mydomain.hu. 85676 IN A 212.92.23.140

    ;; AUTHORITY SECTION:
    mydomain.hu. 85676 IN NS ns.domain.hu.
    mydomain.hu. 85676 IN NS ns.domain.hu.

    the mail.mydomain.hu -s IP dosn't modified.
    Whats the problem?
    Many thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Changes in dns may take up to 24 hours until they get picked up by the dns caches. How long did you wait until you tested for the change?
     
  3. csubakka

    csubakka New Member

    Hi Till!
    30 minutes.
    But the nslookup command looks like dosen't change anything in localhost.
    The nslookup command output display the old IP address.
    Thanks.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are there any pending changes listed in the jobqueue of the ispconfig monitor and are there any errors for "named" in the /var/log/syslog file for this domain?

    Please check the local dns server with this command:

    dig @localhost mail.mydomain.hu

    replace just your domain name "mail.mydomain.hu" and leave the @localhost like it is used in my example.
     
  5. csubakka

    csubakka New Member

    The dig command output:
    Code:
    dig @localhost mail.flexiwebshop.hu
    
    ; <<>> DiG 9.7.3 <<>> @localhost mail.mydomain.hu
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7268
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mail.mydomain.hu.hu.          IN      A
    
    ;; ANSWER SECTION:
    mail.mydomain.hu.   86400   IN      A       95.140.**.***
    
    ;; AUTHORITY SECTION:
    mydomain.hu.hu.        86400   IN      NS      ns.something1.hu.
    mydomain.hu.hu.        86400   IN      NS      ns.something2.hu.
    
    ;; ADDITIONAL SECTION:
    ns.defauldomain.hu.         86400   IN      A       212.92.**.***
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Sep 10 19:24:42 2012
    ;; MSG SIZE  rcvd: 121
    
    In the answer section is the good IP.
    Csaba
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then the dns server has already the correct IP, so you might just have to wait until the caching servers all over the internet pick up the changes.
     
  7. csubakka

    csubakka New Member

    OK.
    Thanks!!!
     

Share This Page