DNS Problem! Help!

Discussion in 'General' started by grantus, Oct 18, 2008.

  1. grantus

    grantus New Member

    I have ISPConfig set up on my webserver. I have a few virtual hosts running on the server that are able to be accessed fine. Their A records are stored on a host that I'm paying for. My friend registered a domain but the service only allows for you to point it to a name server. A records and other stuff like that all costs extra money (www.123reg.com is the place).

    So I set up a DNS server on my server so that I could put in the address for his site and made sure that the name servers at 123reg.com for his domain pointed to my DNS server. When I do an nmap I can see port 53 is running (inside and outside of my network) and when I am on the server computer I can 'dig' my friend's site perfectly. The A records are coming up and all. However when outside the network I can't ping or find his site.

    I am not quite sure what is causing this. Anybody with ideas? I think my setup is fine. Does anybody have general set up information for the DNS manager in ISPConfig?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the real domain name so we can chack what's wrong in the dns configuration.

  3. grantus

    grantus New Member


    The domain name for my friend's site is www.failureatgoth.com and he has another site at photos.failureatgoth.com.

    For some reason my brother who is on my home network where the server is located can access the site by typing it in. I'm still not quite sure why the rest of the outside world can't see it. :(

    Ok as it turns out I think I found the problem. It was a problem with my server's DNS server. I used http://www.checkdns.net service and it said that the domain was pointing to the correct nameservers (server.grantandrews.co.uk and www.grantandrews.co.uk - which are in fact the same machine I just don't have two machines-only a primary - I know this is bad but I wasn't sure what else to do) But it failed when it tried to get the info from this server. It said possibly that the DNS server was down because it was not responding to the request. I'm not quite sure why the DNS server would not be running. It says in ISPConfig that it is running and when i do an external portscan (the server is on a network - all ports have been forwarded ) it says that it can see a service running on port 53, the domain port.

    So for some reason it can see a service on port 53, however when i checkdns.net it it says that the server is possibly down. I'm not sure why my DNS server is not working then. Is there anything i can try that might help fix this DNS server problem ?

    Currently I am using new DNS servers at FreeDNS so point the page to the right place and that seems to be working fine for now. But I would like to get my own DNS server running properly too.

    Thanks guys!
    Last edited: Oct 19, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    Is the server behind a router? If so, make sure that your router forwards port 53 (TCP and UDP) to your server.
  5. grantus

    grantus New Member

    Yes, I am. This could very well be the problem!
    I will change it around now and see what happens. I have to get my brother to do it so it might take a day or two to get done. But I will report back on the findings! Thank you very much! I hold high hope for this because from memory I only had TCP forwarded.
  6. grantus

    grantus New Member


    Yay! It works! :) Thank you so much falko!
    What a simple problem that was causing me all this grief. I had forgotten to put UDP incoming on as well as TCP! I'm so glad it's working now. You guys are genius. Won't be making that mistake again!


Share This Page