DNS Problem Cloudflare 15 seconds

Discussion in 'Installation/Configuration' started by S0ft, Jan 13, 2015.

  1. S0ft

    S0ft Member HowtoForge Supporter

    used ISPConfig Version:, wheezy server pefect
    Cloudflare FREE
    Cloudflare is a service that protects up to 500 gbps DDOS and improves the speed of the websites with a ping very low apart from hide your real IP

    my website without cloudflare first load approximately 2 seconds
    but since I put cloudflare load the first time approximately in 15 seconds.

    changed servers VPS accounts cloudflare also e, changed domains, and everything indicates that the problem is in the server DNS perfect ispconfig3, doesn't work for cloudflare there is a blockage and I don't know what it is

    Have anyone of you used cloudflare?
    the installation is not difficult

    Last edited: Jan 13, 2015
  2. durchd8.de

    durchd8.de Member

    Check with cloudflare in your panel at cloudflare.com - its important you got the DNS settings right at Cloudflare. Your delay/issue has most likely nothign to do with ISPConfig, since:
    1. With DNS at Cloudflare setup correctly, all visitors are redirected to Cloudflare servers.
    2. Cloudflare servers are essentially reverse NGINX proxies of your site. So once Cloudflare has your site cached, it is all cloudflare.

    Possible reasons for your issues:
    1. Your provider has a seriously bad connection to the next Cloudflare datacentre.
    2. Cloudflare has issues to retrieve your content (did you whitelist the cloudflare IP addresses for retrieval? Eg in your firewall on your server or fail2ban?)
    ignoreip =
    maxretry = 3
    destemail = [email protected]
    findtime = 600
    bantime = 6000
    3. Did you check security settings and Cache behaviour at Cloudflare?

    Cloudflare works perfectly fine here. Eg. http://faq-howto.com
  3. S0ft

    S0ft Member HowtoForge Supporter

    I am using

    Cloudflare creates DNS and says the real IP
    in my case:

    The first time charging 15 seconds (problem)
    the second time charge 1 second

    I thought it was the VPS, so I tried to try other VPS in France, Texas and Atlanta from different providers
    with ispconfig3

    I've also changed account cloudflare
    and at all the same thing happens

    It seems that there is something that blocks to cloudflare perfect server:
    the problem do not think to be in cloudflare
    It provides on a cpanel server of the provider free byethost.com and load in 3 seconds the first time

    Last edited: Jan 13, 2015
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It is very unlikely that your problem is related to ispconfig at all as ispconfig writes an apache standard vhost config file, ispconfig is not involved in delivring your website to the browser at all.

Share This Page