DNS or something

Discussion in 'Installation/Configuration' started by dahljh, Nov 2, 2005.

  1. dahljh

    dahljh New Member

    Well, I don't even know where to start. I fear I messed up things royally.

    Lets start with this:

    Under Management > Server > Settings
    The domain name can or can not be the same as a site I am planning to host?

    Under Management > Server > DNS
    All of the sites we are hosting are using multiple outside DNS servers. So what should we put here?
     
  2. dahljh

    dahljh New Member

    Here is my main issue: Email to the new ISPConfig server goes somewhere, but not to users email boxes.

    Here is a selection from my mail log.

    Setup - I sent a message from Yahoo ([email protected]) to one of my ISPConfig Hosting Clients ([email protected]).

    Code:
    Nov  2 02:30:26 WEBPRO postfix/smtpd[19862]: warning: connect to private/tlsmgr: No such file or directory
    Nov  2 02:30:27 WEBPRO postfix/smtpd[19862]: warning: connect to private/tlsmgr: No such file or directory
    Nov  2 02:30:27 WEBPRO postfix/smtpd[19862]: warning: problem talking to server private/tlsmgr: No such file or directory
    Nov  2 02:30:27 WEBPRO postfix/smtpd[19862]: warning: no entropy for TLS key generation: disabling TLS support
    Nov  2 02:30:27 WEBPRO postfix/smtpd[19862]: connect from web30501.mail.mud.yahoo.com[68.142.200.114]
    Nov  2 02:30:28 WEBPRO postfix/smtpd[19862]: warning: support for restriction "check_relay_domains" will be removed from Postfix; use "reject_unauth_destination" instead
    Nov  2 02:30:28 WEBPRO postfix/smtpd[19862]: 0C0EC2FEBE: client=web30501.mail.mud.yahoo.com[68.142.200.114]
    Nov  2 02:30:28 WEBPRO postfix/cleanup[19866]: 0C0EC2FEBE: message-id=<[email protected]>
    Nov  2 02:30:28 WEBPRO postfix/qmgr[15658]: 0C0EC2FEBE: from=<[email protected]>, size=1221, nrcpt=1 (queue active)
    Nov  2 02:30:28 WEBPRO postfix/smtpd[19862]: disconnect from web30501.mail.mud.yahoo.com[68.142.200.114]
    Nov  2 02:30:28 WEBPRO postfix/pickup[15657]: 639982FEC6: uid=10035 from=<smt13_FredFlintstone>
    Nov  2 02:30:28 WEBPRO postfix/cleanup[19866]: 639982FEC6: message-id=<[email protected]>
    Nov  2 02:30:28 WEBPRO postfix/qmgr[15658]: 639982FEC6: from=<[email protected]>, size=427, nrcpt=1 (queue active)
    Nov  2 02:30:28 WEBPRO postfix/local[19890]: 639982FEC6: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov  2 02:30:28 WEBPRO postfix/qmgr[15658]: 639982FEC6: removed
    Nov  2 02:30:32 WEBPRO postfix/local[19867]: 0C0EC2FEBE: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=5, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov  2 02:30:32 WEBPRO postfix/qmgr[15658]: 0C0EC2FEBE: removed
    I have no idea where the email went, but it's not in the users mailbox.

    I also don't know who "admispconfig@" is.

    Here is my netstat.

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    tcp        0      0 *:mysql                 *:*                     LISTEN
    tcp        0      0 *:sunrpc                *:*                     LISTEN
    tcp        0      0 *:hosts2-ns             *:*                     LISTEN
    tcp        0      0 WEBPRO.MyServer:domain *:*                     LISTEN
    tcp        0      0 localhost:domain        *:*                     LISTEN
    tcp        0      0 *:ftp                   *:*                     LISTEN
    tcp        0      0 localhost:953           *:*                     LISTEN
    tcp        0      0 *:smtp                  *:*                     LISTEN
    tcp        0      0 *:pop3                  *:*                     LISTEN
    tcp        0      0 *:imap                  *:*                     LISTEN
    tcp        0      0 *:www-http              *:*                     LISTEN
    tcp        0      0 *:ssh                   *:*                     LISTEN
    tcp        0      0 localhost:953           *:*                     LISTEN
    tcp        0      0 *:smtp                  *:*                     LISTEN
    tcp        0      0 *:https                 *:*                     LISTEN
    tcp        0   2000 WEBPRO.smarttechnol:ssh 33-pool1.ras06.or:62176 ESTABLISHED
    tcp        0      0 WEBPRO.smarttechnol:ssh 2-pool2.ras06.ord:62465 ESTABLISHED
    IPv6/IPv4 Group Memberships
    Interface       RefCnt Group
    --------------- ------ ---------------------
    lo              1      ALL-SYSTEMS.MCAST.NET
    eth0            1      ALL-SYSTEMS.MCAST.NET
    lo              1      ipv6-allnodes
    eth0            1      ff02::1:ffa8:53a6%1074217068
    eth0            1      ipv6-allnodes
    I don't know what else to do. Thanks for your help in advance.
     
  3. dahljh

    dahljh New Member

    Here is my echo localhost:

    Code:
    Connected to localhost.
    Escape character is '^]'.
    220 webpro.MyNewServer ESMTP Postfix
    ehlo localhost
    250-webpro.MyNewServer.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250 8BITMIME
    My ISP does not block port 25

    My ISPConfig Server is set in a DMZ at the moment so I don't have any firewall issues.

    My ISPConfig server has one IP address and it is static (outside) address.

    (I have been reading through the forums and am trying to give the info I see asked alot)

    I am using the SUSE 10 Perfect install to the letter.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    It can be the same, but the servername should be different from the web site's full address. So the servername can be server1.domain.com, whereas the web site's full address is www.domain.com.

    If you don't use the DNS-Manager in ISPConfig you can leave these settings untouched.

    First edit /etc/postfix/main.cf and replace check_relay_domains with reject_unauth_destination in smtpd_recipient_restrictions. Restart Postfix afterwards.
    Did you enable/disable Maildir under Management -> Server -> Settings -> Email? If your POP3 daemon is Courier, then you have to activate Maildir, if it's not, then you probably have to disable it.

    The emails to admispconfig are used to create the email traffic statistics in ISPConfig. Nothing to worry about.
     
  5. dahljh

    dahljh New Member

    Here is my main.cf

    Code:
    disable_dns_lookups = no
    relayhost =
    mailbox_command =
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = yes
    smtpd_use_tls = yes
    smtp_use_tls = yes
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    mydomain = smarttechnologyservices.com
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_tls_auth_only = no
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
     
  6. dahljh

    dahljh New Member

    Changed what you suggested and rebooted the server.

    I am using courier and I do have the MailDir enabled.

    Here is the current mail log after the reboot.

    Code:
    Nov  2 03:24:41 WEBPRO pop3d: bind: Address already in use
    Nov  2 03:24:53 WEBPRO postfix/postfix-script: starting the Postfix mail system
    Nov  2 03:24:53 WEBPRO postfix/master[5644]: daemon started -- version 2.2.5, configuration /etc/postfix
    Nov  2 03:26:01 WEBPRO postfix/smtpd[6012]: warning: connect to private/tlsmgr: No such file or directory
    Nov  2 03:26:02 WEBPRO postfix/smtpd[6012]: warning: connect to private/tlsmgr: No such file or directory
    Nov  2 03:26:02 WEBPRO postfix/smtpd[6012]: warning: problem talking to server private/tlsmgr: No such file or directory
    Nov  2 03:26:02 WEBPRO postfix/smtpd[6012]: warning: no entropy for TLS key generation: disabling TLS support
    Nov  2 03:26:07 WEBPRO postfix/smtpd[6012]: connect from web30502.mail.mud.yahoo.com[68.142.200.115]
    Nov  2 03:26:07 WEBPRO postfix/smtpd[6012]: B7C122FEBE: client=web30502.mail.mud.yahoo.com[68.142.200.115]
    Nov  2 03:26:07 WEBPRO postfix/cleanup[6016]: B7C122FEBE: message-id=<[email protected]>
    Nov  2 03:26:07 WEBPRO postfix/qmgr[5666]: B7C122FEBE: from=<[email protected]>, size=1209, nrcpt=1 (queue active)
    Nov  2 03:26:07 WEBPRO postfix/smtpd[6012]: disconnect from web30502.mail.mud.yahoo.com[68.142.200.115]
    Nov  2 03:26:08 WEBPRO postfix/pickup[5665]: 474D32FEC6: uid=10035 from=<smt13_FredFlintstone>
    Nov  2 03:26:08 WEBPRO postfix/cleanup[6016]: 474D32FEC6: message-id=<[email protected]>
    Nov  2 03:26:08 WEBPRO postfix/qmgr[5666]: 474D32FEC6: from=<[email protected]>, size=427, nrcpt=1 (queue active)
    Nov  2 03:26:08 WEBPRO postfix/local[6040]: 474D32FEC6: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov  2 03:26:08 WEBPRO postfix/qmgr[5666]: 474D32FEC6: removed
    Nov  2 03:26:15 WEBPRO postfix/local[6017]: B7C122FEBE: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=8, status=sent (delivered to command: /usr/bin/procmail -f-)
    Still no email in the users inbox.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Have a look at the directory /var/spool/mail. Dos the emails arrive there in mbox files?

    2) Did you get sort of mbox files in the /tmp/ directory when you send an email and these files stayed in /temp after maildelivery is finished?
     
  8. dahljh

    dahljh New Member

    in the /var/spool/mail directory there is something named SMT13_FredFlintstone

    I don't know where to check this. I can not find a /temp directory. There is nothing in the /tmp though.

    I don;t think I understand what you mean by mbox?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    According to the last line of your log the mail has been sent. Can you check the file /var/spool/mail/SMT13_FredFlintstone if the email is in there?

    Regarding the tls problems in the log: maybe this helps you: http://www.howtoforge.com/forums/showthread.php?t=781
     
  10. dahljh

    dahljh New Member

    I have 2 files in the var/spool/mail/: SMT13_FredFlintstone and admispconfig.

    I dont know what they are, they are not directories.
     
  11. dahljh

    dahljh New Member

    That fixed it, thanks.

    And thanks in advance for the help, I have a production mail server thats on it's last legs and if possible I wanted to switch to hits ISPConfig/linux box.
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Can you open the file and have a look at its content?
     
  13. dahljh

    dahljh New Member

    I used edit to open it and it is empty.

    But !!! (and now you guys can add me to the newbie hall of fame)

    I have been trying to check this account through Outlook with the username FredFlintstone, which didn't give me any errors, but there were no emails either.

    Out of curiosity I logged in to the webmail with FredFlintstone and there are no emails, and it lets me log in.

    Now, I log in as smt13_FredFlintstone and low and behold there are all my emails. How dumb do I feel

    How come it's letting me log in as FredFlintstone? There is only 1 email user under this domain and it is smt13_FredFlintstone but the email address is [email protected].
     
  14. falko

    falko Super Moderator ISPConfig Developer

    That alright.

    When you use an email client such as Outlook you have to use the username (smt13_FredFlintstone), when you use Uebimiau webmail (the ISPConfig webmail package) you have to use the user's email address as login.
     
  15. dahljh

    dahljh New Member

    Is there any way to make every client (outlook, etc..) use the email address to log on with?

    Customers need to have things as simple as possible, I can see our support desk calls rising if we have 2 different ways.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    This will be possible starting with version 3 of ISPConfig which is currently in development. :)
     
  17. dahljh

    dahljh New Member

    Ok,

    and Thank you guys very much for the help. I better get some sleep now. I have to get up in an hour for work.
     

Share This Page