DNS on lan - cannot make it work

Discussion in 'General' started by orasis, Apr 25, 2012.

  1. orasis

    orasis Member

    I am trying this a long time and I always give up.
    Today I want to make it work because I lose a lot..

    well what I want to do is to make the dns in ispconfig 3 take care (on the lan) of the domains I create so that I don't need to enter them in my workstation's hosts file everytime, or even it's subdomains etc.

    I have read various of posts and tutorials here but none is talking about lan. I run ubuntu 10.04 and have created a dns zone using the wizard with the following:

    Domain: example.lan
    IP Address: 192.168.0.200 <--this is the lan ip of the ispconfig server (remember I want this to work on lan and not externally).
    NS1: ns1.example.lan
    NS2: ns2.example.lan

    then I create the site with domain example.lan

    ok now as I can imagine, I am maybe wrong, I can use the hosts file of my workstation to point maybe to the nameservers. So I tried something like this:

    192.168.0.200 myispconfig.server

    192.168.0.200 ns1.example.lan
    192.168.0.200 ns2.example.lan

    now If I go to the browser and hit example.lan -> nothing
    the only way to see the welcome page is to go back to:

    192.168.0.200 example.lan www.example.lan sub.example.lan ..etc

    I have created various ips for the the server at "Server IP Addresses" and the good part is that I can see those IPs showing in my router pointing to the server computer.

    maybe it is impossible, but I would like to know at least.
    please help me with this if you can.
    thanks!
     
  2. Ghostdare

    Ghostdare Member

    I think that you must make every computer from the lan to interogate your ns servers as DNS
     
  3. orasis

    orasis Member

    thanks for the reply, if I understand well you mean that "as a solution" to this you find to stop having a lan all together ? or do I need to use a second router ?
     
    Last edited: Apr 26, 2012
  4. Horfic

    Horfic Member

  5. orasis

    orasis Member

    yes I have disabled dhcp on the router, and also added to the dns entries the ispconfig server's ip instead of my ISP's ones without any success so far.

    let me check your link and get back to ya.
     
  6. till

    till Super Moderator

    Have you tested the dns records on the server with:

    dig @localhost example.lan

    and checked the syslog file for BIND errors?
     
  7. orasis

    orasis Member

    till, the above command returns:
    Code:
    dig: couldn't get address for 'localhost.example.lan': not found
    the /var/log/syslog shows no errors.

    take a look at the attachments, how I have ispconfig and router setup right now.

    Question: At 'Server Config' there is the field "Nameserver". right now I have my ISP's there, is that wrong ? Those are already in /etc/resolv.conf though
     

    Attached Files:

    Last edited: Apr 26, 2012
  8. orasis

    orasis Member

    ok I made it work. I had to add the following that was missing. check attachments. My question now is though, why till's command returns "not found" still, and what I should put at the "Nameservers" at "Server Config" ? As I remember, ispconfig had by default "192.168.0.1,192.168.0.2"
     

    Attached Files:

  9. orasis

    orasis Member

    my friend I finally did :) those ns1 and ns2 were missing, and I always forgot to add to the client computer network settings the server dns ips.
     

Share This Page