DNS not written

Discussion in 'General' started by MaxT, Mar 25, 2015.

  1. MaxT

    MaxT Member

    DNS is not written. I follow the debug procedure:
    commenting:
    Code:
    #crontab -e
    #* * * * * /usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done
    then:
    Code:
    # /usr/local/ispconfig/server/server.sh
    finished.
    It seems the debug is not working. Where can I trace the failure?

    And please, 2 more questions:
    - When I make a manual change inside /etc/bind/pri.mydomain.com, I cannot see these changes inside ISPConfig. It seems ISPConfig is not reading the DNS zones.

    - It is possible to delete a client without losing its associated websites?. I don't know if these websites would be moved from /var/www/clients/client1/webX to /var/www/webX.
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You set the loglevel to debug before running server.sh manually?
    Ispconfig never reads configfiles. You can change your configs with ispconfig and the changes will be written to disk.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You can change the owner of the website to the admin user or another client and thend elete the old client.
     
  4. MaxT

    MaxT Member

    yes, I have checked "Debug" without success. However, now I have changed $conf["log_priority"] = 0 inside /usr/local/ispconfig/server/lib/config.inc.php and now it works.

    When I enter in the website section, I cannot see the admin user in the "Client" in the drop down menu. Only the rest of users. Also I have an option to leave it in blank (?). That's normal?

    Also, I'm trying to configure one server with two IPs. The second IP is the ns2 zone of the server and also it belongs to a website. It has a reverse PTR (server2.domain2.com). The server is already well configured with both ip's and it is working without errors.

    So I have the typical "server1.domain1.com" -> 111.111.111.111 and "server2.domain2.com" -> 222.222.222.222

    However, I cannot find a way to reflect inside ISPConfig the presence of this secondary ip (server2.domain2.com). I'm reading this guide:
    https://www.howtoforge.com/how-to-r...-secondary-with-ispconfig-3-debian-squeeze-p2
    However, when I go to System > Server Services, I don't see the second server as the guide shows:

    [​IMG]

    Therefore, I only have the option to point server1.domain1.com -> 222.222.222.222 in System->Server Ip adresss. The server works with boith ip. Although ISPConfig is not reflecting the DNS zone files which are manually configured. There is not DNS errors in reports although I want to reflect the presence of server2.domain2.com in ISPConfig. However, I have no option to do it inside "Sytem ->Server services" and "System->Server config"

    Where is the option to include it?

    lot of thanks!
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats correct. You have to set the client field to "empty" when the site shall be owned by no client which means that the site is owned by the admin directly.

    Thats correct and intended. The zone files are managed by ISPConfig only, you may not edit them manually. If you want to change a dns zone, then do that in ispconfig. If you want to manage dns files manually, then ensure that you disable the ispconfig dns module completely for this server first.

    Just add both IP addresses under syestem > server IP. You can select the server fr which the IP address is there as well.
     
  6. MaxT

    MaxT Member

    ...but the second server is missing. This is what I do:

    1 - I go to:
    System -> Server IP Addresses
    Code:
    server1.domain1.com      IPv4    222.222.222.222    80,443  
    server1.domain1.com      IPv4    111.111.111.111     80,443  
    
    2 - then I click in 222.222.222.222 to assign server2.domain2.com:
    IP Addresses
    Code:
    Server                 server1.domain1.com  (in this dropdown there is no option serve2.domain2.com)
    Client 
    Type                   IPV4
    IP Address             222.222.222.222
    HTTP NameVirtualHost (x)
    HTTP Ports              80,443
    
    ... there is no option in the dropdown for the second server. And I cannot write inside this field. It seems the ISPConfig still doesn't know the second IP 222.222.222.222 belongs to server2.domain2.com.

    However, the server2.domain2.com is already present in dns zone files and hosts files. These are my server related files:

    /etc/hosts:
    Code:
    127.0.0.1  localhost
    111.111.111.111  server1.domain1.com
    222.222.222.222  server2.domain2.com
    
    /etc/bind/pri.server2.domain2.com
    Code:
    $TTL  300
    server2.domain2.com.  IN  SOA  ns2.domain1.com. root.domain2.com. (
      2015031607
      7200
      540
      604800
      86400 )
    ;
    server2.domain2.com. 3600  IN  NS  ns1.server1.com.
    server2.domain2.com. 3600  IN  NS  ns2.server1.com.
    server2.domain2.com. 3600  IN  A  222.222.222.222
    localhost  14400  IN  A  127.0.0.1
    
    server2.domain2.com. 3600  IN  MX  0  server2.domain2.com.
    www  14400  IN  CNAME  server2.domain2.com.
    ns2  14400  IN  A  222.222.222.222
    server2.domain2.com.  IN  A  222.222.222.222
    
    The DNS reports show me 0 errors, the PTR are fully right. ISPConfig is not detecting this?.

    In that case, Where is the option inside ISPConfig to establish the association (server2.domain2.com -> 222.222.222.222)?.


    thanks again!
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The IP address setting is for apache / nginx. Your second server ahs no webserver and therefor it does not get displayed in the list.
     
  8. MaxT

    MaxT Member

    I'm sorry but I 'm not sure if I understand the solution.

    I have access to http://serv2.domain2.com and http://222.222.222.222
    Or do you point to a different issue?

    Or do you mean the apache server belongs to the primary ip threfore there is not any problem at all?

    Thanks again for the help. I'm really blocked with this :(


    I'm reading here about updating the ISPConfig database in the installation process to allow a secondary server:

    "Make sure you replace 1.2.3.5 with the IP address and server2.example.com with the hostname of your secondary DNS server!"

    *** "2 Setting Up server1.example.com (Primary DNS)": https://www.howtoforge.com/how-to-r...and-secondary-with-ispconfig-3-debian-squeeze

    I didn't make such thing in the installation process. It can have some relation with this problem?
     
    Last edited: Mar 25, 2015

Share This Page