DNS not working with ISPconfig3

Discussion in 'Installation/Configuration' started by melkij22, Apr 18, 2012.

  1. melkij22

    melkij22 New Member

    Hi all,
    I have question about DNS. I'm using opensuse 12.1 OS.
    Also I have one server which is connected to internet via router with DMZ. ( I can connect to server and do whatever I want via external IP address ).
    I have installed mydns and fresh install of ispconfig 3. ( done everything like was written in Perfect server guide )
    Then I changed ns1 and ns2 at my domain registrator to :
    ns1.mydomain.com ip : myexternalip
    ns2.mydomain.com ip : myexternalip

    Then I made dns records in ispconfig -> dns :
    DNS Zone :
    Code:
    Zone ( SOA ) mydomain.com
    NS ns1.mydomain.com
    Email info@mydomain.com
    Refresh 7200
    Retry 540
    Expire 604800
    Minimum 86400
    TTL 3600
    
    And records :
    Code:
    	A 	mydomain.com. 	MyExternalIP 	0 	
    	A 	mail 	MyExternalIP 	0 	
    	A 	www 	MyExternalIP 	0 	
    	MX 	mydomain.com. 	mail.mydomain.com. 	10 	
    	NS 	mydomain.com. 	ns1.mydomain.com. 	0 	
    	NS 	mydomain.com. 	ns2.mydomain.com. 	0
    
    Then I tryed to ping mydomain.com, but it is written :
    Ping request could not find host mydomain.com. Please check the name and try again.


    and here is dig
    Code:
     <<>> DiG 9.8.1-P1 <<>> mydomain.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 38417
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mydomain.com.                        IN      A
    
    ;; Query time: 48 msec
    ;; SERVER: 192.168.1.254#53(192.168.1.254)
    ;; WHEN: Fri May 18 10:10:50 2012
    ;; MSG SIZE  rcvd: 32
    
    
    
    What should I check or do?
    Thanks
     
  2. melkij22

    melkij22 New Member

    I managed to make it working. Just mydns was not working. :) so port 53 was closed.
    Now another question - I have made domain and added website, but there is a problem - when I'm connecting from my ftp to domain and changed index file, browser still showing old ( standart ) index page not my new, why?
     
  3. till

    till Super Moderator

    If you uploaded a new index file,please ensure that you deleted the default index.html file from ispconfig.
     
  4. melkij22

    melkij22 New Member

    yes, I done it. Firstly deleted old index file, then uploaded new. Problem still exists
     
  5. till

    till Super Moderator

    Ensure that you enabled auto subdomain ww in the website settings. Also your dns records are incomplete, the a-records for ns1 and ns2 are missing.
     
  6. melkij22

    melkij22 New Member

    autosubdomain - www was enabled. I have added ns1 and ns2 A records, still problem the same
     
  7. till

    till Super Moderator

    Dekete all files with the name "index.html" in the "web" directory of the website as root user. Then restart apache and try again.
     
  8. melkij22

    melkij22 New Member

    I have done it. Still problem exists.
    I have created another domain and ftp user, when I'm connecting via ftp manager I can see that ipconfig creating everything fine, but when I'm browsing first or second domain I still see this standard index page ( but it is deleted from first and second domain )
     
  9. melkij22

    melkij22 New Member

    As I see in FTP options - my site should be in /srv/www/clients/client1/web1 but when I'm opening that dir it's showing me that can't access that dir and there is no index file ( but in ftp I see index file )
     
  10. till

    till Super Moderator

    The website dir is /srv/www/clients/client1/web1/web and not /srv/www/clients/client1/web1 and in /srv/www/clients/client1/web1/web/ there must be a file named index.html and this file has to be deleted.
     
  11. iulianbrinzoi

    iulianbrinzoi New Member

    DNS Fix!

    Try to change template of old DNS to this new template code.
    Work perfectly!
    [ZONE]
    origin={DOMAIN}.
    ns=ns1.{DOMAIN}.
    mbox={EMAIL}.
    refresh=28800
    retry=7200
    expire=604800
    minimum=86400
    ttl=86400

    [DNS_RECORDS]
    A|{DOMAIN}.|{IP}|0|86400
    A|www|{IP}|0|86400
    A|mail|{IP}|0|86400
    A|{NS1}.|{IP}|0|86400
    NS|{DOMAIN}.|{NS1}.|0|86400
    MX|{DOMAIN}.|mail.{DOMAIN}.|10|86400

    Julian the king!
     

Share This Page