1. Hi All,

    I have 2 nodes
    node1.clusterenv.com 192.20.20.11
    node2.clusterenv.com 192.20.20.21

    DNS is configured on node1.clusterenv.com

    Everything works fine except I'm not able to do nslookup from node1.clusterenv.com (where the dns daemon is running).

    The Bind Version I'm running id :- "BIND 9.3.6-P1-RedHat-9.3.6-4.P1.el5"

    Please find the attached named.conf file and other associated files.

    Looking forward to hear from you all

    Thanks and Regards
    Nidhin Tomson
     

    Attached Files:

    Last edited: Feb 16, 2012
  2. falko

    falko Super Moderator ISPConfig Developer

    Does
    Code:
    dig @localhost clusterenv.com
    work?

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    netstat -uap
    ? Any errors in your logs?
     
  3. Hi Falko,

    Thanks for your response.

    Please find below the requested o/p :-

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:2208 *:* LISTEN 3218/hpiod
    tcp 0 0 *:nfs *:* LISTEN -
    tcp 0 0 *:vce *:* LISTEN 3774/ricci
    tcp 0 0 node1.clusterenv.com:21064 *:* LISTEN -
    tcp 0 0 *:814 *:* LISTEN 2752/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 2654/portmap
    tcp 0 0 node1.clusterenv.com:http *:* LISTEN 3426/httpd
    tcp 0 0 *:16851 *:* LISTEN 3576/modclusterd
    tcp 0 0 *:47923 *:* LISTEN -
    tcp 0 0 *:948 *:* LISTEN 3313/rpc.mountd
    tcp 0 0 node1.clusterenv.com:domain *:* LISTEN 5127/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 5127/named
    tcp 0 0 *:917 *:* LISTEN 3281/rpc.rquotad
    tcp 0 0 *:telnet *:* LISTEN 3259/xinetd
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 3245/cupsd
    tcp 0 0 *:50008 *:* LISTEN 2885/ccsd
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 5127/named
    tcp 0 0 localhost.localdomain:smtp *:* LISTEN 3405/master
    tcp 0 0 localhost.localdomain:2207 *:* LISTEN 3223/python
    tcp 0 0 node1.clusterenv.com:41539 192.20.20.31:iscsi-target ESTABLISHED 2397/iscsid

    [[email protected] ~]# netstat -uap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    udp 0 0 *:nfs *:* -
    udp 0 0 localhost.localdomain:57232 localhost.locald:domain ESTABLISHED 3576/modclusterd
    udp 0 0 *:914 *:* 3281/rpc.rquotad
    udp 0 0 node1.clusterenv.com:63771 198.41.0.4:domain ESTABLISHED 5127/named
    udp 0 0 node1.cluste:netsupport *:* 2891/aisexec
    udp 0 0 node1.clusterenv.com:5149 *:* 2891/aisexec
    udp 0 0 239.192.83.8:netsupport *:* 2891/aisexec
    udp 0 0 node1.clusterenv.com:55975 198.41.0.4:domain ESTABLISHED 5127/named
    udp 0 0 *:eek:mirr *:* 2752/rpc.statd
    udp 0 0 *:811 *:* 2752/rpc.statd

    [[email protected] ~]# dig @localhost clusterenv.com

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> @localhost clusterenv.com
    ; (1 server found)
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached
    [[email protected] ~]#


    ======================

    There is no specific error messages in /var/log/messages regarding the dns..
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Your BIND isn't listening on port 53 UDP. Please correct it.
     
  5. Hi Falko,

    I have added the "listen-on port" keyword to the global options in named.conf. assuming it will enable my named to listen on udp port 53.

    ==========================================
    listen-on port 53 {
    127.0.0.1 port 53;
    192.20.20.11 port 53;
    };
    ==========================================

    I have already disabled the firewall and selinux for this host.
    even then i get the same timeout error for local nslookup.
    Could you help me figure-out the cause behind my issue.
    below I'm pasting my netstat and nslookup outputs..

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:2208 *:* LISTEN 3231/hpiod
    tcp 0 0 *:961 *:* LISTEN 3326/rpc.mountd
    tcp 0 0 *:nfs *:* LISTEN -
    tcp 0 0 *:930 *:* LISTEN 3294/rpc.rquotad
    tcp 0 0 *:vce *:* LISTEN 3720/ricci
    tcp 0 0 node1.clusterenv.com:21064 *:* LISTEN -
    tcp 0 0 *:58091 *:* LISTEN -
    tcp 0 0 *:sunrpc *:* LISTEN 2687/portmap
    tcp 0 0 node1.clusterenv.com:http *:* LISTEN 3439/httpd
    tcp 0 0 *:16851 *:* LISTEN 3588/modclusterd
    tcp 0 0 node1.clusterenv.com:domain *:* LISTEN 4509/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 4509/named
    tcp 0 0 *:telnet *:* LISTEN 3272/xinetd
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 3258/cupsd
    tcp 0 0 *:50008 *:* LISTEN 2897/ccsd
    tcp 0 0 *:824 *:* LISTEN 2762/rpc.statd
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 4509/named
    tcp 0 0 localhost.localdomain:smtp *:* LISTEN 3418/master
    tcp 0 0 localhost.localdomain:2207 *:* LISTEN 3236/python


    [[email protected] ~]# netstat -uap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    udp 0 0 *:nfs *:* -
    udp 0 0 node1.cluste:netsupport *:* 2903/aisexec
    udp 0 0 node1.clusterenv.com:5149 *:* 2903/aisexec

    udp 0 0 239.192.83.8:netsupport *:* 2903/aisexec
    udp 0 0 *:927 *:* 3294/rpc.rquotad
    udp 0 0 *:38562 *:* 3524/avahi-daemon:
    udp 0 0 *:818 *:* 2762/rpc.statd
    udp 0 0 node1.clusterenv.com:domain *:* 4509/named
    udp 0 0 localhost.locald:domain *:* 4509/named
    udp 0 0 *:821 *:* 2762/rpc.statd
    udp 0 0 *:958 *:* 3326/rpc.mountd
    udp 0 0 *:tftp *:* 3272/xinetd
    udp 0 0 *:44369 *:* -
    udp 0 0 node1.clusterenv.com:34909 198.41.0.4:domain ESTABLISHED 4509/named
    udp 0 0 *:mdns *:* 3524/avahi-daemon:
    udp 0 0 *:sunrpc *:* 2687/portmap
    udp 0 0 localhost.localdomain:34419 localhost.locald:domain ESTABLISHED 3588/modclusterd
    udp 0 0 *:ipp *:* 3258/cupsd

    [[email protected] ~]# dig @localhost clusterenv.com

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> @localhost clusterenv.com
    ; (1 server found)
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached
    [[email protected] ~]#
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That looks good.

    What's the output of
    Code:
    iptables -L
    ?
     
  7. Hi Falko,

    Please find the requested o/p.

    [[email protected] ~]# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    [[email protected] ~]#

    ===================

    By default I have set iptables/selinux to disable status.But still i'm getting same "connection timeout error" when i try to do nslookup from localhost.
    See below the latest nslookup o/p.

    [[email protected] ~]# nslookup node51
    ;; connection timed out; no servers could be reached

    [[email protected] ~]#



    Please suggest me how to proceed further.

    Thanks and Regards
    Nidhin Tomson
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Hm, looks good as well. What's the output of
    Code:
    getenforce
    ?
     

Share This Page