DNS not found for 1 domain

Discussion in 'General' started by jcombs_31, Oct 20, 2011.

  1. jcombs_31

    jcombs_31 New Member

    I have one domain that doesn't want to resolve for some reason. I've deleted and recreated the zone with the wizard.

    If I run dig domain.com on the server I can see the A record exists. If I run dig from my home machine I'm getting a failure. The nameservers are correct and whois shows them as correct. I'm using BIND with Debian Lenny.

    If i look in /etc/bind/ I see pri.domain.com which I've compared to others and it looks fine.

    Any advice on where to go from here.
     
  2. till

    till Super Moderator

    If you query the local server with dig and it returns the correct record, then your problem is not the bind configuration file of the domain.

    There are several possible problems:

    1) Bind is not listening on the external interface.
    2) A firewall is blocking the bind port.
    3) The dns change has not been propagated.

    for 1+2) Post the output of:

    netstat -tap

    and

    iptables -L

    For 3), wait 24 hours. But only if 1+2 dont show any problems :)
     

Share This Page