DNS Not being updated

Discussion in 'Installation/Configuration' started by allwayson, Sep 12, 2006.

  1. allwayson

    allwayson New Member

    I am very new to both Linux and ISPConfig. I recently followed the instructions for the perfect setup of Fedora 5 and then the instructions for ISPConfig. Everything seemed to work perfectly and it really looks like this is going to work very well for me. I am very excited about the concepts here. I do however have a problem. For some reason everything seems to be working except DNS BIND9 is not being changed when I add sites or records directly into ISPConfig. I have searched the forums but have not found anyone having this particular issue? I don't know what information you might need to help be troubleshoot this so please guide me here. Otherwise the setup is exactly as the perfect setup for Fedora 5 suggests and then install of ISPConfig went without any errors. This is a brand new setup on a brand new box if that helps at all.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is BIND started? Please post the output of: netstat -tap

    Is the named configuration in /var/named/chroot/etc/ changed? Please check the named.conf
  3. allwayson

    allwayson New Member

    Looks to be running

    BIND is running and will respond to queries. Here is the netstat output:

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:56642 *:* LISTEN 1563/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 1888/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1545/portmap
    tcp 0 0 *:hosts2-ns *:* LISTEN 2170/ispconfig_http
    tcp 0 0 *:* LISTEN 12030/named
    tcp 0 0 tao.myipowersite.net:domain *:* LISTEN 12030/named
    tcp 0 0 tao:domain *:* LISTEN 12030/named
    tcp 0 0 tao:ipp *:* LISTEN 3853/cupsd
    tcp 0 0 tao:rndc *:* LISTEN 12030/named
    tcp 0 0 *:smtp *:* LISTEN 18363/master
    tcp 0 0 *:imaps *:* LISTEN 1918/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 1918/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 1918/dovecot
    tcp 0 0 *:imap *:* LISTEN 1918/dovecot
    tcp 0 0 *:http *:* LISTEN 13834/httpd
    tcp 0 0 *:ftp *:* LISTEN 2329/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 1784/sshd
    tcp 0 0 *:https *:* LISTEN 13834/httpd
    tcp 0 2372 tao.myipowersite.net:ssh 24-247-97-100.dhcp.ald:5482 ESTABLISHED 28579/0
    [[email protected] ~]#

    The named.conf in the /var/named/chroot/etc/ does not look to have changed from the original install? Should this file be writable by other then owner? Current permissions on this file are 644.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to run these commands again:

    and the restart named afterwards. Did you have any errors in the logfile /home/admispconfig/ispconfig/ispconfig.log ?
  5. falko

    falko Super Moderator ISPConfig Developer

  6. allwayson

    allwayson New Member

    Its fixed

    It is working now. It was both the permissions issue mentioned above, not all of the files are set correctly when following "The perfect setup Fedora Core 5" or I missed it the first time.

    Once the permissions are set correctly it did not work at first until I discovered the setting mentioned in the other thread about changing the directory setting for zonefiles under server settings for DNS. It has to be set to /var/named/chroot/var/named so that zonefiles can be created correctly.

    Everything else worked right out of the box! What a great product!! Can't wait to really start using it!

Share This Page