DNS not being created

Discussion in 'Installation/Configuration' started by djtremors, Jul 7, 2006.

  1. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    Can someone tell me at what point does the master dns domain files get created?

    I'm using FC4 with ispc 2.2.3 and created a reseller and then a client. Now created a test domain of blah.com to the clients and clicked the Create DNS and MX yet after the save it doesn't appear to create the DNS records.

    I went into the properties of the Site and clicked on the co-domain and selected it. I noticed another set of "Create DNS/MX" which I ticked and saved that too.
    Still no DNS created.

    where else can it be to create master dns records?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Is the DNS file written when you create it in the DNS manager?
    Does other changes like email accounts or websites get written?
     
  3. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    Looking at this (below), I assume the site works fine and if I put it in my own hosts file an entry for www.blah.com to point to the server. I can browse the "welcome" new site page.

    ls -l /var/www/
    total 24
    drwxr-xr-x 2 root root 4096 Jan 17 22:37 cgi-bin
    drwxr-xr-x 3 root root 4096 Jul 7 09:51 error
    drwxr-xr-x 2 root root 4096 Jan 17 22:37 html
    drwxr-xr-x 3 root root 4096 Jul 7 09:52 icons
    drwxr-xr-x 2 root root 4096 Jul 7 10:28 sharedip
    drwxr-xr-x 8 apache web1 4096 Jul 7 13:44 web1
    lrwxrwxrwx 1 root root 13 Jul 7 13:44 www.blah.com -> /var/www/web1

    Wow, I created an email and 2 minutes later the /etc/passwd account FINALLY was created..lol.. i saw this on my test machine at home but didn't expect it on a P4 3Ghz server.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you see the zone file for the domain in /var/named/chroot/var/named/?
     
  5. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    Hmm checking this out.

    damn it. it's now working and there IS a /var/named/chroot folder where I was sure there wasn't one. I can see the chrooted folder now.. Argh!

    sorry for the trouble.
     
    Last edited: Jul 8, 2006
  6. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    FAR OUT!!

    I really got to stop working on multiple servers.

    The problem wasn't my home environment it was the machine at work. Grr (time for bed really).

    There is no chroot folder. I don't think FC4 out of the box is setup in an chrooted environment.

    [root@warlock install_ispconfig]# ls -l /var/named/
    total 72
    drwxrwx--- 2 named named 4096 May 18 2005 data
    -rw-r--r-- 1 named named 198 Aug 26 2004 localdomain.zone
    -rw-r--r-- 1 named named 195 Aug 26 2004 localhost.zone
    -rw-r--r-- 1 named named 415 Aug 26 2004 named.broadcast
    -rw-r--r-- 1 named named 2518 Aug 26 2004 named.ca
    -rw-r--r-- 1 named named 432 Aug 26 2004 named.ip6.local
    -rw-r--r-- 1 named named 433 Aug 26 2004 named.local
    -rw-r--r-- 1 named named 416 Aug 26 2004 named.zero
    drwxrwx--- 2 named named 4096 May 18 2005 slaves

    the data/ and slaves/ folder are empty.
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you follow this tutorial: http://www.howtoforge.com/perfect_setup_fedora_core_4 for your FC4 machine?
     
  8. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    yes sort of. I followed it in another FC4 install and from memory it failed on installing apt

    PHP:
    rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm


    '
    But I browsed the url and managed to find the new name of the file.
    Then there was another part which failed so now I've been working without it though didn't noticed that ispc required the chroot path to do it's work.

    I've done the yum install bind-chroot and it's now running a chroot version but tried to update the dns and still not creating files.

    any other minimum requirements to create the zone files or could you tell me where the DNS is created or updated in the php code and I'll find it myself?
     
  9. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    Would setting the path to server_bind_zonefile_dir in isp_server db entry make any difference?
     
  10. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    OK fixed.

    I noticed in the server settings section the zone path dir was somehow set to /etc/bind which doesn't exist. That explains the missing zone files.

    I set it to /var/named/chroot/var/named/ and saved it then made a change to the DNS and it recorded the entry.. yippie :D

    server_bind_zonefile_dir in the config DB now shows /var/named/chroot/var/named/ and works fine now ;)
     

Share This Page