DNS/Nameserver on Opensuse 11 server

Discussion in 'Server Operation' started by Gorghor, Nov 1, 2008.

  1. Gorghor

    Gorghor New Member

    Hi people,

    I'm trying to get a work/home server setup to work on several projects with other people.
    I followed the excellent HOWTO for installing OpenSuse 11 (skipping the ISPconfig specific parts as I do not wish to use it) as a server and have everything running very nicely.

    I also have a domain name from OVH which I'm currently using as a redirection address, but it also offers advanced features like DNS NS configuration.

    Also my ISP provides me with a fixed IP.

    Now, I would like my server to actually "host" this address so that I can configure various subdomains within Apache (eg project1.mydomain.com, phpmyadmin.mydomain.com etc..) but I'm a bit lost.

    I checked the HOWTO section but I'm not sure where to start and am a bit afraid of messing up my whole setup.

    Could someone help me out?


    Last edited: Nov 1, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    Is the server behind a router? If so, you can place the server in the DMZ, and you must configure your router to use the static IP (ask your ISP how to do that).
  3. Gorghor

    Gorghor New Member

    Hi there,

    Thanks for the answer.

    Yup, it's behind a router and it is already in the DMZ. I'm not sure I understand what you mean with configuring the router to use the static IP. Do you mean that instead of having it route from say 91.xx.zz.yy to, it should directly be assigned to 91.xx.zz.yy? Is there no way to get around this? Hosting web pages works fine with the current config and if at all possible, I would like to not have to reconfigure the entire home network.

    Oh and in case my first explanation was unclear, I believe what I'm trying to do is basically the contents of the following HOWTO, but without ISPConfig

    *How To Run Your Own Name Server With ISPConfig And providerdomain.de (Schlund)*

  4. martien

    martien New Member

    You are behind a router so set port forwarding for 53 (dns),80 (apache) and other needed ports. Then contact your domain register and ask them to register you 2 name servers (ex. ns1.yourdomain.com and ns2.yourdomain.com) and point them to your static ip. After that you have to configure bind (as you saw in the tutorials). Make zone for yourdomain.com. Then edit your apache configuration and add virtualhost for your domain.
    Note: If your server's ip is local ip behind the router (ex. 192.168...) the dns records must be set to your public ip address, but your apache virtualhost - to your local ip.
  5. Gorghor

    Gorghor New Member

    Hi Martien,

    That's basically what I'd been trying to do, only I was using the internal IP for the records, and the domain manager system of my registar wasn't accepting the new NS values. It seems to have worked this time. So thank you very much!

    Must wait and see once propagation is done though.

    Another thing: I seem to have been mislead when thinking I had a static IP. I'm getting cable internet and the DHCP had kept me on the same IP for several months, but I just unplugged the modem and reconnected to see and I now have a new address. My router has a DynDns function, can I then point the nameservers/records to the IP of my DynDns? can that work?

  6. martien

    martien New Member

    Never used dyndns. But i think you can talk to your ISP operators. Ask them to give you static ip for using remote administration for example. I think they can't refuse your request (except for clause in the contract that you signed).
    Your modem gets new address, cause of it's reconnection.8-9 mounts is a long period. Anyway i think dyndns will works for you, you just have to read about it.
  7. Gorghor

    Gorghor New Member

    Ok, will read up on that thanks!

    Bad news though: My registar accepted the modification (used to give me a Denic error directly), but now I get an email saying that the process cannot be continued

    ERROR: The nameserver list doesn't match the given one (ns1.xxx.yy./77.xx.xx.xx)

    I'm searching right now, but if anyone knows what this means, I'd be grateful
  8. Leszek

    Leszek Member

    Maybe ns1.xxx.yy doesn't resolve to 77.xx.xx.xx ?
  9. Gorghor

    Gorghor New Member

    I worked this problem out now. Since the secondary NS was required to have a different IP by my registar, I had to change it, and had forgotten to change in BIND as well.

    Now I can't seem to get my secondary NS' to update their information and thus the procedure says they have no SOA file.

    At least I have the feeling I'm getting somewhere... *sigh*
  10. Gorghor

    Gorghor New Member

    Well I think I finally got it running! The firewall was still blocking port 53 although Yast said it was open.

    Thanks to everyone for helping! :)

Share This Page