DNS Nameserver help

Discussion in 'Installation/Configuration' started by Ryanmt, Apr 11, 2008.

  1. Ryanmt

    Ryanmt New Member

    Im using ISPConfig and following this guide.

    im not using godaddy im using 123reg who are very smilar.

    Ive setup the ns1 and ns2 in the control panel and added the IPs of my server, the domains are ns1.lyndsayb.co.uk and ns2.lyndsayb.co.uk .. lyndsayb.co.uk now works and resolves to the server.

    However the dig part is different to how it should be, other domain hosts say they cannot find ns1.lyndsayb.co.uk ..
    Suggested output is..

    Mine is ...

    Where have i gone wrong?

  2. Ryanmt

    Ryanmt New Member


    36hrs after dns was updated and still nothing, can anybody check just to see if this is UK2s problem
  3. falko

    falko Super Moderator ISPConfig Developer

    It's working for me:
    mh1:~# dig ns1.lyndsayb.co.uk
    ; <<>> DiG 9.3.4 <<>> ns1.lyndsayb.co.uk
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47660
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    ;ns1.lyndsayb.co.uk.            IN      A
    ns1.lyndsayb.co.uk.     172800  IN      A
    ;; Query time: 161 msec
    ;; SERVER:
    ;; WHEN: Sat Apr 12 17:32:39 2008
    ;; MSG SIZE  rcvd: 52
  4. Ryanmt

    Ryanmt New Member

    Hey thanks for the reply.

    Im fairly sure ive set it all up right but im still not getting anywhere, i get the message

    "Nameserver [ns1.lyndsayb.co.uk] doesn't exist at the registry)" at one domain registrar and the other said "ns1.lyndsayb.co.uk was not found. Nameservers must exist "

    Is there anything i could have configured wrong in ispconfig? I know my hypervm control panel has something about reverse DNS but ive not added anything to that.. do i need to?

    at my girlfriends house i get the following, whast the admin.lyndsayb.co.uk about, ive never created that :S

    Last edited: Apr 12, 2008
  5. edge

    edge Active Member Moderator

    Some registrars will allow you to set the IP for the NS. (this is sometimes needed when using a new NS server as it's not know to the world jet)

    I beleive that Godaddy has this option, but do not know if 123reg has this.

    This is what I get when doing a dig on your NS
    The admin.lyndsayb.co.uk. is auto created by Bind as it's needed.
    Last edited: Apr 12, 2008
  6. Ryanmt

    Ryanmt New Member

    Thanks for the reply, seems your getting the same dig as me. To clarify what ive done is followed this guide to setup the ns1 and ns2 to the ips


    then followed the ISPsetup side of things as if i had done it at godaddy. Does that seem ok?

    for testings sake i tried adding the nameservers as IPs and got was not found. Nameservers must exist

    I think theres something not setup right on the server :(
    Last edited: Apr 12, 2008
  7. edge

    edge Active Member Moderator

    Do not enter the IP in the NS part from the registrar.
    Try looking for some "advanced" setting, or "create a DNS setting" option in the registrar interface.

    There you should be able to enter the "ns1.lyndsayb.co.uk" and IP: ""

    Again, I'm not with Godaddy / 123reg, so not sure how to do this.
  8. falko

    falko Super Moderator ISPConfig Developer

  9. Ryanmt

    Ryanmt New Member

    Hi, ive not set up any glue records. Ive contacted the people who ive registered the domain with and they say it something i have to setup at my end (i dont belive it is?) basically the support are useless.

    I do have the option however of using their nameservers.. If i do that and then add some A records to point ns1 and ns2 at the correct IPs will that work? I think that will make it so i cant have that as a functioning website?
  10. Ryanmt

    Ryanmt New Member

  11. BinkS

    BinkS New Member

    Hi mate, I have some domains reg'd with 123-reg, I am using the IP address as name servers for www and @ :)
  12. Ryanmt

    Ryanmt New Member

    is your setup the same as that mate? Having loads of trouble getting this sorted i should have had this up and running last week :( :(
  13. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    You have several A settings

    Check if you can set the DNS data like this:

    lyndsayb.co.uk A
    *.lyndsayb.co.uk CNAME lynsayb.co.uk
    lyndsayb.co.uk MX mail.lyndsyb.co.uk
    lyndsab.co.uk TXT v=spf1 a mx ~all

    Leave the ns1 and ns2 settings as they are.

    If you find the setting to specify the IP of the Nameservers with the registrar then you could use names like ns1.lyndsayb.co.uk instead of IPs which is sometimes manditory.
    Last edited: Apr 14, 2008
  14. Ryanmt

    Ryanmt New Member

    Hi, thanks for the reply. just tried adding the wildcard like you said


    http://lyndsayb.co.uk still doesnt goto the right place. No joy on the nameserver front either (though it may just be taking a while to propogate to the other domain registras im trying to set the nameservers on)
  15. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    This is still missing in your configuration:

    lyndsayb.co.uk A

    and it might be that you have to write things out

    You have

    * CNAME lyndsayb.co.uk

    Try to add

    *.lyndsayb.co.uk CNAME lyndsayb.co.uk

    EDIT: By the way set the priority for mail to 10
    Last edited: Apr 14, 2008
  16. Ryanmt

    Ryanmt New Member

    just tried to add that and it doesnt let me, i dont get an error message but they dont get added to the list either.
  17. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    And if you add a "." point at the end of the A record domain name:

    lyndsayb.co.uk. A

    it could be that 123.reg does this entry by themselfs.
    Please check there FAQ.

    I realised that one nameserver is on the same IP with your web.
    If you use ISPConfig you have to add the settings I wrote to you there!
  18. Ryanmt

    Ryanmt New Member

    ive tried adding a . at the end and it still doesnt add it. Just to clarify im using the 123reg nameservers in an attempt to get the ns1 and ns2 working.

    Do i add a copy of what ive got in my screenshot onto my dns servers on ipsconfig?

    Thanks for the help, much appriciated
  19. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Ok. I checked the whois data for you domain.

    At the moment you have


    That means that you don't use the DNS system of ISPConfig and thus don't have to add the settings there.

    You also don't have to add the ns1 and ns2 so delete them.

    There was an edit of the domain data today.
    If you have added the above mentioned nameservers so wait at least 24 hours.

    Check with 123.reg how to configure there nameservers. They should be able to explain how you enter the zone data like I mentioned earlier.

    Hope that helps.
  20. Ryanmt

    Ryanmt New Member

    the screenshots are of me configuring the 123reg name servers. I had previously tried setting the nameservers for that domain as ns1.lynsayb.co.uk and ns2.., that site worked but the nameservers wernt valid according to other domain registrars so i couldnt add more domains to my server.

Share This Page