DNS - named will not start ??

Discussion in 'Installation/Configuration' started by brainz, Mar 8, 2007.

  1. falko

    falko Super Moderator

    This is definitely wrong.
    Your /var/named folder has wrong permissions. Please run
    Code:
    chmod 755 /var/named/
    chmod 775 /var/named/chroot/
    chmod 775 /var/named/chroot/var/
    chmod 775 /var/named/chroot/var/named/
    chmod 775 /var/named/chroot/var/run/
    chmod 777 /var/named/chroot/var/run/named/
    cd /var/named/chroot/var/named/
    ln -s ../../ chroot
    chkconfig --levels 235 named on
    /etc/init.d/named start
    and change the value back to /var/named/chroot/var/named in ISPConfig.
     
  2. brainz

    brainz New Member

    Hi guys

    Thankyou for you assistance i have solved the peoblem and the bind dns is up and running again....

    The problem was there was a stray entry in the pri file in i removed it and bang its back up and running.....

    You know one of these days i am going to have to get you guys a beer prehaps down at the bevarian bar in sydney along with some [SIZE=-1]sauerkraut to go with it....

    Once again thankyou for you help.... Im sure if i mess the server up again in someway i will be back for help...

    regards
    brainz
    [/SIZE]
     
  3. brainz

    brainz New Member

    Hi Guys,

    I just got a email from root and it says this...

    Just wondering what this meant it seems its the port used for webadmin..

    regards
    brainz
     
    Last edited: Sep 30, 2008
  4. falko

    falko Super Moderator

    You can switch off the monitoring for port 10000 in ISPConfig under Management -> Server -> Services -> Monitoring (if you don't have webmin installed or don't want to monitor it).
     
  5. radim_h

    radim_h Member

    is any site in there

    You have to put some site into DNS manager or DNS serverwill not start.. (just after installation of ISPC for example)
     
    Last edited: Mar 22, 2007
  6. rlhesson

    rlhesson Guest

    I have the same problem as the guy in this thread did, I have tried everything but still get this message

    [root@drake named]# /etc/init.d/named restart
    Stopping named: [FAILED]
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found
    /etc/named.conf:3: parsing failed

    I have changed the Zonefile directory to
    /var/named/chroot/var/named

    waited 1-2 min and everything but I still get that message.
     
  7. rlhesson

    rlhesson Guest

    Fixed it by overwriting the whole directory from a backup
     
  8. till

    till Super Moderator

    I guess that your directory had the wrong permissions and as you overwrote it with your backup, you fixed the permissions too.
     
  9. rlhesson

    rlhesson Guest

    Could be, but I redid the permissions following the perfect setup and it still wasnt working.
     
  10. adriaan

    adriaan New Member

    When I change it to: /var/named/chroot/var/named where the same files are as in /home/admispconfig/ispconfig/web/multidoc/edit: ISPConfig automaticly changes to /etc/named and the error is still the same.
     
  11. Richard87

    Richard87 New Member

    I am having the same problems, the fix in named.conf gets reverted after a few minutes
     
  12. adriaan

    adriaan New Member

    A very funny thing is that I don't have a /etc/named.conf. Altough the start says I have?!
    Code:
    [root@xara ~]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found
    
    /etc/named.conf:3: parsing failed
                                                               [FAILED]
     
  13. Richard87

    Richard87 New Member

    (named is in a chroote'd envirement, wich means named.conf is located at /var/named/chroot/etc/named.conf)
     
  14. mlz

    mlz New Member

    Richard, double check the template files for ISPConfig and make sure it isn't boffed there. Also check the settings in the control panel. Log in as admin, management, server, settings, then click on the DNS tab.
     
  15. Richard87

    Richard87 New Member

    Thanks, that worked just fine:D
     
  16. falko

    falko Super Moderator

    What's the output of
    Code:
    updatedb
    locate named.conf
    ?
     
  17. m1_davidson

    m1_davidson New Member

    This is the output of my "locate named.conf":

    [root@res ~]# locate named.conf
    /usr/share/man/man5/named.conf.5.gz
    /home/admispconfig/ispconfig/web/multidoc/edit/named.conf
    /root/ispconfig/isp/conf/named.conf.master
    /var/named/chroot/etc/named.conf
    /var/named/chroot/etc/named.conf.rpmsave
    /etc/named.conf
    /etc/named.conf~
    /etc/named.conf.old
    /etc/log.d/conf/services/named.conf

    And, yes, I'm having this issue too.
     
  18. falko

    falko Super Moderator

    What's in /etc/named.conf?
     
  19. m1_davidson

    m1_davidson New Member

    options {
    pid-file "/var/named/chroot/var/run/named/named.pid";
    directory "/var/named/chroot/var/named";
    auth-nxdomain no;

    I seem to have fixed it though. Thanks a mil for getting back.
     
  20. roadster

    roadster New Member

    I've also had this issue of Bind failing today with:

    /etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found

    /etc/named.conf:3: parsing failed

    I changed the server setting in ISPConfig from:

    /home/admispconfig/ispconfig/web/multidoc/edit

    to:

    /var/named/chroot/var/named

    but still got the error until I noticed that named.conf still had the reference to the original location near the top of the file. Once this was manually changed to the new location everything was fine.

    I'm wondering what had caused the issue after 3 months of trouble free operation ..... I had made two system changes today:

    i) added 4 additional ip addresses to eth0 + ISPConfig
    ii) added a SSL certificate to a site on the 'base' ip address

    Thanks to all for an excellent piece of open source software and committed support!
     

Share This Page