DNS - named will not start ??

Discussion in 'Installation/Configuration' started by brainz, Mar 8, 2007.

  1. brainz

    brainz New Member

    Hi till and falko

    The dns named will not start.... when i try to restart it this is what i get..

    help please

    regards
    brainz
     
  2. till

    till Super Moderator

    Please post the content of the file /root/ispconfig/isp/conf/named.conf.master
     
  3. brainz

    brainz New Member

    As Requested till,

    Here is the content of /root/ispconfig/isp/conf/named.conf.master

    till also i get this.. which maybe a clue...
    regards
    brainz
     
    Last edited: Mar 8, 2007
  4. brainz

    brainz New Member

    Hi till

    i also get this as a email from the server as well

    regards
    brainz
     
    Last edited: Sep 30, 2008
  5. martinfst

    martinfst HowtoForge Supporter

    That's because the mailserver and probably spamassassin use DNS for various checks. It will go away when you fixed your DNS.
    Is the output you posted for /root/ispconfig/isp/conf/named.conf.master really like that? No new lines?
     
  6. brainz

    brainz New Member

    Im sorry but yes there are no new lines
     
  7. martinfst

    martinfst HowtoForge Supporter

    It should look like:
    Code:
    
    options {
            pid-file "/var/run/bind/run/named.pid";
            directory "{BINDDIR}";
            auth-nxdomain no;
            /*
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
             */
            // query-source address * port 53;
    };
    
    //
    // a caching only nameserver config
    //
    zone "." {
            type hint;
            file "db.root";
    //
    // a caching only nameserver config
    //
    zone "." {
            type hint;
            file "db.root";
    };
    
    zone "0.0.127.in-addr.arpa" {
            type master;
            file "db.local";
    };
    
    <!-- BEGIN DYNAMIC BLOCK: named_reverse -->
    zone "{ZONE}.in-addr.arpa" {
            type master;
            file "pri.{ZONE}.in-addr.arpa";
    };
    <!-- END DYNAMIC BLOCK: named_reverse -->
    
    <!-- BEGIN DYNAMIC BLOCK: named -->
    zone "{DOMAIN}" {
            type master;
    };
    <!-- END DYNAMIC BLOCK: named -->
    
    <!-- BEGIN DYNAMIC BLOCK: named_slave -->
    zone "{DOMAIN}" {
            type slave;
            file "sec.{DOMAIN}";
            masters { {MASTERS}; };
    };
    <!-- END DYNAMIC BLOCK: named_slave -->
    
    //// MAKE MANUAL ENTRIES BELOW THIS LINE! ////
    
    Including the newlines. This is a copy of my master file, which I think I have not modified. But please double check. After replacement, update a DNS entry in the panel and check you have new files in /etc/bind (or /var/lib/named/etc/bind, which is symlinked)
     
  8. brainz

    brainz New Member

    Im sorry,

    But i think the faile is the same here is mine is a readable format...

    Code:
    
    options {
            pid-file "/var/named/chroot/var/run/named/named.pid";
            directory "{BINDDIR}";
            auth-nxdomain no;
            /*
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
             */
            // query-source address * port 53;
    };
    
    //
    // a caching only nameserver config
    //
    zone "." {
            type hint;
            file "named.ca";
    };
    
    zone "0.0.127.in-addr.arpa" {
            type master;
            file "named.local";
    };
    
    <!-- BEGIN DYNAMIC BLOCK: named_reverse -->
    zone "{ZONE}.in-addr.arpa" {
            type master;
            file "pri.{ZONE}.in-addr.arpa";
    };
    <!-- END DYNAMIC BLOCK: named_reverse -->
    
    <!-- BEGIN DYNAMIC BLOCK: named -->
    zone "{DOMAIN}" {
            type master;
            file "pri.{DOMAIN}";
    };
    <!-- END DYNAMIC BLOCK: named -->
    
    <!-- BEGIN DYNAMIC BLOCK: named_slave -->
    zone "{DOMAIN}" {
            type slave;
            file "sec.{DOMAIN}";
            masters { {MASTERS}; };
    };
    <!-- END DYNAMIC BLOCK: named_slave -->
    
    //// MAKE MANUAL ENTRIES BELOW THIS LINE! ////
    there is not difference except my named dns will not start....

    regards
    brainz
     
  9. till

    till Super Moderator

    What is in the field "Zonefiles Dir.:" in ISPConfig under management > server > settings on the dns tab?
     
  10. brainz

    brainz New Member

    till this is

    regards
    brainz
     
  11. till

    till Super Moderator

    Ok, this explains your problem. Which linux distribution do you use, or do you know where your named configuration is located?
     
  12. brainz

    brainz New Member

    till

    i use fedora core 5 and the named.conf is in the /etc/named.conf
    as far as i know...

    till would you like me to post the named.conf contence...

    regards
    brainz
     
    Last edited: Mar 8, 2007
  13. till

    till Super Moderator

    Please enter this path in the zonefile field:

    /var/named/chroot/var/named
     
  14. brainz

    brainz New Member

    hi till i entered the it in the zonefile field in ispconfig and attempted to restart named from ispconfig and it didnt restart. I also tried to restart it using /etc/init.d/named restart and it gave me this...

    regards
    brainz
     
  15. till

    till Super Moderator

    After you entered the new value, click on save and then wait about a minute. Is the new value saved or has it returned to the wrong value when you open the form again after 1-2 minutes?
     
  16. brainz

    brainz New Member

    hi till

    i waited 1-2 minutes and checked the /etc/named.conf
    and it has not changed...... it is still

    regards
    brainz
     
  17. falko

    falko Super Moderator

    Any errors in /home/admispconfig/ispconfig/ispconfig.log? What's the output of
    Code:
    ls -la /root/ispconfig
    ?
     
  18. brainz

    brainz New Member

    Hi falko

    there are no errors just this is the only warning that i have in the log

    What's the output of
    Code:
    ls -la /root/ispconfig
    ?


    this is the output.....

    regards
    brainz
     
  19. falko

    falko Super Moderator

    There's a problem with your named configuration. What's in /etc/named.conf?
    What's in the zonefile field in ISPConfig?
    What's the output of
    Code:
    ls -la /var/named/chroot/var/named
    ?
     
  20. brainz

    brainz New Member

    here is what is in named.conf falko......


    here is
    falko it was this ....

    /home/admispconfig/ispconfig/web/multidoc/edit

    and till had me change it to this...

    /var/named/chroot/var/named

    But i have chaged it back to this...

    /home/admispconfig/ispconfig/web/multidoc/edit






    here is the output falko

    regards
    brainz
     
    Last edited: Sep 30, 2008

Share This Page