DNS MX Records Ubuntu 10.10

Discussion in 'Installation/Configuration' started by mattbh, Jul 21, 2011.

  1. mattbh

    mattbh New Member

    Hi All

    I'm having a problem receiving external mail, i can send no problems and receive mail internally. So i used http://www.mxtoolbox.com to verify my DNS records and it returns that my MX record points to the IP 0.0.0.0. Which is not right.

    Here are my DNS records copied straight out of the ispconfig control panel (proper names replaced):

    A mail ***.***.***.189 0
    A domain.tld. ***.***.***.189 0
    A www ***.***.***.189 0
    MX domain.tld. mail.domain.tld. 10
    NS domain.tld. ns1.***.***. 0
    NS domain.tld. ns2.***.***. 0

    Please if anybody can see something wrong or if im missing a record? I did use the dns wizard to setup these records.

    Any help much appreciated.
     
  2. falko

    falko Super Moderator

    Is your ISPConfig server authoritative for your domain? You can check that by running
    Code:
    dig ns yourdomain.com
    Also, you can check your DNS settings on www.intodns.com
     
  3. mattbh

    mattbh New Member

    Thanks Falko I ran a test on intoDNS and the mx record had this error:

    Your MX records that were reported by your nameservers are:

    10 mail.domain.tld No A Record (no glue either)

    [These are all the MX records that I found. If there are some non common MX records at your nameservers you should see them below. ]
     
  4. falko

    falko Super Moderator

    You must create an A record for mail.domain.tld.
     
  5. mattbh

    mattbh New Member

    Hi

    So i added an A record like you said(below), but still nothing.

    A mail.domain.tld. ***.***.***.189 0

    Is there something wrong with it?

    Is there a place i can check through ssh on the server where these records are stored?
     
  6. falko

    falko Super Moderator

    If you use BIND, check out /etc/bind/named.conf and the files included in there.

    You can also check your domain here: http://www.intodns.com/
     
  7. mattbh

    mattbh New Member

    Hi Falko

    I can't see anything wrong, this thing is just driving me nuts.... Thanks for your help. www.intodns.com still giving the same story:

    10 mail.domain.tld No A Record (no glue either)
     
  8. till

    till Super Moderator

    Please check that your dns server is really the authoritive DNS server for this domain.
     
  9. mattbh

    mattbh New Member

    This is the response i get when running dig (i have no idea what this means):

    ; <<>> DiG 9.7.1-P2 <<>> ns domain.tld
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11348
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;domain.tld. IN NS

    ;; ANSWER SECTION:
    domain.tld. 600 IN NS ns1.otherdomain.tld.
    domain.tld. 600 IN NS ns2.otherdomain.tld.

    ;; ADDITIONAL SECTION:
    ns1.otherdomain.tld. 293 IN A ***.***.***.***
    ns2.otherdomain.tld. 294 IN A ***.***.***.***

    ;; Query time: 31 msec
    ;; SERVER: ***.***.***.***#53(***.***.***.***)
    ;; WHEN: Wed Aug 3 11:27:59 2011
    ;; MSG SIZE rcvd: 104
     
  10. till

    till Super Moderator

    Is the IP address displayed in the line ns1.otherdomain.tld the IP address of your dns server? If not, then your server is not authoritive for that domain.
     
  11. mattbh

    mattbh New Member

    yes the ip is the same as when i ping it from my desktop.
     
  12. till

    till Super Moderator

    The question was if this is the IP address of your server, not if its the same when you ping it.
     
  13. mattbh

    mattbh New Member

    yeah i got that, i pinged the dns server of the company who is hosting our server and the ip address that is in the dig is the same as the ip address that i got from pinging the dns server.
     
  14. CSsab

    CSsab New Member

    A records for nameservers

    Hi, I have had this problem before and all I had to do after using the wizard is add A records for the name servers. You will notice that your have authority "0" - no name servers.

    Should look like this:

    AUTHORITY 2


    Just add 2 records to the one created for you by the wizard like this:

    ns1
    domain.tld
    IP of the nameserver

    and -

    ns2
    domain.tld
    IP of secondary dns


    Till did a screenshot ages ago which showed the setup well but I can't find it right now ... just make sure you only put in "ns1" like where it says "www" .. and nothing else - also don't forget the "." after (<--- Edited - when you are adding other records like MX records (A records should points to an IP)
     
    Last edited: Aug 3, 2011
  15. mattbh

    mattbh New Member

    Hi

    Sorry just a little confused as to what to put in. attached is a screenshot of the inputs.

    so i put ns1 in the host name box, and the ip of the name sever in the ip-address box?

    And then repeat for ns2?
     

    Attached Files:

  16. CSsab

    CSsab New Member

    Yes that is right.

    ns1

    and the external IP address of your nameserver (for example your static IP)

    People have different setups. I have only a single static IP at the moment so both of my nameservers are on the same IP.

    For ns2 you should have a second IP but people rarely complain about that these days due the world running out of IPv4 IP's ...

    Remember that if your server goes down then both of your name servers go down.

    Did you take a look at Falkos new how to about setting up DNS ?
     

Share This Page