DNS MX Record Problem

Discussion in 'Server Operation' started by celtic, May 26, 2007.

  1. celtic

    celtic New Member

    Following the 3 pictures attached we can see that:

    1) MX Record is configured in ISPConfig
    2) MX Record is configured in the zone file
    3) MXLookup tool keeps saying no MX Record exists


    4) Mail Server is a MS Exchange working properly
    5) We are not receiving any e-mail on the jfo.pt domain

    Help is very much appreciated.

    Kind Regards and Thanks in advance
     

    Attached Files:

  2. edge

    edge Active Member Moderator

    The MX record can not be an IP. It should point to the A record "afonso"

    So: afonso MX 10 212.13.x.x. is wrong.
    It should be like: afonso MX 10 afonso.jfo.pt.

    In records, click on the IP nr thats under Mailserver.
    Change the IP nr to: afonso (or if you like to: afonso.jfo.pt)
    Change the Hostname to: @
     
    Last edited: May 26, 2007
  3. celtic

    celtic New Member

    So it should be like this?

    $TTL 86400
    @ IN SOA jfo.nortenet.pt. jfo.jfo.pt. (
    2007052602 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;
    NS jfo.nortenet.pt. ; Inet Address of name server 1
    NS ns1.twisted4life.com. ; Inet Address of name server 2
    ;

    @ MX 10 afonso.jfo.pt.

    jfo.pt. A 212.13.41.2
    www A 212.13.41.2
    afonso A 212.13.49.200
     
    Last edited: May 26, 2007
  4. celtic

    celtic New Member

    Update:

    1) MXlookup web site now reports the correct mail server.

    2) All e-mail ending in @jfo.pt is rejected: 550: Recipient Address Rejected: user unknown in local recipient table.

    Seems to me that inspite of the MX record the server keeps "owning" my jfo.pt e-mails.

    Kind Regards and Thanks in advance
     
  5. falko

    falko Super Moderator ISPConfig Developer

    This means that the receiving server doesn't know that it's responsible for the mails, i.e., it isn't configured to receive emails for the domain.
    What MTA do you use on the receiving server? Postfix?
     
  6. edge

    edge Active Member Moderator

    falko,

    He is using MS Exchange
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Then I can't help him, I guess... ;)
     
  8. celtic

    celtic New Member

    The thing is if I decide to give Domain authority to may ISP all mail works well because I just ask for a MX record for mail server 212.13.49.200 and a host record for www.jfo.pt.

    What I am trying to do is get independent of ISP's and take control of my domain.

    The thing is that it seems that my Ubuntu server is not letting go of the mails to the mail server and is checking if the users exist instead of simply passing them to the proper server to check. Is there any place to check outside of ISPConfig to prevent such behavior?

    PS1: I am a MS Exchange specialist and can assure you that the MS Exchange is in perfect condition.

    PS2: my var/log/mail.log.* files reach more than 3Gb. Is that normal or should I check those files to find some wrong behavior.
     
  9. edge

    edge Active Member Moderator

    The thing is that your MX record (that is for mail) is pointing to the MS Exchange server. (afonso.jfo.pt).
    So theoretically the mail will (should) never go to the Ubuntu server!

    Are you seeing anything in the logfiles from MS Exchange?
     
  10. edge

    edge Active Member Moderator

    I've just done a DNS report on your domain again, and it looks like you have changed some things again.

    You will need to set the MX record in both namserver (jfo.nortenet.pt, ns1.twisted4life.com)
     
  11. celtic

    celtic New Member

    1) MS Exchange is really passive here.

    2) The ns1.twisted4life.com is configured as secondary DNS because in Portuguese law we are forced to have 2 DNS for .pt domains. That domain only copies the jfo.pt zones from the Ubuntu.

    3) In the DNS report they mention 2 Mail servers. One is Ubuntu and the other the MS Exchange. How to prevent that from happening?

    4) When I create a user named 'jfo' in Postfix, I immediatly can receive mails for [email protected] that stay in the Postfix mailbox instead of going to the MS Exchange server.

    Any Ideas?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Your MX records are wrong:

    Code:
    dig mx jfo.pt
    
    ; <<>> DiG 9.3.4 <<>> mx jfo.pt
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47073
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;jfo.pt.                                IN      MX
    
    ;; ANSWER SECTION:
    jfo.pt.                 86400   IN      MX      10 jfo.nortenet.pt.
    jfo.pt.                 86400   IN      MX      10 [B]afonso[COLOR="Red"].[/COLOR][/B]
    
    ;; Query time: 411 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Mon May 28 18:40:38 2007
    ;; MSG SIZE  rcvd: 75
    Please delete the jfo.nortenet.pt record. The second one should look like this:

    Code:
    jfo.pt.                 86400   IN      MX      10 afonso
    (not dot at the end!)

    or

    Code:
    jfo.pt.                 86400   IN      MX      10 afonso.jfo.pt.
    Take a look here: http://www.howtoforge.com/traditional_dns_howto
     
  13. celtic

    celtic New Member

    Thank you guys for helping me out.

    I dont know how DNS got so messed up but I'm sure it was my fault after all.
     
  14. celtic

    celtic New Member

    Once again today my DNS config got messed up.

    I've tried pretty much everything I know (wich is not many at all) but still with no success regarding my e-mails and also resolving my afonso.jfo.pt IP name.

    when tracing afonso.jfo.pt it resolves to an old IP: 212.13.49.200 instead of the actual one: 194.79.74.222.

    And MX testers keep saying that I have 2 MX records when only one is configured. And assuming that it is correct the name cannot be resolved to the mail server. inspite of that SMTP test resolver mail server name and checks correctly the email addresses.

    I've read the tutorial but it did not add much to my poor knowledge.

    please help out to understand what's happening here before I go crazy!

    Pics included can help out reading my mind.

    Kind regards and - again - thanks in advance
     

    Attached Files:

  15. celtic

    celtic New Member

    Same configuration for a customer is required an was done but the MX record keeps reporting bad.

    check bsl.pt domain. The MX record should point to server.bsl.pt that should resolve to 194.79.73.146.

    I am so confused...
     
  16. falko

    falko Super Moderator ISPConfig Developer

    It's working for me:

    Code:
    node2:~# dig mx bsl.pt
    
    ; <<>> DiG 9.3.4 <<>> mx bsl.pt
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7408
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;bsl.pt.                                IN      MX
    
    ;; ANSWER SECTION:
    bsl.pt.                 86400   IN      MX      10 server.bsl.pt.
    
    ;; ADDITIONAL SECTION:
    server.bsl.pt.          86400   IN      A       194.79.73.146
    
    ;; Query time: 673 msec
    ;; SERVER: 62.109.123.7#53(62.109.123.7)
    ;; WHEN: Wed Sep 12 22:49:59 2007
    ;; MSG SIZE  rcvd: 63
    
    node2:~#
     
  17. celtic

    celtic New Member

    Is it possible that the problem was about propagation issues?
     
  18. falko

    falko Super Moderator ISPConfig Developer

    It can take up to 72 hours until DNS changes propagate, so - yes.
     

Share This Page