DNS Issues :(

Discussion in 'Installation/Configuration' started by stoute, Apr 28, 2013.

  1. stoute

    stoute New Member

    I am running in to a DNS error. Multi-server setup.

    Server Set-Up
    Server A: Main ISPConfig Server with everything. DNS, Mail, etc.
    Server B: Secondary server, has everything less the ISPConfig Interface.

    The website created "example.com" is on server B

    My DNS Settings in ISPConfig:
    Code:
    A	example.com.	10.198.199.130	0	86400	
    A	mail	10.198.199.130	0	86400	
    A	www	10.198.199.130	0	86400	
    MX	example.com.	mail.example.com.	10	86400	
    NS	example.com.	servera.domain.com.	0	86400	
    NS	example.com.	serverb.domain.com.	0	86400
    
    When I DIG
    "dig example.com"
    Code:
    ;; ANSWER SECTION:
    example.com.	86400	IN	A	10.198.199.130
    When I DIG for NS
    "dig example.com NS"
    Code:
    ;; ANSWER SECTION:
    example.com.	86400	IN	NS	servera.domain.com.
    example.com.	86400	IN	NS	serverb.domain.com.
    So you can see that it has the correct name servers listed BUT when you try going to that website it pulls up the default (new site welcome index.html) for the server and not the actual website. I have already FTP into the example.com site and deleted the index.html and it now has index.php with the old wordpress installation from my last server I am moving it from.


    I hope thats enough information. I need some major coffee/help.

    Thanks Guys!

    I forgot to say that intoDNS gives me this error:
    Code:
    DNS servers responded	ERROR: One or more of your nameservers did not respond:
    The ones that did not respond are:
    10.198.199.129
    Also even If I use godaddy's DNS service it pulls up another site hosted on that server, but NOT the one I'm looking for.
     
    Last edited: Apr 28, 2013
  2. stoute

    stoute New Member

    so this might be something else as any sites that are created through the ISPConfig Interface or Remote API create the site on the secondary server but if you go to that URL, it will pull up a site hosted on the main server.

    Maybe I set up the second server incorrectly?
     
  3. pititis

    pititis Member

    Hi,

    These settings are fine:

    Code:
    NS	example.com.	[B]servera[/B].domain.com.	0	86400	
    NS	example.com.	[B]serverb[/B].domain.com.	0	86400
    
    But you need to add a couple A records for the nameservers:
    Code:
    A	servera      	10.198.199.130	0	86400	
    A	serverb      	10.198.199.131	0	86400	
    
    Cheers
     
  4. stoute

    stoute New Member

    do I need to add the a records even though the domain for the name servers and the domain I'm setting up are different?

    example.com - the domain I'm creating the DNS for (domainA.com)

    ns1.domain.com - Name server (ns1.domainB.com)
    ns2.domain.com - Name server (ns2.domainB.com)

    I hope that makes sense
     
  5. kike

    kike New Member

    please post /etc/host i each server & uname -n
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No. These a records have only be added when the ns recordsvare subdomains of the zone.

    Take a look into the syslog, the named error and its reason is logged there.
     
    Last edited: Apr 30, 2013
  7. stoute

    stoute New Member

    master server
    Code:
    127.0.0.1	localhost
    127.0.1.1	ns1.domain.com
    10.198.199.129	ns1.domain.com	ns1
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    uname -n:
    Code:
    ms1.domain.com
    remote server:
    coming up
     
  8. kike

    kike New Member

    127.0.0.1 localhost
    supress this ->>>127.0.1.1 ns1.domain.com
    10.198.199.129 ns1.domain.com ns1 # this is a class A ip, review subnet mask, i think you don't need this class, better use 192.168.0.x/24
    add the other name server ->>> 10.198.199.130 ns2.domain.com ns2 ( if not change to class C ip then correct with apropiate subnetmask in your network configuration )
    "in both servers same hosts file"

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ------------------------------------
    uname -n = ms1??????????? not ns1?¿?¿?
    correct and restart bind (/etc/init.d/bind9 restart) or named

    it fails, post please ifconfig
     
    Last edited: Apr 30, 2013

Share This Page