Dns issues

Discussion in 'Installation/Configuration' started by RingofFire, Jun 27, 2007.

  1. RingofFire

    RingofFire New Member

    Code:
    03.08.2007 - 13:08:43 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1927: WARNING: could not groupadd -g 12001 web1_anonftp &> /dev/null
    03.08.2007 - 13:08:43 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1928: WARNING: could not useradd -d /var/www/web1/ftp -g web1_anonftp -m -s /bin/false -u 12001 web1_anonftp &> /dev/null
    
    Other than that, no other errors besides it failing to restart postfix a couple of times. It had no problem adding other users apparently, only adding the anonymous ftp users.

    Code:
    [[email protected] ~]# ls -la /root/ispconfig
    total 72
    drwxr-xr-x  9 root root  1024 Aug  3 13:17 .
    drwxr-x---  3 root root  1024 Aug  3 13:19 ..
    -rw-r--r--  1 root root     8 Aug  3 13:17 .old_path_httpd_root
    -rwxr-xr-x  1 root root 40157 Jun  3 14:16 cronolog
    -rwxr-xr-x  1 root root  9673 Jun  3 14:16 cronosplit
    drwxr-xr-x 12 root root  1024 Jun  3 12:13 httpd
    drwxr-xr-x 14 root root  2048 Jun  3 14:16 isp
    drwxr-xr-x  6 root root  1024 Jun  3 12:08 openssl
    drwxr-xr-x  6 root root  1024 Jun  3 12:29 php
    drwxr-xr-x  4 root root  1024 Jun  3 14:16 scripts
    drwxr-xr-x  4 root root  1024 Jun  3 14:16 standard_cgis
    drwxr-xr-x  2 root root  1024 Jun  3 14:16 sv
    -rwx------  1 root root  9389 Jun  3 14:16 uninstall
    
    Yes. Followed the directions to the letter.

    Code:
    Installed Packages
    Name   : bind-chroot
    Arch   : x86_64
    Epoch  : 30
    Version: 9.3.4
    Release: 1.fc5
    Size   : 0.0
    Repo   : installed
    Summary: A chroot runtime environment for the ISC BIND DNS server, named(8)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    And what's the output of
    Code:
    ls -la /root/ispconfig
    ?
     
  3. RingofFire

    RingofFire New Member

    Already had it in there.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. What's the output of
    Code:
    ps aux | grep wconf
    ?
     
  5. RingofFire

    RingofFire New Member

    Code:
    [[email protected] ~]# ps aux | grep wconf
    root     23645  0.0  0.0   6516  1184 ?        S    May31   0:25 /bin/bash /root/ispconfig/sv/ispconfig_wconf
    root      5343  0.0  0.0   3904   608 pts/0    S+   Jun21   0:00 grep wconf
    
    Normal?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's how it's supposed to be.
    Do you get any error messages when you run
    Code:
    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    on the shell?
     
  7. RingofFire

    RingofFire New Member

  8. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's fine. I'm coming to my wit's end... :(
     
  9. RingofFire

    RingofFire New Member

    Isnt there any reason why ISPconfig wouldnt write dns config and ftp config?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The result in #47 means that the config has already been written or in other words, that there are no chnages pending to be written to the config files.

    Maybe the config has been written but to wrong locations. Which bind config directory is set in ispconfig under management > server > settings ?
     
  11. RingofFire

    RingofFire New Member

    Ok, after looking at this in more detail,

    ISPConfig IS writing new dns entries to /etc/named.conf, but for some reason bind isnt reading named.conf, its reading /var/named/chroot/etc/named.caching-nameserver.conf for config and named.rfc1912.zones in the same directory for dns entries.

    Setting ISPConfig to use named.rfc1912.zones as the named.conf file doesnt work, because it overwrites the top of the file with configuration data that causes named to crash.

    How do I change it so that its using /etc/named.conf like it should be for dns entries?

    Also, ISPConfig still isnt writing in new FTP users or email accounts.
     
    Last edited: Aug 11, 2007
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please reconfigure your nameserver as described in the perfect setup guide for your linux distribution.
     
  13. RingofFire

    RingofFire New Member

    Thats the problem, I followed the guide and its configured wrong. The guide just says to yum bind-chroot which I did and to chmod the directories for it to the right levels.

    The guide does not mention named.conf or any other config files, it says "ISPConfig will configure bind"
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    You posted above that your nameserver uses the file /var/named/chroot/etc/named.caching-nameserver.conf and thats definately not the file that is used when the named server is installed as described in the howto.

    Please run:

    yum install bind-chroot

    and post the output.
     

Share This Page