DNS issues with F15

Discussion in 'Installation/Configuration' started by Turbanator, Jul 19, 2011.

  1. Turbanator

    Turbanator Member HowtoForge Supporter

    I'm breaking down and asking for guidance.
    I have ISPC3 running just fine on Lenny and F13. I'm doing a Perfect Howto setup on F15 now and can't get any domain to work. Even if I ssh into the server and ping a domain, I get ping: unknown host www.kbcontract.com after about 10 sec. So strange. I like to think I know how to setup ISPC3 without problems but I'm lost now.

    I can reinstall from scratch, but I'd rather try to figure this out.

    Any guidance would be much appreciated.

    bind/named is running.
    domains and dns are setup.
    selinux and firewall disabled
    I can ping the server name remotely no problem.
    I can't ping any domain I setup remotely nor on the server itself.
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post your named.conf?
  3. Turbanator

    Turbanator Member HowtoForge Supporter


    // named.conf
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    options {
            listen-on port 53 {; };
            listen-on-v6 port 53 { ::1; };
            directory       "/var/named";
            dump-file       "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            memstatistics-file "/var/named/data/named_mem_stats.txt";
            allow-query     { localhost; };
            recursion yes;
            dnssec-enable yes;
            dnssec-validation yes;
            dnssec-lookaside auto;
            /* Path to ISC DLV key */
            bindkeys-file "/etc/named.iscdlv.key";
            managed-keys-directory "/var/named/dynamic";
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
    zone "." IN {
            type hint;
            file "named.ca";
    include "/etc/named.rfc1912.zones";
    include "/etc/named.root.key";
    include "/etc/named.conf.local";
    Last edited: Jul 20, 2011
  4. Turbanator

    Turbanator Member HowtoForge Supporter


    I decided to look back at my F13 box to see if I make any bind changes...I did the following and applied to F15...works like a charm now

    //      listen-on port 53 {; };
    listen-on { any; };
    //      allow-query     { localhost; };
    allow-query { any; };
    I don't really understand WHY...but it worked.

    Hope this helps others.
  5. Woodsman

    Woodsman New Member

    Thanks Turbanator
    This is exactly what I needed to fix my DNS issues...

    The Woodsman

Share This Page