DNS issues when setting up ISPConfig 3 for Intranet use

Discussion in 'Installation/Configuration' started by mick02, Apr 16, 2010.

  1. mick02

    mick02 New Member

    Good afternoon folks,

    I've got a dilemma on my hands. I want to set up ISPConfig on our company network so that I can host a number of websites. I've set up ISPConfig as per the instructions on this site however I'm having some problems accessing the sites that I have created.

    The server name is called intranet.mydomain.lan. The network already has a domain controller and DNS server (both on a Windows 2003 box). When I try to access intranet.mydomain.lan I get a page not found error. When I add the IP address of intranet to my LAN DNS server I receive the generic Apache index.html.

    I've added the IP address of my ISPConfig server to the nameservers entry on the windows DNS server but still nothing.

    Can anyone tell me how to get ISPConfig to play nice in a Windows domain?

    Thanks,
    Mick
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    For ispconfig it makes no difference if the server is in a intranet or not. Make sure that you created DNS A-Records in your dns server for every domain that you want to use as website in ispconfig. Then create the websites and select the internal IP addresses were the dns A-Records point to in the ispconfig website settings for this site.
     
  3. mick02

    mick02 New Member

    I understand Till however when I create the site intranet.mydomain.lan in ISPConfig and then add the A Record on the Windows DNS server to point intranet.mydomain.com to IP address 192.168.1.116 only the default apache index.html is displayed. It is as if the domain is resolved before it hits ISPConfig and as a result it only serves the default index.html.

    After making the changes I did a ipconfig /flushdns on my PC but that didn't make any difference.

    Any thoughts?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    AS I explained above, make sure that you selected IP 192.168.1.116 in the websites settings of this website in ispconfig and not *.
     
  5. yipi

    yipi New Member

    i can't select ip-address on web-domain,
    the option just "*" .

    i have configure DNS with dns-wizard.

    until now i can't ping my domain. :(
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You said that you use a external dns server and not the one from ispconfig, so why did you configure it then in ispconfig? You have to configure it in the dns server of your network.

    Then you missed to add the ip addresses in the ispconfig server settings.
     
  7. mick02

    mick02 New Member

    As stated below, the only option in ISPConfig is the *.
     
  8. yipi

    yipi New Member

    @mick02: im sorry use your thread for my problem,
    but it seems we have same problem. :)

    nop, i use ispconfig for dns server. :)

    :( sorry im newbie and my english is bad.
     
    Last edited: Apr 16, 2010
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Then read #6 again and do what I suggested to you there.
     
  10. moshion

    moshion New Member

    Intranet

    Hi
    I have a question about intranet and ispconfig.
    Can I have a domain called sampleserver.com and a subdomain, let's say, mydomain.sampleserver.com on the internet, and then have multiple subdomains only on the intranet?
    The point is to insert data in the intranet and some of that data be available in the internet, but both work on the same database.
    Thank you.
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

Share This Page