DNS issues on ISPConfig 3 on VPS

Discussion in 'Installation/Configuration' started by mdkberry, Sep 23, 2011.

  1. mdkberry

    mdkberry New Member

    Hi All

    just built ISPConfig 3 on Centos 5.6 - i386 on a VPS server. All running fine except seeing problems with DNS. Its a bit complicated to explain but so far it goes like this...

    the hostname is vps01.mbitservices.com.au the public ip address of my vps is 103.1.185.18

    I am hosting x3 sites on it , I own the domain names registered at Crazy Domains:

    mbitservices.com.au
    markberrymusic.com
    openheartliving.com

    I have added DNS zones into ISPConfig 3 for all the above and I am setting
    ns1.mbitservices.com.au with an A record : 103.1.185.18 on each site within ISPConfig 3. As the first name server and Crazy Domains relevant name server as the second NS.

    I have added the glue record ns1.mbitservices.com.au as ip 103.1.185.18 into Crazy domains for the site mbitservices.com.au

    mbitservices.com.au is working fine on the internet
    the other two are not

    even if I ping from a shell into my VPS I cannot ping those sites.
    and nslookup suggests the DNS is actually using the VPS hosts Name servers

    help!
    any suggestion
     
  2. CSsab

    CSsab New Member

    I think it might be as simple as adding A records for your name servers in both of these zones:

    markberrymusic.com
    openheartliving.com

    Give it a try.
     
  3. mdkberry

    mdkberry New Member

    getting stranger

    Hi CSsab

    thanks for the suggestion, it nearly worked, I am now able to access the sites using

    markberrymusic.com
    openheartliving.com

    but if I put www. in front of them it fails.

    lookups for both www. and without supposedly resolve to 103.1.185.18 , and I am pretty sure I have setup the ISPConfig 3 correctly according to the manual...

    I have the auto-subdomain set to 'www.' in the sites section
    I have the A records for both domains set for 'www' as well as MX records and everything that would normally be created using the domain zone wizard setup in ISPConfig 3 is set.

    any other ideas?

    Rgds
    Mark
     
  4. falko

    falko Super Moderator

    I'm getting no A records for both domains (with and without www):

    Code:
    mh1:~# dig markberrymusic.com
    
    ; <<>> DiG 9.3.4 <<>> markberrymusic.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 48695
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;markberrymusic.com.            IN      A
    
    ;; Query time: 280 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sat Sep 24 11:37:30 2011
    ;; MSG SIZE  rcvd: 36
    
    mh1:~# dig www.markberrymusic.com
    
    ; <<>> DiG 9.3.4 <<>> www.markberrymusic.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62504
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.markberrymusic.com.                IN      A
    
    ;; AUTHORITY SECTION:
    www.markberrymusic.com. 86400   IN      SOA     ns1.nameresolve.com. hostmaster.www.markberrymusic.com. 2011092400 16384 2048 1048576 2560
    
    ;; Query time: 183 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sat Sep 24 11:37:35 2011
    ;; MSG SIZE  rcvd: 103
    
    mh1:~# dig openheartliving.com
    
    ; <<>> DiG 9.3.4 <<>> openheartliving.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 35879
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;openheartliving.com.           IN      A
    
    ;; Query time: 291 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sat Sep 24 11:37:47 2011
    ;; MSG SIZE  rcvd: 37
    
    mh1:~# dig www.openheartliving.com
    
    ; <<>> DiG 9.3.4 <<>> www.openheartliving.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51460
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.openheartliving.com.       IN      A
    
    ;; AUTHORITY SECTION:
    www.openheartliving.com. 86400  IN      SOA     ns1.nameresolve.com. hostmaster.www.openheartliving.com. 2011092320 16384 2048 1048576 2560
    
    ;; Query time: 102 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sat Sep 24 11:37:51 2011
    ;; MSG SIZE  rcvd: 104
    
    mh1:~#
    Did you check your domains on www.intodns.com ?
     
  5. falko

    falko Super Moderator

    Just found this:
    Code:
    mh1:~# dig ns markberrymusic.com
    
    ; <<>> DiG 9.3.4 <<>> ns markberrymusic.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29695
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;markberrymusic.com.            IN      NS
    
    ;; ANSWER SECTION:
    markberrymusic.com.     86400   IN      NS      [COLOR="Red"]ns1.nameresolve.com[/COLOR].
    markberrymusic.com.     86400   IN      NS      ns1.mbitservices.com.au.
    
    ;; Query time: 343 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sat Sep 24 11:39:28 2011
    ;; MSG SIZE  rcvd: 103
    
    mh1:~# dig ns openheartliving.com
    
    ; <<>> DiG 9.3.4 <<>> ns openheartliving.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6606
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;openheartliving.com.           IN      NS
    
    ;; ANSWER SECTION:
    openheartliving.com.    86400   IN      NS      ns1.mbitservices.com.au.
    openheartliving.com.    86400   IN      NS      [COLOR="Red"]ns1.nameresolve.com[/COLOR].
    
    ;; Query time: 345 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sat Sep 24 11:39:40 2011
    ;; MSG SIZE  rcvd: 104
    
    mh1:~#
    Both not-working domains use ns1.nameresolve.com as one nameserver, while the working domain mbitservices.com.au uses ns1.mbitservices.com.au and ns2.mbitservices.com.au.
     
  6. mdkberry

    mdkberry New Member

    solved it !

    Hi

    Thanks Falko it put me onto a solution though I am not sure it is supposed to be done this way at least it works and everything is up and running.

    I basically have had to create a separate name server for each domain zone and then set that as the name server with a glue record for each domain back at Crazy domains.

    e.g. I have ns1.markberrymusic.com added into that domain zone on ISPConfig as an A record and as the primary name server, and then set it again as a glue record at crazy domains, and I have done this the same for each site I have on ISPconfig.

    I dont think this is how it is supposed to be set up but its working, I am still convinced something is wrong in the bind chroot DNS setup somewhere on my server but hell, if it works I dont much care

    thanks for the input. hopefully that will be it now and I can finally get some sleep.

    Mark
     
  7. falko

    falko Super Moderator

    Gald you got it working! :)

    Usually you just need two nameservers, e.g. ns1.example.com and ns2.example.com, where you host all your zones. No need to create new nameserver hostnames for each domain.
     
  8. mdkberry

    mdkberry New Member

    sorted !

    Hi

    its finally fixed. I dont know if it is really the solution but the solution came about after the following.

    putting two NS Servers records in the ISPConfig 3 DNS zones instead of just one ns server seemed to solve the problem.

    i.e. I now have ns1.mbitservices.com.au and ns2.mbitservices.com.au both set as
    my ISCconfig public ip address. And I add these as both ns servers for each site. entered both at the registrar for the site,
    and in ISPConfig and voila, all new sites work.

    thanks all
    M
     
    Last edited: Sep 29, 2011

Share This Page