DNS Issue with ISPConfig 3

Discussion in 'Installation/Configuration' started by asterinux, Feb 4, 2013.

  1. asterinux

    asterinux New Member

    Hi all,

    I managed to install ISPConfig 3 for the first time, and its also my first time to use ISPConfig, my dns(chrooted bind) is already configured, i can dig / nslookup records,.. but one thing I dont really get is that when i Add a Zone in ISPConfig Web Gui, it will be created in /var/named/chroot/var/named and the format of the file is eg: pri.mobile.domain.com, so it automatically created with a prefix of pri.,, can i configure ISPConfig not to add pri as prefix to my newly created zone file?... another thing after i create a zone file, do we need to manually include it to /etc/named.conf? ex: include /var/named/mobile.domain.com.


    Thanks in advance, :)
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No. ISPConfig will create the files with prefix and will also use this prefix in the named-conf-local file which conatains the zones and gets included in named.conf

    No. All you have to do is to include the named-conf-local file at the end of the name.conf file. If your server would have been empty (which is a requirement for the installation of ispconfig btw.) and installed as decribed in the perfects etup guide for ispconfig, then bind would have been setup correctly for the use with ispconfig automatically.
     
  3. asterinux

    asterinux New Member

    thank you for your quick response, this is now the last part of my /etc/named.conf file.

    PHP:
    include "/var/named/chroot/var/named/named.local";
    include 
    "/var/named/chroot/etc/named.conf.local";
    is this how it must be done?


    btw, i dont have any zone declared in my /etc/named.conf file, as i said when i create a zone in ISPConfig, it is created in /var/named/chroot/var/named ..
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If thats the file were ispconfig writes the zones in your installation, then its ok. You can freely configure this file in ispconfig under system > server config.
     
  5. asterinux

    asterinux New Member

    hi till, i already added a zone in mobile.domain.com, and added some test record.. but im unable to ping this record created.. heres my newly added zonefile..

    $TTL 3600
    @ IN SOA srv1.domain.com. admin.company.com. (
    2013020401 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;

    test 86400 A 192.168.245.120

    this file was in /var/named/chroot/var/named....
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The file is incomplete as you did not add all required records. Incomplete files are skipped by bind.

    Better use the dns wizard in ispconfig to add a zone as it will add required records like ns records automatically. If the ns records that you use for your zone are subdomains of the zone, then dont forget to add a-records for these subdomains as well.
     
  7. asterinux

    asterinux New Member

    It works!

    thanks for this till, i created another zone, now using with wizard... so records were created automatically for me.. now i can ping the record that i created.. thanks for your help till, :)


    Edit: Now, how am I gonna mark this thread solved? :D
     
    Last edited: Feb 5, 2013
  8. asterinux

    asterinux New Member

    Other system dont have named.conf.local

    hi, just a follow up question before this thread will be mark solved,


    In my other system with bind chroot installed, i didnt find any named.conf.local file, i want to include that file as what till said, is it on different location? thank you...

    Edit: I do find it on /etc/named.conf.local but whenever i include that file in named.conf, bind will error

    /etc/named.conf:71: open: /var/named/chroot/etc/named.conf.local: file not found .. any help please?? thanks..
     
    Last edited: Feb 5, 2013
  9. asterinux

    asterinux New Member

    Zone created not detected :(

    Update:

    what i did is that, i tried to symlink the file /etc/named.conf.local to /var/named/chroot/etc/named.conf.local

    PHP:
    ln /etc/named.conf.local /var/named/chroot/etc/

    then i add a zone in ISPConfig GUI, then restart named

    PHP:
    service named restart
    ... it fail, another error occured.

    PHP:
    service named restart
    Starting named

    Error in named configuration:
    zone localhost.localdomain/INloaded serial 0
    zone localhost
    /INloaded serial 0
    zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0
    .ip6.arpa/INloaded serial 0
    zone 1.0.0.127
    .in-addr.arpa/INloaded serial 0
    zone 0.in
    -addr.arpa/INloaded serial 0
    zone srv1
    .domain.com/INloaded serial 2013011004
    zone branch
    .srv1.domain.com/INloading from master file /var/named/chroot/var/named/pri.branch.srv1.domain.com failedfile not found
    zone branch
    .srv1.domain.com/INnot loaded due to errors.
    _default/branch.srv1.domain.com/INfile not found
                                                               
    [FAILED]
    .... am i doing it the wrong way? :(
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The setup supported by ispconfig is described in the perfect setup guide. If you use a different setup which is not supported like you did, then files can be missing or might have to be created manually.
     
  11. asterinux

    asterinux New Member

    hi till,

    may i know which part did i make it wrong? whenever i delete the zone in ISPConfig GUI and restart the named service, all errors went away.. but when i create a zone and restart named again, it will display an error "file not found".. thanks... i dont know how to proceed :(
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Install bind exactly as described in the perfects etup guide for the linux distrbution that you use before you install ispconfig. Dont change any config files if the changes are not described in the perfect setup, the guides comtain ecah required step and your server will work out of the box.
     
  13. asterinux

    asterinux New Member

    thanks till, i adjust the settings in System > Server Config > DNS
    and set the zone file directory to /var/named/data ... so i still include /etc/named.conf.local in /etc/named.conf file... and it works .. thanks again sir..:D
     

Share This Page