DNS help

Discussion in 'Installation/Configuration' started by ggohdin, Mar 16, 2009.

  1. ggohdin

    ggohdin New Member

    Hi, im prety sure this is a dns problem. anyways

    when I nslookup google.com as an example I get:

    Code:
    Server:         192.168.1.1
    Address:        192.168.1.1#53
    
    Non-authoritative answer:
    Name:   google.com
    Address: 74.125.67.100
    Name:   google.com
    Address: 74.125.45.100
    Name:   google.com
    Address: 209.85.171.100
    
    When I use dig `hostname` i get:
    Code:
    ; <<>> DiG 9.5.1-P1 <<>> server1.agama.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 45167
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server1.agama.com.             IN      A
    
    ;; AUTHORITY SECTION:
    agama.com.              7249    IN      SOA     ns1.gldn.net. dnsmaster.gldn.net. 2005122700 10800 3600 3600000 86400
    
    ;; Query time: 52 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Mon Mar 16 15:55:46 2009
    ;; MSG SIZE  rcvd: 93
    
    Now the weird thing is ns1.gldn.net is deffinatly not my ns1, I donno where its even from.

    But if I change my resolv.conf file from ip 192.168.1.1(gateway ip) to 192.168.1.4(server ip)

    I get this when I use "dig `hostname`:

    Code:
    ; <<>> DiG 9.5.1-P1 <<>> server1.agama.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 45982
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;; WARNING: recursion requested but not available
    
    ;; QUESTION SECTION:
    ;server1.agama.com.             IN      A
    
    ;; AUTHORITY SECTION:
    agama.com.              86400   IN      SOA     ns1.agama.com. webmaster.agama.com. 2009031623 28800 7200 604800 86400
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.4#53(192.168.1.4)
    ;; WHEN: Mon Mar 16 15:58:32 2009
    ;; MSG SIZE  rcvd: 85
    
    which has my correct ns1. but then if i use nslookup on google.com again with the changed resolv.conf file nothing happens:

    Code:
    Server:         192.168.1.4
    Address:        192.168.1.4#53
    
    ** server can't find google.com: NXDOMAIN
    
    any ideas on what could be going on? cheers.
     
  2. ggohdin

    ggohdin New Member

    Ok so after spending 8 hours reading around the net and this forum. I have put my ISP's nameservers ip addresses in my resolv.conf and removed 192.168.1.1 (my gateway ip).

    resolv.conf
    Code:
    search agama.com
    nameserver 203.109.129.67
    nameserver 203.109.129.68
    
    When I use "dig @localhost ns agama.com" i get:

    Code:
    ; (2 servers found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44127
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    ;; WARNING: recursion requested but not available
    
    ;; QUESTION SECTION:
    ;agama.com.                     IN      NS
    
    ;; ANSWER SECTION:
    agama.com.              86400   IN      NS      ns1.agama.com.
    agama.com.              86400   IN      NS      ns2.agama.com.
    
    ;; ADDITIONAL SECTION:
    ns1.agama.com.          86400   IN      A       123.123.123.123
    
    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Mar 16 20:09:46 2009
    ;; MSG SIZE  rcvd: 79
    
    which is correct, but if i go "dig `hostname`" i get:
    Code:
    ; <<>> DiG 9.5.1-P1 <<>> server1.agama.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 15603
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server1.agama.com.             IN      A
    
    ;; AUTHORITY SECTION:
    agama.com.              10800   IN      SOA     ns1.gldn.net. dnsmaster.gldn.net. 2005122700 10800 3600 3600000 86400
    
    ;; Query time: 379 msec
    ;; SERVER: 203.109.129.67#53(203.109.129.67)
    ;; WHEN: Mon Mar 16 20:10:34 2009
    ;; MSG SIZE  rcvd: 93
    
    and when i nslookup google.com i get:

    Code:
    Server:         203.109.129.67
    Address:        203.109.129.67#53
    
    Non-authoritative answer:
    Name:   google.com
    Address: 74.125.45.100
    Name:   google.com
    Address: 209.85.171.100
    Name:   google.com
    Address: 74.125.67.100
    
    which is ok

    "ns1.gldn.com" is deffinatly the nameservers of the actual domain name ww.agama.com which is not associated to me at all. how do i get this to display my own nameservers e.g "ns1.agama.com" if i use 1.92.168.1.4(server ip) in my resolv.conf file it will work but then i cannot nslookup anything.

    Any advice or just to ignore this would be a bit help

    thank you.
     
    Last edited: Mar 16, 2009
  3. falko

    falko Super Moderator ISPConfig Developer

  4. chipsafts

    chipsafts New Member

    are you looking at setting up a seperate internal and external
    dns zones setup?
     
  5. ggohdin

    ggohdin New Member

    Hey, I am pretty confused. I just want it so people can view websites off my server. I know i had a dns problem but I have configured my DNS and hopefully this looks right

    when I "dig @localhost agama.co.nz" which will be the website address, i get:

    Code:
    ; <<>> DiG 9.5.1-P1 <<>> @localhost agama.co.nz
    ; (2 servers found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5096
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    ;; WARNING: recursion requested but not available
    
    ;; QUESTION SECTION:
    ;agama.co.nz.                   IN      A
    
    ;; ANSWER SECTION:
    agama.co.nz.            86400   IN      A       123.123.123.123
    
    ;; AUTHORITY SECTION:
    agama.co.nz.            86400   IN      NS      ns1.ggohdin.com.
    agama.co.nz.            86400   IN      NS      ns2.ggohdin.com.
    
    ;; ADDITIONAL SECTION:
    ns1.ggohdin.com.        86400   IN      A       123.123.123.123
    ns2.ggohdin.com.        86400   IN      A       123.123.123.123
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Mar 17 15:10:16 2009
    ;; MSG SIZE  rcvd: 124
    
    
    (ip 123.123.123.123 is just untill my isp sets up my static ip)

    when i nslookup google.com i get:
    Code:
    Server:         203.109.129.67
    Address:        203.109.129.67#53
    
    Non-authoritative answer:
    Name:   google.com
    Address: 209.85.171.100
    Name:   google.com
    Address: 74.125.67.100
    Name:   google.com
    Address: 74.125.45.100
    
    which is right.

    but when I dig "dig `hostname`" i still get:
    Code:
    ; <<>> DiG 9.5.1-P1 <<>> server1.agama.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 18556
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server1.agama.com.             IN      A
    
    ;; AUTHORITY SECTION:
    agama.com.              10800   IN      SOA     ns1.gldn.net. dnsmaster.gldn.net. 2005122700 10800 3600 3600000 86400
    
    ;; Query time: 385 msec
    ;; SERVER: 203.109.129.67#53(203.109.129.67)
    ;; WHEN: Tue Mar 17 15:38:16 2009
    ;; MSG SIZE  rcvd: 93
    
    Is this a DNS glue problem? I know that ns1.gldn.net is owned by a webhosting company that hosts the web address "www.agama.com".

    how can I get my server name to stop been confused with agama.com?

    also eventually I want to get my server (192.168.1.4) accessible from other computers not on this lan, could they just type my wan ip address with :8080?
     
  6. ggohdin

    ggohdin New Member

    netstat -tap if it helps

    Code:
    server1:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      2176/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      5548/master
    tcp        0      0 localhost.localdoma:649 *:*                     LISTEN      3017/famd
    tcp        0      0 *:mysql                 *:*                     LISTEN      2240/mysqld
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      2332/spamd.pid
    tcp        0      0 *:sunrpc                *:*                     LISTEN      1930/portmap
    tcp        0      0 *:54835                 *:*                     LISTEN      1941/rpc.statd
    tcp        0      0 *:ftp                   *:*                     LISTEN      2983/pure-ftpd (SER
    tcp        0      0 server1.agama.co:domain *:*                     LISTEN      2894/mydns
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      2894/mydns
    tcp        0      0 *:ssh                   *:*                     LISTEN      2147/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN      5548/master
    tcp        0    248 server1.agama.com:ssh   192.168.2.2:3724        ESTABLISHED 3099/sshd: administ
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      2871/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      2889/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      2877/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      2854/couriertcpd
    tcp6       0      0 [::]:http-alt           [::]:*                  LISTEN      3085/apache2
    tcp6       0      0 [::]:www                [::]:*                  LISTEN      3085/apache2
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      2983/pure-ftpd (SER
    tcp6       0      0 localhost:domain        [::]:*                  LISTEN      2894/mydns
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2147/sshd
    tcp6       0      0 [::]:https              [::]:*                  LISTEN      3085/apache2
    
    I have been going on 4 days straight, wondering whats happening, maybe I will reinstall and change my hostname.
     
  7. Flash

    Flash New Member

    You need to change the SOA record of your domain. the name server that is displayed is in that record.

    agama.com. 10800 IN SOA ns1.gldn.net. dnsmaster.gldn.net. 2005122700 10800 3600 3600000 86400

    Also dnsmaster.gldn.net which is the email adres [email protected] should probably replaced by something you use.

    IF this is a hosted domain by a hosting company, ns1.gldn.net might actually be their name server which is coming from their config. and you might not be able to change that.
     
  8. ggohdin

    ggohdin New Member

    Hi, I changed the hostname to "newt72.net" when I dig `hostname` now, I get this:

    Code:
    ; <<>> DiG 9.5.1-P1 <<>> server1.newt72.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 38599
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server1.newt72.net.            IN      A
    
    ;; AUTHORITY SECTION:
    net.                    851     IN      SOA     a.gtld-servers.net. nstld.verisign-grs.com. 1237370564 1800 900 604800 900
    
    ;; Query time: 54 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Wed Mar 18 23:03:51 2009
    ;; MSG SIZE  rcvd: 109
    
    those are not my zones, how do I change zones for hostname?

    cheers
     
  9. Flash

    Flash New Member

    A few questions.

    1. is newt72.net your domain (eg. did you register that domain) ?
    2. are you running a local DNS server with the domain newt72.net in a zone?
    3. if 1 or 2 is yes, do you have a entry in the DNS zone for server1 ?
     
  10. ggohdin

    ggohdin New Member

    Hi, thanks for gettign back to me, I think I have gottect really confused. My hostname for my server is server1 when I type dig `hostname` it resolves to my servers domain (newt72.net), but it doesnt show any of the nameservers it just comes up with the zone for .net.

    but I can ping server1 and newt72.net.

    If I type " dig @localhost ns newt72.net" everything resolves perfectly.

    so im not to sure what I have done.

    But If i change my resolv.conf nameserver to my servers ip "192.168.1.4", then when i use dig `hostname` it works, but I know that that ip address connot be there.
     
    Last edited: Mar 18, 2009
  11. falko

    falko Super Moderator ISPConfig Developer

  12. Flash

    Flash New Member

    dig actually uses your /etc/hosts file if im correct to query first. you might have an entry there for that name.
     
  13. ggohdin

    ggohdin New Member

    Hey, thanks for the reply. I checked that and that name links to the internal IP of my server, so that shouldent be a problem where when I dig hostname it should get newt72.net at ip 192.168.1.4 then bring up the server info.

    am I right?
     
  14. falko

    falko Super Moderator ISPConfig Developer

    I tried www.intodns.com with newt72.net, and I get "Can't get nameservers at parent server!<br>I only check domains not subdomains!"

    Is newt72.net a registered domain?
     
  15. ggohdin

    ggohdin New Member

    Hi, i think i confused myself as well as you, lol. Ill try some stuff this week and see what happens and ill post back with my findings. Mail server part of the server works though as well as ftp (local only so far).
     

Share This Page