DNS Failure returned to network-tools.com

Discussion in 'Installation/Configuration' started by DantePasquale, Nov 17, 2009.

  1. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Hi All,

    I configured Register.com to point to my dns server (ISPConfig) and now I'm having problems resolving from outside my network. Various external tools return DNS FAILURE -- but no information. The only thing I see locally is that:
    Code:
    dig @74.1.46.166 www.cocoanet.us
    
    ; <<>> DiG 9.5.1-P2 <<>> @74.1.46.166 www.cocoanet.us
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27409
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    ;; [B]WARNING: recursion requested but not available
    [/B]
    ;; QUESTION SECTION:
    ;www.cocoanet.us.		IN	A
    
    ;; ANSWER SECTION:
    www.cocoanet.us.	86400	IN	A	74.1.46.163
    
    ;; Query time: 12 msec
    ;; SERVER: 74.1.46.166#53(74.1.46.166)
    ;; WHEN: Mon Nov 16 22:11:41 2009
    ;; MSG SIZE  rcvd: 49

    Here's the mydnsexport for one of the domains in question:

    mydnsexport:

    Code:
    $TTL 86400
    ; Zone: cocoanet.us. (#1)
    ; Created by "mydnsexport"
    ; Mon Nov 16 22:05:34 2009
    $ORIGIN cocoanet.us.
    
    @	IN SOA	ns1.cocoanet.us.	webadmin.cocoanet.us. (
    	2009111608	  ; Serial
    	28800     	  ; Refresh
    	7200      	  ; Retry
    	604800    	  ; Expire
    	86400     	) ; Minimum
    
    cocoanet.us 	86400	IN MX   	10 www.cocoanet.us.
    cocoanet.us 	86400	IN TXT  	"v=spf1 a mx ptr ~all"
    inferno     	86400	IN A    	74.1.46.162
    mail        	86400	IN CNAME	www.cocoanet.us.
    ns1         	86400	IN A    	74.1.46.168
    ns2         	86400	IN A    	74.1.46.166
    www         	86400	IN A    	74.1.46.163
    OK, I found this link that says that MX records don't work with CNAME entries, so I removed the CNAME entries, and MX record still doesn't work. http://mydns.bboy.net/faq/#11

    I also added a recursion directive in the /etc/mydns.conf and pointed that to one of my network providers DNS servers. That helped on the local lookups, but I still didn't get any incoming e-mails or any incoming http requests because resolution wasn't happening outside of my network.

    Any ideas???
     
    Last edited: Nov 17, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You missed to add the dot at the end of cocoanet.us in the mx records. By the way, if you use the dns wizard to create the dns records the next time, you can be sure that all nescessary subrecords get created properly.
     
  3. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Till, I did use the DNS wizard to create the entries. No hand editing :( So the record should look like:

    Code:
    cocoanet.us.   86400	IN MX   	10 www.cocoanet.us
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The record must have a dot at the end in the ispconfig interface.

    The record can not have been created with the wizrad as the MX record created by the wizard never points to a www.... subdomain. It always points to a mail... subdomain.

    I suggest you delete the record and recreate it with the wizard and use the default template that comes with ispconfig to create it.
     
  5. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Not to give you a hard time, but I'm not getting this. I did indeed use the Control Panel DNS wizard, but I'll delete and recreate. Here's what I input:
    Code:
    Hostname:                          cocoanet.us
    Mail Server Name:             mail
    
    But that still looks weird, for one, I don't have an A record for mail.cocoanet.us, I had a CNAME, but that's what I removed.

    Here's the mydnsexport:
    Code:
    mydnsexport cocoanet.us
    $TTL 86400
    ; Zone: cocoanet.us. (#1)
    ; Created by "mydnsexport cocoanet.us"
    ; Tue Nov 17 10:05:30 2009
    $ORIGIN cocoanet.us.
    
    @       IN SOA  ns1.cocoanet.us.        webadmin.cocoanet.us. (
            2009111704        ; Serial
            28800             ; Refresh
            7200              ; Retry
            604800            ; Expire
            86400           ) ; Minimum
    
    cocoanet.us     86400   IN MX           10 mail.cocoanet.us.
    cocoanet.us     86400   IN TXT          "v=spf1 a mx ptr ~all"
    inferno         86400   IN A            74.1.46.162
    ns1             86400   IN A            74.1.46.168
    ns2             86400   IN A            74.1.46.166
    www             86400   IN A            74.1.46.163
    
    What values should I input into the DNS MX Form?

    Also, I hate to be a pain, but could you run:
    Code:
    dig @74.1.46.166 www.cocoanet.us
    As I don't think the request is actually getting to my server through the network provider.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You use the wrong dig query for MX records. The correct query to get the MX record is:

    dig MX @localhost cocoanet.us

    to check your local dns server.
     
  7. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Thnks. Got things better: I had to put the dot at the end, I guess form didn't put it there for MX or TXT records.

    Code:
    mydnsexport cocoanet.us
    $TTL 86400
    ; Zone: cocoanet.us. (#1)
    ; Created by "mydnsexport cocoanet.us"
    ; Tue Nov 17 10:24:15 2009
    $ORIGIN cocoanet.us.
    
    @       IN SOA  ns1.cocoanet.us.        webadmin.cocoanet.us. (
            2009111710        ; Serial
            28800             ; Refresh
            7200              ; Retry
            604800            ; Expire
            86400           ) ; Minimum
    
    cocoanet.us.    86400   IN MX           10 www.cocoanet.us.
    cocoanet.us.    86400   IN TXT          "v=spf1 a mx ptr ~all"
    inferno         86400   IN A            74.1.46.162
    ns1             86400   IN A            74.1.46.168
    ns2             86400   IN A            74.1.46.166
    www             86400   IN A            74.1.46.163
    
    I've found that both formats work for dig, maybe that's HP-UX or Solaris, tho. I work on those most of the time.

    Anyway, My reason for asking about the dig, is that when I run this from my office, it times out. DNS to my server may be blocked here (I don't run the Firewall servers here). Can you try this for me?
     
    Last edited: Nov 17, 2009
  8. falko

    falko Super Moderator ISPConfig Developer

    This is what I get:

    Code:
    mh1:~# dig @74.1.46.166 www.cocoanet.us
    
    ; <<>> DiG 9.3.4 <<>> @74.1.46.166 www.cocoanet.us
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19893
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.cocoanet.us.               IN      A
    
    ;; ANSWER SECTION:
    www.cocoanet.us.        86400   IN      A       74.1.46.163
    
    ;; Query time: 145 msec
    ;; SERVER: 74.1.46.166#53(74.1.46.166)
    ;; WHEN: Wed Nov 18 14:26:02 2009
    ;; MSG SIZE  rcvd: 49
    
    mh1:~#
     

Share This Page