DNS errors with checking on dnsreport

Discussion in 'Server Operation' started by sajo, Nov 15, 2006.

  1. sajo

    sajo New Member

    I dont know anymore what to do. I read traditionaly how to for DNS I read a lot on this forum and everything looks OK in my configuration files and in pri files. But when I check my DNS on dnsreport.com I keep getting this errors.

    I attached print screen, its bad quality but can be seen what is wrong.

    Can anybody help me about this
     

    Attached Files:

    • dns1.JPG
      dns1.JPG
      File size:
      85.2 KB
      Views:
      230
  2. falko

    falko Super Moderator ISPConfig Developer

    Please post your domain name here so that I can check it.
     
  3. sajo

    sajo New Member

    Oh yes.. shame on me I forgot

    sajko.biz

    Well I try all the time something and I almost did it but only with manualy changing the pri.sajko.biz
    I just dont get it how to do it thrue ISPConfig.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    As far as I can tell everything is ok:

    Code:
    mh1:~# dig sajko.biz
    
    ; <<>> DiG 9.2.1 <<>> sajko.biz
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19272
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;sajko.biz.                     IN      A
    
    ;; ANSWER SECTION:
    sajko.biz.              86400   IN      A       193.77.152.144
    
    ;; Query time: 135 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Nov 17 15:15:28 2006
    ;; MSG SIZE  rcvd: 43
    
    mh1:~# dig ns sajko.biz
    
    ; <<>> DiG 9.2.1 <<>> ns sajko.biz
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20162
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;sajko.biz.                     IN      NS
    
    ;; ANSWER SECTION:
    sajko.biz.              86395   IN      NS      ns2.sajko.biz.
    sajko.biz.              86395   IN      NS      ns1.sajko.biz.
    
    ;; Query time: 2 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Nov 17 15:15:33 2006
    ;; MSG SIZE  rcvd: 63
    
    mh1:~# dig ns1.sajko.biz
    
    ; <<>> DiG 9.2.1 <<>> ns1.sajko.biz
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17255
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;ns1.sajko.biz.                 IN      A
    
    ;; ANSWER SECTION:
    ns1.sajko.biz.          86400   IN      A       193.77.152.144
    
    ;; Query time: 71 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Nov 17 15:15:41 2006
    ;; MSG SIZE  rcvd: 47
    
    mh1:~# dig ns2.sajko.biz
    
    ; <<>> DiG 9.2.1 <<>> ns2.sajko.biz
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24154
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;ns2.sajko.biz.                 IN      A
    
    ;; ANSWER SECTION:
    ns2.sajko.biz.          86400   IN      A       193.77.152.144
    
    ;; Query time: 89 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Nov 17 15:15:46 2006
    ;; MSG SIZE  rcvd: 47
    
    mh1:~# dig mx sajko.biz
    
    ; <<>> DiG 9.2.1 <<>> mx sajko.biz
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5664
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;sajko.biz.                     IN      MX
    
    ;; ANSWER SECTION:
    sajko.biz.              86400   IN      MX      10 server.sajko.biz.
    
    ;; Query time: 122 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Nov 17 15:15:55 2006
    ;; MSG SIZE  rcvd: 50
    
    mh1:~# dig server.sajko.biz
    
    ; <<>> DiG 9.2.1 <<>> server.sajko.biz
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57965
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server.sajko.biz.              IN      A
    
    ;; ANSWER SECTION:
    server.sajko.biz.       86391   IN      A       193.77.152.144
    
    ;; Query time: 3 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Nov 17 15:16:04 2006
    ;; MSG SIZE  rcvd: 50
    What's in pri.sajko.biz?
     
  5. sajo

    sajo New Member

    I dont know why but I have to manualy write www A point

    Code:
    $TTL        86400
    @       IN      SOA     ns1.sajko.biz. admin.sajko.com. (
                            2006111702       ; serial, todays date + todays serial #
                            28800              ; refresh, seconds
                            7200              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ;
                    NS      ns1.sajko.biz.              ; Inet Address of name server 1
                    NS      ns2.sajko.biz.              ; Inet Address of name server 2
    
    ;
    
      MX      10 server.sajko.biz.
    mail  MX      10 server.sajko.biz.
    
    sajko.biz.      A        193.77.152.144
    sajko.biz       A       193.77.152.144
    ns1       A       193.77.152.144
    ns2       A       193.77.152.144
    server       A       193.77.152.144
    mail       A       193.77.152.144
    www      A    193.77.152.144
    
    sajko.biz.       TXT  "v=spf1 a ptr ?all"
    
    ;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
    

    And this is named.conf
    I add recursion no; but there is a problem because each time when I modifie something about DNS in ISPConfig every time I have to rewrite this line. And this line is because I got this alarm and I read how to repair wit adding this recursion no; line

    Code:
    options {
            pid-file "/var/run/bind/run/named.pid";
            directory "/etc/bind";
            auth-nxdomain no;
            recursion no;
            /*
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
             */
            // query-source address * port 53;
    };
    
    //
    // a caching only nameserver config
    //
    zone "." {
            type hint;
            file "db.root";
    };
    
    zone "0.0.127.in-addr.arpa" {
            type master;
            file "db.local";
    };
    
    zone "1.168.192.in-addr.arpa" {
            type master;
            file "pri.1.168.192.in-addr.arpa";
    };
    zone "152.77.193.in-addr.arpa" {
            type master;
            file "pri.152.77.193.in-addr.arpa";
    };
    
    
    zone "izbrani.com" {
            type master;
            file "pri.izbrani.com";
    };
    zone "sajko.biz" {
            type master;
            file "pri.sajko.biz";
    };
    zone "sajko.com" {
            type master;
            file "pri.sajko.com";
    };
    zone "zmks.com" {
            type master;
            file "pri.zmks.com";
    };
    zone "mkrokovnjaci.com" {
            type master;
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Which record do you have to rewrite?

    You must add that line to the named.conf template /root/ispconfig/isp/conf/named.conf.master.
     
  7. sajo

    sajo New Member

    Thanks for that info. I put it in named.conf.master and now its there every time I change something.

    Thanks

    Do you know anything about reverse dns error I cant fixed.

    Well that must be something with my miscunfiguration so dont wory about this.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    You must ask your ISP who gave you the IP address to create a correct reverse DNS record for you.
     
  9. sajo

    sajo New Member

    Thanks Falko I'll do that.
     

Share This Page