¿DNS email configuration problem?

Discussion in 'Installation/Configuration' started by spanish, Dec 12, 2009.

  1. spanish

    spanish HowtoForge Supporter

    Hello,

    I have problems with email reception. I think it is a DNS problem, but I'm not sure about it and how solve the problem.

    I have installed ISPConfig3 in a OpenVZ virtual machine (Debian Lenny minimal template).

    Failure notice:

    Hi. This is the qmail-send program at ns1.otherdomain.org.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <mail@mydomain.org>:
    Sorry, I couldn't find a mail exchanger or IP address. (#5.4.4)

    This is my configuration:

    -------------------------------------------------------------

    1.- My hostname

    # hostname
    server1.mydomain.org

    # hostname -f
    server1.mydomain.org

    -------------------------------------------------------------

    2.- My IP (Fail Over)

    111.222.333.444

    -------------------------------------------------------------

    3.- DNS records in my ISP provider (OVH):

    mydomain.org DNS

    DNS server name DNS server IP
    ns1.mydomain.org 111.222.333.444
    ns2.mydomain.org 111.222.333.444
    server1.mydomain.org 111.222.333.444
    ns.kimsufi.com -

    -------------------------------------------------------------

    4.- DNS Zone and Records
    Like http://www.howtoforge.com/forums/showpost.php?p=146326&postcount=8

    DNS Zone
    Server: Server 1
    Client: -
    Zone (SOA): mydomain.org.
    NS: ns1.mydomain.org.
    Email: admin.mydomain.org.
    ...

    Records
    A mail 111.222.333.444 0
    A mydomain.org. 111.222.333.444 0
    A ns1 111.222.333.444 0
    A www 111.222.333.444 0
    MX mydomain.org. mail.mydomain.org. 10
    NS mydomain.org. ns1.mydomain.org. 0
    NS mydomain.org. ns2.mydomain.org. 0

    -------------------------------------------------------------

    5.- Mail Domain

    Server: Server 1
    Client: Client 1
    Domain: mydomain.org
    Spamfilter: Normal
    Active: Yes

    -------------------------------------------------------------

    If I change the Mail Domain to mail.mydomain.org, I can send and receive email in mail@mail.mydomain.org.

    But if I change the Mail Domain to mydomain.org, I can't receive email in mail@mydomain.org.

    Any idea?

    Thanks,

    Manuel
     
  2. spanish

    spanish HowtoForge Supporter

    Solved

    Now, the email (send and receive) is working correctly (DNS propagation, I suppose).

    OK. I'm grateful for your work.

    I will be a subscriber!

    :)

    Thanks and cordial greetings,

    Manuel
     

Share This Page