DNS does not work

Discussion in 'Installation/Configuration' started by EdjeB, Apr 7, 2011.

  1. EdjeB

    EdjeB New Member

    Hi,

    I use The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3] setup. At one point everything worked. Now, all of a sudden dns does not. I have several several dns zones and multiple sites using a couple of ip-addresses on a single server. Lately i did updates, upgrades, dist-upgrades. Now there is only one site (on the first ip) and subdomains from that sites that works. This is really frustrating.
    I want to break down to where the issue is. So i have a couple of questions:
    - What logs can i tail to see any errors that pop up when trying to browse the non working sites?
    - how do i know if the database content, concerning dns and the zone files are ok?
    - how do i determine if this is dns on the box or external, like my registrar of dns propagation?
    - is there a good dns troubleshoot how to somewhere that'll get me in the right direction?

    please help me out to get the other domains back in the air asap. thanks in advance for any effort.

    Kind regards,
    Ed
     
  2. till

    till Super Moderator

    Restart bind and then take a look at the syslog to see which error bind has added there.
     
  3. EdjeB

    EdjeB New Member

    Solved

    Hi,

    thanks. I have it solved. The problem was that the additional ip-addresses that i configured in interfaces where not bound to the nic. a restart fixed that.

    Kind regards,
    Ed.
     

Share This Page